Failed installing 'openhab-package-standard': No matching features for openhab-package-standard/0

Started after upgrading 2.4 to 2.5

I tried deleting the addons.cfg file but that did not resolve the error. Any ideas?

Check /var/lib/openhab2/config/org/openhab/addons.config make sure everything looks correct. Here are the binding changes for OH 2.5 that may be causing the issue?

Discontinued Add-ons

Azure IoT

Due to changes in the Azure API, this add-on is no longer working and has been removed.

Sen.se Persistence Service

The Sen.se service has been discontinued, therefore there is no longer any use of this openHAB persistence service. It has thus be removed from the distribution.

Breaking Changes in Add-ons

DarkSky Binding

The item type of ‘rain’ and ‘snow’ channels have been changed to ‘Number:Speed’.

EnOcean Binding

Channel ‘receivingState’ has been removed, because this was a string containing many information. For this, there are three new channels: ‘rssi’, ‘repeatCount’ and ‘lastReceived’.

Homekit

Some tags have been renamed. Old names will not be supported in future versions. Please check documentation.

LGWebOS Binding

The binding parameter ‘localIP’ has been removed. The binding now uses system defaults for network communication. The thing type parameter ‘deviceId’ is no longer a parameter, but a property. Parameters ‘host’ and ‘key’ have been added.

MQTT Binding

Homie channel names may have changed if special characters are used for MQTT topic names.

OneWire Binding

The thing types ms-th and ms-tv have been marked deprecated and will be updated to ms-tx automatically.
The thing types counter2 , digitalio , digitalio2 , digitalio8 , ibutton , temperature have been marked deprecated and will be updated to basic automatically.

Please note that auto-upgraded things keep their thing UID including the deprecated thing type .

Manually (via textual configuration) defined things need to be changed to ms-tx or basic respectively.

Deprecated thing types will be removed with the next official release.

OpenSprinkler Binding

The stationXX channels have been removed and replaced by a bridge/thing combination. See documentation for further information.

OpenSprinkler Binding

The Pi interface was removed, as it does not provide all of the features of the binding anymore. Please use the HTTP interface instead.

senseBox Binding

The senseBox binding is now using Units of Measurements, and the channel name for Illuminance has changed. The Items must be reconfigured.

Somfytahoma Binding

The following channels have been renamed: ‘cyclic_button_state’ to ‘cyclic_button’, ‘battery_status_state’ to ‘battery_status’ and ‘lighting_led_pod_mod_state’ to ‘lighting_led_pod_mode’.

Systeminfo Binding

The ‘cpu#load’ channel has been removed because the OSHI library no longer provides this information.

TP-Link Smart Home Binding

The energy and rssi channels are now using Units of Measurements. Items must be adapted and the things must be recreated.

Tesla Binding

The binding has been heavily refactored. It is required to delete old Tesla Things and set them up from scratch.

Vitotronic Binding

The following channels have been renamed: ‘outsite_temp’ to ‘outside_temp’, ‘pelletburner:power’ to ‘pelletburner:powerlevel’, ‘party_temp’ to ‘party_temp_setpoint’ and ‘save_temp’ to ‘save_temp_setpoint’

Since, by default, everything in there is commented out, how did you think deleting a file OH expects to be present would resolve anything with out causing further issues? Commenting out any uncommented entries or leaving a blank file there would have made mush more sense logically.

I saw it suggested in a few old posts…

This is the contents. Only the MQTT and astro bindings enabled.

/var/lib/openhab2/config/org/openhab/addons.config


:org.apache.felix.configadmin.revision:=L"8"
binding="mqtt,astro"
misc="ruleengine"
package="standard"
service.pid="org.openhab.addons"
ui="basic,paper,habpanel,homebuilder"

That looks like an addons.config file, not addons.cfg I believe that OH recreates the addons.config file if it is missing.
The addons.cfg file is where you would manually tell OH to onstall addons.

From /var/lib/openhab2/config/org/openhab/addons.config

I removed package=“standard” and the error is now gone after a restart…

It is now gone? Great, assuming it functions normally.
I just checked my recently installed test system and see the package line.

:org.apache.felix.configadmin.revision:=L"3"
binding="zwave"
package="standard"
service.pid="org.openhab.addons"

If the OP rechecks the file I’m sure it will have “standard” listed, unless he manually changed it in addons.cfg.

Something during the upgrade was missing (log tells the issue) for that package and by removing it from addons.config and restarting it was loaded correctly.

1 Like

You are assuming "no == “now” and not “no” == “not”.

no is now … corrected

1 Like