Failed Openhabian Upgrade

  • Platform information:
    • Hardware: Raspberry Pi 4
    • OS: Openhabian
    • Java Runtime Environment: Unknown
    • openHAB version: 3.1

I attempted to perform an update of my Openhabian instance last night via the openhabian-config dialog. I first ran the updater, which was prompted before anything else, then attempted the “update everything” option (apologies, I don’t remember the exact nomenclature used). After some time, this second updater said that there was an error and it had failed to update. I tried again and was more-quickly met with the same message. Thinking nothing of it, I decided to reboot and try again. Unfortunately, the Pi now fails to boot. The green light flashes 4x and nothing more happens. Looking elsewhere, it appears the loader.bin file is possibly corrupted and missing. Could anyone point me to a known-good copy of this file that I could replace on the SD card and, if nothing more, backup my configuration and start over with a fresh install?

Alternatively - is there a way to recover my current install config from the SD card and copy it over to a fresh install?

Well, the issue was definitely with the SD card - I was able to copy over most everything from the old one but it disconnected and crashed a LOT.
Can anyone point me to the file locations of my personal config items so I can bring them over to a new installation?

your config is stored in
/etc/openhab
/var/lib/openhab

btw, you can install the image also an SSD drives which are more reliable.

Thank you for the reply and suggestion!