Failed to Install http1

When I install the HTTP binding from PaperUI I get the following error:

Failed installing 'openhab-binding-http1': Unable to resolve osgi.identity; type="osgi.bundle"; version:Version=""; osgi.identity="org.openhab.core.automation.module.script.rulesupport": missing requirement osgi.wiring.package; filter:="(osgi.wiring.package=org.openhab.core.automation.module.script.rulesupport.shared.simple)"

Do I need to install something else for this binding to work properly?

  • Platform information:
    • Hardware: Intel with Windows 10
    • openHAB version: 2.5.2 stable release

Have you enabled legacy binding support?

Yes, legacy support is enabled. I tried it enabled and disabled and got the same result.

I just realized I’m running a corrected version of “org.openhab.core.automation.module.script.rulesupport” to fix the rule loading issue on Windows. I wonder if that is causing the issue? @5iver

Seems to be related… in the console, what is returned for this?

list -s |grep rulesupport

I’m thinking you make have cleared the cache and the original bundle popped up again, so you may need to uninstall it again. I’ll fire up my Windows VM and install http1.

It returns:
303 | Active | 80 | | org.openhab.core.automation.module.script.rulesupport

OK… I received the same error. So, remove the updated rulesupport bundle from /addons/ and install the http1 binding or wait for it to try to install again. After it installs, follow the steps again for adding in the updated bundle.

That seemed to do the trick. Thanks Scott!


1 Like

Please mark the topic solved by clicking the square box on the post that provided the solution.