Failing to install openhabian using wifi

  • Hardware: rasp pi zero 2w (I know this is not reccomended but wifi shouldn’t be the problem right)
  • Issue of the topic: I’ve been trying to install openhabian using the wifi setup with config changes below. I’ve tried ipv6 on and off.
    I’ve also tried looking for the hotspot, which the log says was launched. but I couldn’t find it.
    I first tried without changing the timezone. no difference.
timezone=Europe/Brussels
locales="en_BE.UTC+1 en_BE.UTC+1"
system_default_locale="en_BE.UTC+1"
wifi_ssid="WiFi-2.4-A266"
wifi_password="w9k56hksacw9h"
wifi_country="BE"
ipv6=disable

first-boot.log below



2021-05-07_18:51:02_CEST [openHABian] Starting the openHABian initial setup.
2021-05-07_18:51:02_CEST [openHABian] Storing configuration... /etc/openhabian.conf: line 63: pi3: command not found
OK
2021-05-07_18:51:03_CEST [openHABian] Enable maximum debugging output
++ timestamp
++ date +%F_%T_%Z
+ echo -n '2021-05-07_18:51:03_CEST [openHABian] Starting webserver with installation log... '
2021-05-07_18:51:03_CEST [openHABian] Starting webserver with installation log... ++ command -v python3
+ [[ -x /usr/bin/python3 ]]
+ bash /boot/webserver.bash start
bash: /boot/webserver.bash: No such file or directory
+ sleep 5
++ ps -ef
++ pgrep python3
+ isWebRunning=
+ [[ -n '' ]]
+ echo FAILED
FAILED
+ defaultUserAndGroup=openhabian
+ userName=openhabian
+ groupName=openhabian
+ is_raspbian
+ [[ '' == \r\a\s\p\b\i\a\n ]]
++ cat /etc/os-release
+ [[ PRETTY_NAME="Raspbian GNU/Linux 10 (buster)"
NAME="Raspbian GNU/Linux"
VERSION_ID="10"
VERSION="10 (buster)"
VERSION_CODENAME=buster
ID=raspbian
ID_LIKE=debian
HOME_URL="http://www.raspbian.org/"
SUPPORT_URL="http://www.raspbian.org/RaspbianForums"
BUG_REPORT_URL="http://www.raspbian.org/RaspbianBugs" =~ Raspbian ]]
+ return 0
+ defaultUserAndGroup=pi
+ rm -f /etc/sudoers.d/010_pi-nopasswd
++ timestamp
++ date +%F_%T_%Z
+ echo -n '2021-05-07_18:51:08_CEST [openHABian] Changing default username and password... '
2021-05-07_18:51:08_CEST [openHABian] Changing default username and password... + [[ -v openhabian ]]
+ id pi
+ echo SKIPPED
SKIPPED
+ echo 'watch cat /boot/first-boot.log'
+ echo noipv4ll
+ [[ -z WiFi-2.4-A266 ]]
+ grep -qs openHABian /etc/wpa_supplicant/wpa_supplicant.conf
++ timestamp
++ date +%F_%T_%Z
+ echo -n '2021-05-07_18:51:08_CEST [openHABian] Setting up Wi-Fi connection... '
2021-05-07_18:51:08_CEST [openHABian] Setting up Wi-Fi connection... + wifiCountry=BE
+ wifiSSID=WiFi-2.4-A266
+ wifiPassword=w9k56hksacw9h
+ grep -qs '^BE[[:space:]]' /usr/share/zoneinfo/zone.tab
+ wifiCountry=BE
++ wpa_passphrase WiFi-2.4-A266 w9k56hksacw9h
+ wifiConfig='network={
	ssid="WiFi-2.4-A266"
	#psk="w9k56hksacw9h"
	psk=3d5367138f3be3fd7d3ced6eaf2d814728fa2f8c21bbe054b748d90d35073863
}'
+ echo -e '# WiFi configuration generated by openHABian\ncountry=BE\nctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev\nupdate_config=1\n# Network configuration was created by wpa_passphrase to ensure correct handling of special characters\nnetwork={
	ssid="WiFi-2.4-A266"
	#psk="w9k56hksacw9h"
	psk=3d5367138f3be3fd7d3ced6eaf2d814728fa2f8c21bbe054b748d90d35073863
\tkey_mgmt=WPA-PSK\n}'
+ sed -i 's|REGDOMAIN=.*$|REGDOMAIN=BE|g' /etc/default/crda
++ timestamp
++ date +%F_%T_%Z
+ echo -n '2021-05-07_18:51:08_CEST [openHABian] Configuring network... '
2021-05-07_18:51:08_CEST [openHABian] Configuring network... + grep -qs wlan0 /etc/network/interfaces
+ cond_echo '\nNot writing to '\''/etc/network/interfaces'\'', wlan0 entry already available. You might need to check, adopt or remove these lines.'
+ [[ -z 1 ]]
+ is_pi
+ is_pifour
+ [[ '' == \p\i\4 ]]
+ grep -q '^Revision\s*:\s*[ 123][0-9a-fA-F][0-9a-fA-F][0-9a-fA-F]11[0-9a-fA-F]$' /proc/cpuinfo
+ return 1
+ is_cmfour
+ [[ '' == \c\m\4 ]]
+ grep -q '^Revision\s*:\s*[ 123][0-9a-fA-F][0-9a-fA-F][0-9a-fA-F]14[0-9a-fA-F]$' /proc/cpuinfo
+ return 1
+ is_pi400
+ [[ '' == \p\i\4\0\0 ]]
+ grep -q '^Revision\s*:\s*[ 123][0-9a-fA-F][0-9a-fA-F][0-9a-fA-F]13[0-9a-fA-F]$' /proc/cpuinfo
+ return 1
+ is_cmthreeplus
+ [[ '' == \c\m\3\+ ]]
+ grep -q '^Revision\s*:\s*[ 123][0-9a-fA-F][0-9a-fA-F][0-9a-fA-F]10[0-9a-fA-F]$' /proc/cpuinfo
+ return 1
+ is_cmthree
+ [[ '' == \c\m\3 ]]
+ grep -q '^Revision\s*:\s*[ 123][0-9a-fA-F][0-9a-fA-F][0-9a-fA-F]0[aA][0-9a-fA-F]$' /proc/cpuinfo
+ return 1
+ is_pithree
+ [[ '' == \p\i\3 ]]
+ grep -q '^Revision\s*:\s*[ 123][0-9a-fA-F][0-9a-fA-F][0-9a-fA-F]0[8dDeE][0-9a-fA-F]$' /proc/cpuinfo
+ return 1
+ is_pitwo
+ [[ '' == \p\i\2 ]]
+ grep -q '^Revision\s*:\s*[ 123][0-9a-fA-F][0-9a-fA-F][0-9a-fA-F]04[0-9a-fA-F]$' /proc/cpuinfo
+ return 1
+ is_pione
+ [[ '' == \p\i\1 ]]
+ grep -q '^Revision\s*:\s*00[0-9a-fA-F][0-9a-fA-F]$' /proc/cpuinfo
+ grep -q '^Revision\s*:\s*[ 123][0-9a-fA-F][0-9a-fA-F][0-9a-fA-F]0[0-36][0-9a-fA-F]$' /proc/cpuinfo
+ return 1
+ is_cmone
+ [[ '' == \c\m\1 ]]
+ grep -q '^Revision\s*:\s*[ 123][0-9a-fA-F][0-9a-fA-F][0-9a-fA-F]06[0-9a-fA-F]$' /proc/cpuinfo
+ return 1
+ is_pizerow
+ [[ '' == \p\i\0\w ]]
+ grep -q '^Revision\s*:\s*[ 123][0-9a-fA-F][0-9a-fA-F][0-9a-fA-F]0[cC][0-9a-fA-F]$' /proc/cpuinfo
+ return 1
+ is_pizero
+ [[ '' == \p\i\0 ]]
+ grep -q '^Revision\s*:\s*[ 123][0-9a-fA-F][0-9a-fA-F][0-9a-fA-F]09[0-9a-fA-F]$' /proc/cpuinfo
+ return 1
+ return 1
+ wpa_cli reconfigure
+ echo OK
OK
++ timestamp
++ date +%F_%T_%Z
+ echo -n '2021-05-07_18:51:08_CEST [openHABian] Ensuring network connectivity... '
2021-05-07_18:51:08_CEST [openHABian] Ensuring network connectivity... + running_in_docker

I doubt that this will help but this

looks like there is a problem with the configuration.

right, that does not help. I was testing if fake hardware would help. I guess I did something wrong, but it has nothing to do with the problem unfortunatly.

Something may be wrong
It is a 2.4g network ?

it is, I have a 5.0 and 2.4. I’m pretty sure I tried both.
but I’m assuming 2.4 is better

No only 2.4GHz IEEE 802.11b/g/n wireless LAN is supported :slight_smile:

So now that openHABian is installed on your sd card it is a bit bricked

With the SD card in your computer
on the boot drive create a file wpa_supplicant.conf - Make sure that the file extension is .conf not
wpa_supplicant.conf.txt Windows can hide the extension txt

Constance of file / Change network ssid and psk

country=US
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
network={
	ssid="MyWiFiNetwork"
	psk="aVeryStrongPassword"
	key_mgmt=WPA-PSK
}

This should copy the file over to linux partition on boot to setup your wifi

oh my god it actually worked! thank you so much :smiley:

1 Like

Please let me add an extra point of attention:
I have been trying to connect to the wifi without success.
I changed all wifi settings, made dedicated accesspoints for my rbpi and failed everytime.
I changed the openhabian.conf million times, I added the wpa_supplicant file, without succes. It took me 100 tries.

Until…I reflashed my SD card with a fresh install of Openhab. And now, I first modified the openhabian.conf file and added my wifi details. Now it works. Finally!

(who could imagine that I couldnt change the openhabian.conf file afterwards? It seemed that it picked it up, but oh no)