Fails to install/see any new z-wave/zigbee thing

  • Platform information:
    • Hardware: Raspberry 3/1GB/16GB
    • OS: Openhabian (Debian GNU/Linux 10 (buster))
    • Java Runtime Environment: which java platform is used and what version
    • openHAB version: 3.0.1
  • Issue of the topic: Fails to add items via usb-dongle

First, I don’t think this is necessarily an openhab issue. It might be an os/dongle thing.

Now, the story.

A while ago I had a small NUC machine running Windows server. It was doing some small stuff and I thought it might be a good idea to use it also for home automation. I downloaded openhab 2.0, bought an Aeotec gen5 stick and added z-wave things. All went fine.

Now, I moved and decided to start the network from scratch. I bought also a cheap cc2531 from amazon (they claim it is already flushed and should work fine with openhab) and I tried to set them up both, to do a mesh network (reuse some of my old things and by new ones).

I ditched Windows and decided to use ubuntu 20.10. Installed it, openhab installation is going fine. I am adding the dongles via add-new-thing, use binding (z-wave/zigbee), configured the port and openhab was seeing both dongles as green. Logs are happy, no complains there. I start the process of adding new things, I use the z-wave/zigbee bindings, reset the devices and put them into inclusion mode, then start the scan - but the no thing is found. The other bindings (network, chromecast, bluetooth) seem to work. Again, nothing in the logs.

Ok, I am thinking maybe there is a bug in oh3, installing oh2.5. The same behavior.

Now, I am thinking there might be a hardware issue, or something that I missed. I found an old raspberry 3 lying around in a drawer. Installed openhabian on it, everything is the default. Adding the sticks, the same. No thing is found.

I did some reading over the web and some complained about zigbee being messed by wifi or distance. The closest zigbee thing is 3m away (one wooden wall between) and z-wave 1m away (nothing in between). I set my wifi channel on 1 and the manually set the zigbee chanel to 25. Still the same, nothing in the logs.

Basically, the only things I see things like this:

2021-03-14 13:35:31.469 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'zwave:serial_zstick:745a8d3f6d' changed from UNINITIALIZED to INITIALIZING
2021-03-14 13:35:31.494 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'zwave:serial_zstick:745a8d3f6d' changed from INITIALIZING to OFFLINE (BRIDGE_OFFLINE): Controller is offline
2021-03-14 13:35:40.943 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'zwave:serial_zstick:745a8d3f6d' changed from OFFLINE (BRIDGE_OFFLINE): Controller is offline to ONLINE

and then later on

2021-03-14 13:47:57.876 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'zwave:serial_zstick:745a8d3f6d' changed from ONLINE to UNINITIALIZED
2021-03-14 13:47:58.240 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'zwave:serial_zstick:745a8d3f6d' changed from UNINITIALIZED to UNINITIALIZED (HANDLER_MISSING_ERROR)
2021-03-14 13:47:58.287 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'zigbee:coordinator_cc2531:5608b4b50c' changed from ONLINE to UNINITIALIZED
2021-03-14 13:48:03.339 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'zigbee:coordinator_cc2531:5608b4b50c' changed from UNINITIALIZED to UNINITIALIZED (HANDLER_MISSING_ERROR)

Yet, when I check them in the interface, they look “green”/ONLINE.

If I use lsusb:

Bus 001 Device 005: ID 0658:0200 Sigma Designs, Inc. Aeotec Z-Stick Gen5 (ZW090) - UZB
Bus 001 Device 004: ID 0451:16a8 Texas Instruments, Inc. 
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. SMC9514 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

On dmesg the only errors I see are around the bluetooth dongle:

[  178.493741] WARN::dwc_otg_hcd_urb_dequeue:639: Timed out waiting for FSM NP transfer to complete on 0
[  204.031225] Bluetooth: hci0: command 0x2005 tx timeout
[  206.047266] Bluetooth: hci0: command 0x200b tx timeout
[  208.063251] Bluetooth: hci0: command 0x200c tx timeout

[  300.093799] WARN::dwc_otg_hcd_urb_dequeue:639: Timed out waiting for FSM NP transfer to complete on 5

Now, to be honest, I am pretty confused. I don’t know where else can I look for problems on why none of the things I want to add are being seen by openhab.

At this moment, I haven’t tried any other software as - like I told you - I don’t really think it’s openhab’s fault (I hope, fingers crossed). So, guys, any hint?


For Z-Wave resetting was a mistake. The network is stored on the controller for non-secure devices so if you had just configured it for OH your devices would have been discovered. You now need to do one of two things for each device:

Open the controller Thing and then select Exclude Devices and exclude a device from the network.
Factory Reset the device

You can then scan for & discover the device, including it into your network.

I am not as familiar with Zigbee.

I did them both. The reason I reset everything is that part of the devices left in the old place, I have new ones - I thought it’s faster. I know they’re stored on the device, I just thought it’s easy just to add them back and then let them “recofigure”. Yes, I did that - the z-wave was hard-reset.

For some reason, I have the same problem with both of them - and that’s why I think the problem lies some around os-level configuration. They’re kind of different in terms of frequencies and devices-to-be-included which makes me think the problem is a bit lower.

could be the Serial-Port-Configuration in Linux:

Can be set in openhabian-config menue 35

Yes, I think that did the trick.

So, in my case, it seems like the name of the ports was not changed at all between reboots. Also, openhab was able to see them fine (i even tried to mix between them - put zwave controller to work on zigbee’s one and vice versa, and they immediately complained).

What I did:

  • i set the extra options for java;
  • i added the extra privileges for openhabian user:
  • reboot.

Aster restart, the new zigbee device was immediately seen.

Thanks a lot!

That is required for zigbee as stated in the binding docs.

If you are running on Linux, then you probably need to add the user ‘openhab’ to the tty group, and enable EXTRA_JAVA_OPTS for the serial port your coordinator uses (see Linux install guide (opens new window)).