Failure to enroll garage door opener in zwave network

Tags: #<Tag:0x00007f4335c8c290>

I’m trying to enroll my garage door opener with my zwave network.

Name: Linear GoControl GD00Z-8 ZWave Garage Door Opener with Sensor
PN: GD00Z-8-GC

It seems to be recognizing the security, but is unable to add the device. Is this the error message for a device that isn’t in the database?

2020-12-04 22:51:42.348 [INFO ] [g.discovery.internal.PersistentInbox] - Added new thing 'zwave:device:e96ab58b:node2' to inbox.
2020-12-04 22:51:47.430 [INFO ] [mmandclass.ZWaveSecurityCommandClass] - NODE 2: Using Scheme0 Network Key for Key Exchange since we are in inclusion mode.
2020-12-04 22:51:47.605 [INFO ] [alization.ZWaveNodeInitStageAdvancer] - NODE 2: SECURITY_INC State=COMPLETE
2020-12-04 22:51:47.848 [WARN ] [wave.discovery.ZWaveDiscoveryService] - NODE 2: Device discovery could not resolve to a thingType! 014F:4744:3531::3.0
2020-12-04 22:51:48.066 [INFO ] [ommandclass.ZWaveVersionCommandClass] - NODE 2: Command Class COMMAND_CLASS_BASIC has version 0!

I’ve tried dropping and re-adding it, and even accidentally hard reset the zwave controller (that thing should really come with a warning, or a re-label to “factory reset” with a confirmation step), but still I get the same response when I attempt to enroll it in the network.

Anybody have any ideas?

Thanks

It looks like the version of zwave binding that you are using has this device in the Thing definitions. In looking at the device database, I do not see a device that supports that type:id (4744:3531). It will need to be added to the database…

If you have trouble, post the xml file (in $OPENHAB_HOME/userdata/zwave) that the binding generated and someone here may be able to help.

1 Like

NODE 2: Device discovery could not resolve to a thingType! 014F:4744:3531::3.0

That device does not appear to be in our community maintained device database. If the device is fully discovered there should be an xml file in the zwave folder under userdata. That can be used to help make a database entry. The guide is here.

EDIT: Scott beat me to it.

1 Like

I think this is the file - I seem to have a few node2 files in there over the various re-enrollments I’ve performed. I have no idea how to contribute to the zwave database, and the above link didn’t seem to work.

network_cb05bb98__node_2.xml (9.0 KB)

Thanks

That xml file looks good/ A link to the pdf of the manual would be useful too.

Uh-Oh!
@chris I assume you know I think the website crashed again :frowning:

1 Like

Here you go…

GoControl GD00Z-8-GC Manual.pdf (849.7 KB)

1 Like

The website is back up but logins are still disabled for a while longer.

Looks like the GD00Z-4 has 4744:3030,4744:3032,4744:3530, but obviously not 4744:3531. The GD00Z-8 is very similar to the GD00Z-4, but there wasn’t 100% alignment with the command classes. Does that mean I should create it as a new device?

Yes, we need a new device created. It appears logins have not yet been enabled on the website.

Chris had a couple of major server failures happen at the same time. Fortunately he had some backups on a third server for the first two.

I just added the device ready for the next database export.

Oh, sweet, thanks! I have been checking back, and while the login option works again, I hadn’t (and still don’t) seen the “Create Device” button.

What’s the process for getting this to my local machine? Do I wait until 2.5.11 is released?

You missed this bold part from the guide.

To use the database you must first register on the site, then email, or open a ticket to have your access updated to allow you to edit the information.

The database is manually exported to GitHub periodically, usually at least once a week. After that, the OH snapshot build process builds a new binding with the changes.

You can then use the manual install script to install the updated binding on your system,

You then need to delete the Thing from OH (do NOT exclude) and re-add to get the new settings.

Ah, yes, that would do it. This kind of seems like an unnecessary step, seeing as the database is read-only already without an account, unless having an account gives you some advantage without the ability to create devices?

Thanks for the detailed steps on getting this into my system, and your patience with explaining everything else!

Neil

The account lets you create tickets there. @chris can let us know what else.

You can then use the manual install script to install the updated binding on your system

I just realized the manual install script was Linux based, whereas I’m running OH on Windows. It seems like all the fancy OH tools are written for Linux, sigh. Can I just download the zwave snapshot release to my addons folder, when it’s available?

A manual installation will need help resolving its dependencies. If they are already being used by another binding, then copying the jar to /addons/ might be enough. The instructions in the readme for the script show what the script does and what you would need to do to install everything manually.

1 Like

I think the vast majority of users here use UNIX-like systems such as Linux and MacOS. Since Java is cross-platform it also runs on Windows.

For instance, I am looking closely at the Docker install but it broke when the improved WSL2 Docker for Windows was released. You can run OH but cannot access any USB sticks :frowning: