<Feature Request> Please add paper ui password protection

Sorry if this post in the wrong place
but please, pretty please… many please… add a password protection to the paper ui, or at least can show/hide the paper ui web page setup!! That’s really important!!

here is the story of why this is so important:
My mom accidently click the paper ui button and she have no idea how to go back to habpanel page, and she somehow, I don’t know how, she brokes the openhab system completely (I am curretnly running openhab2.1 docker)

please make it happen, or at least can hide the admin panel, or maybe some IT tech (nginx?) to redirect the main page directly to habpanel page(http://localhost:8080), but I have no idea how to make this happen…


Just use http://localhost:8080/habpanel/index.html#/ instead of just http://localhost:8080. Then when they go to http://localhost they go straight to HABPanel.

She should have a bookmark that sends her straight to the HABPanel page in the first place. You shouldn’t be showing or handing out the address to the Dashboard to users.

Are you sure you want your mom playing in Habpanel as well? You can do most of the same things in Habpanel regarding installing and uninstalling bindings as well as some configuration stuff.

Perhaps better to set a default bookmark, etc to the BasicUI or ClassicUI?

Unfortunately this won’t work if I add the /habpanel/index.html#/ behind the localhost:8080, it returns alywas Connection lost! trying to reconnect here is what I’ve done:

server {
    listen                                     80;
    server_name               ;

    location / {
        proxy_pass                            http://localhost:8080/habpanel/index.html#/;
        proxy_set_header Host                 $http_host;
        proxy_set_header X-Real-IP            $remote_addr;
        proxy_set_header X-Forwarded-For      $proxy_add_x_forwarded_for;
        proxy_set_header X-Forwarded-Proto    $scheme;

however if I change proxy_pass back to default http://localhost:8080, nginx works and show the main page with paper ui as well…(without port8080 though, so I assume nginx is being correctly setup)
Looks like habpanel must have to access through the main page if nginx is in barkground.
Also tested with both latest 2.2.0snapshot and stable 2.1.0 version, got the same result as well
What did I done something wrong? Do I also need to deal with the https stuff in nginx?

Hi, I am pretty sure she can “click” the light icon etc to turn on/off everything, it just full of buttons^^(I also babysit the habpanel to a very simple ui so that she can totally control everything via habpanel)…and also I believe habpanel can be lock via paper ui setting, so in this case the habpanel is more like a frontend web page shown in wall mounted tablet.
A bookmark is very helpful indeed ^^… however if someone typing localhost:8080 he still can access admin panel to change/mess the settings(via browser)

I think you need to remove the index.html#/ part. You want to proxy to the server, not to a specific webpage.

Are you confusing HABPanel with Habmin? I’m pretty sure HABPanel is supposed to be a users interface. It has been awhile since I’ve played with it but the last time it did there was no way to install bindings and such.

doh :crazy_face: Your were right, I was…

But perhaps it would be nice to be able to hide your backend PaperUI and Habmin from users. Perhaps the ability to load those from a different port?

1 Like