Feedback from a new user

Dear experienced users,

being fairly new new to Openhab I have started my journey using the Openhabian quick start guide.

However I ran into a couple of (known) issues which I could partly solve based on instructions given.

Seeing the huge potential of openhab clearly in front of me, I would like to start over and contribute with re-testing, once the issues are marked as solved.

My question is: How Can I manually generate an SD-card image from latest git master, that will allow me to retest, if the following topics are solved, maybe / hopefully in a few weeks?

I encountered the following issues/blockers:
1.) JAVA/zulu8 issue (https://github.com/openhab/openhabian/issues/710#issuecomment-529074719)
2.) Locale issue (https://github.com/openhab/openhabian/issues/706)
3.) After installing “homegear” via the OpenHABian Configuration Tool, I receive an error when entering the recommended command as shown by the the config tool:

openhabian@openhab:~$ homegear -v
Homegear version 0.7.40-2948

openhabian@openhab:~$ homegear -r
10/20/19 13:12:53.484 Could not connect to socket. Error: Permission denied
10/20/19 13:12:53.485 Could not connect to socket. Error: Permission denied
10/20/19 13:12:55.483 Could not connect to socket. Error: No such file or directory
10/20/19 13:12:55.483 Could not connect to socket. Error: No such file or directory

Digging a bit deeper …

openhabian@openhab:~$ sudo systemctl status homegear.service
● homegear.service - Homegear
Loaded: loaded (/lib/systemd/system/homegear.service; enabled; vendor preset: enabled)
Active: active (running) since Sun 2019-10-20 13:11:49 CEST; 32min ago
Process: 4208 ExecStartPre=/etc/homegear/homegear-start.sh (code=exited, status=0/SUCCESS)
Main PID: 4210 (homegear)
Tasks: 82
Memory: 35.9M
CGroup: /system.slice/homegear.service
└─4210 /usr/bin/homegear -u homegear -g homegear -p /var/run/homegear/homegear.pid

Oct 20 13:11:49 openhab systemd[1]: Starting Homegear…
Oct 20 13:11:49 openhab systemd[1]: Started Homegear.
Oct 20 13:11:49 openhab homegear[4210]: 10/20/19 13:11:49.774 Loading RPC server settings from /etc/homegear/rpcservers.conf
Oct 20 13:11:49 openhab homegear[4210]: 10/20/19 13:11:49.780 Loading RPC client settings from /etc/homegear/rpcclients.conf
Oct 20 13:11:49 openhab homegear[4210]: 10/20/19 13:11:49.847 Info: Setting allowed core file size to “4294967295” for user with id 0 and group with id 0.
Oct 20 13:11:49 openhab homegear[4210]: 10/20/19 13:11:49.847 Info: Core file size now is “4294967295”.
Oct 20 13:11:49 openhab homegear[4210]: 10/20/19 13:11:49.847 Info: Setting maximum thread priority to “4294967295” for user with id 0 and group with id 0.
Oct 20 13:11:49 openhab homegear[4210]: 10/20/19 13:11:49.848 Info: Maximum thread priority now is “4294967295”.

… we can see that the service seems to run fine, however the recommended command will still fail.

Thanks for any advice given.

Below the requested standard information.

Platform information:
Release -> Raspbian GNU/Linux 10 (buster)
Kernel -> Linux 4.19.75-v7+
Platform -> Raspberry Pi 2 Model B Rev 1.1
Java Runtime Environment:
openjdk version “1.8.0_222”
OpenJDK Runtime Environment (Zulu8.40.0.178-CA-linux_aarch32hf) (build 1.8.0_222-b178)
OpenJDK Client VM (Zulu8.40.0.178-CA-linux_aarch32hf) (build 25.222-b178, mixed mode, Evaluation)
openHAB version: 2.4

1 Like

Welcome!

If I were starting now I think the latest Testing version, 2.5M4. might be a better choice. 2.4 is now quite old and there will be quite major migration changes when moving from 2.4 to 2.5 when it is released at the end of this year.

Do you have OpenHAB running? OpenHABian right now can be a little fussy to install, but I have dome it recently. We can work around the issues to get you running.

I am not too familiar with this. What are you needing to do? I am in the US and have not touched the local stuff but I am a former UNIX administrator so we can likely figure this our.

I do not use homegear so I cannot help with that.

Hello @Bruce_Osborne,

thanks for instant reply.

The locale error is thrown out in many areas of the installation process and also negatively affects the frontend in PAPERUI.

I can see broken “umlauts” such as ä,ü,ö,ß which are common in German language. They are usually shown as question marks “?” on the UI then.

So your kind advice is to not utilize Openabian, but rather jump on the “mothership” and switch to OpenHab Testing 2.5M4.

I will try that and come with feedback, should I still encounter the above.

Thanks again.

BR

Bert

So, what local do you need set? Perhaps @sihui could advise since he is in Germany.

You can install 2.5M4 from OpenHABian.

Ok, so you are willing to help with openHABian, not with openHAB - did I get that right ?
Great, you’re welcome!

If so, clone the repo from Github and have a look at README.md to find out how you can generate your own image. Please also check out CONTRIBUTING.md .

You can also edit /opt/openhabian/functions/*.bash in place.
Just remember to not let openhabian-config update itself on start.

That ain’t the OP’s point.

Hi,

being new, I just recognized that those are two different (however related) projects: OpenHAB and OpenHABian.

For the sake of simplicity (and being a newcommer) I would like to start retesting OpenHABian. I can also see from recent work done by @mstormi that he is anyway actively working on the issues I reported in my first post.

Daumen hoch!

I will have a look at the pages you have highlighted, I am sure there will be some good learnings for me.

In case I do not manage (due to lack of time or skills) I am however extremely happy to test any new image file should you be planning to release a successor for the current publicly available image.

https://github.com/openhab/openhabian/releases/download/v1.5/openhabian-pi-raspbian-201908050414-gitca0976f-crc6a66b5a1.img.xz

So if you want me to retest if “my” problems are closed, please ping me and guide me to the “test version” of any new image.

I will be happy to “feed” my Raspi with it and give feedback,

BR

Bert

You don’t need to build an image to test latest openHABian.
It’ll update itself from Github with the latest available.
See https://github.com/openhab/openhabian/issues for open issues and feel free to pick any of them and make a Pull Request.
Not all of these are coding tasks, some are on documentation.
And there’s never enough testing
So you’re welcome to test whatever function of openHABian for yourself whatever and open a Github issue for anything you find to be weird or not working. We might choose to (technically) not share your view and quickly close it again but we’re nonetheless grateful about anyone willing to help.

I don’t know the homegear stuff but I’d guess that just like with openHAB, you must use the openhab user to run it, not openhabian.
Feel free to find out if there’s a combination of access rights to allow for both, running as openhab and doing admin as openhabian, and to come up with a PR.

Hi Bert and welcome to the OpenHAB community!!!
The whole system has been thru a TON of changes lately and the developers and maintainers have been working double over time but the good news is that all these changes have brought with them a TON of improvements and enhancements.
We all try to help anyway we are capable. I have been using OpenHAB for a little over a year and like to hang out and answer questions in the forum when I can. That is my small contribution. A number of other members do the same and figuring out an issue is fun to us so feel free to ask questions and have fun!

1 Like

My advice was abased in my experience with the stability of the Milestones and he changes later for migrating from 2.4.

I see some German users here to help and some more experienced openHANian users. I will bow out now.

Thanks for the warm welcome and the useful replies. I openened 2 github issues for this containing the essence of the discussion we had here.

I sincerely hope it is usefull feedback from someone new to the topic, if not please close them


BR

Bert