FGRGBW-441 METER command class support

Hi @chris
i want items configuration setting for getting METER information from controller.
i want to get power and current values…

Please send me configurations

If you are using OH1, please refer to the wiki. If you are using OH2, please check the database for the device you have to see what channels are available. If there are channels missing, they will need to be added.


my openhab is 1.7.0
and configurations i tried is

Number RGB_power_0 {zwave=“154:0:command=SENSOR_MULTILEVEL,sensor_type=4”}

i am getting value
but i am not values with METER command class


my entry for METER c ommand class:

Number RGB_meter {zwave=“154:0:command=METER,meter_scale=E_KWh,refresh_interval=20”}

I would suggest to check the XML file for this device to see what it shows is supported. (in the /etc/zwave folder if I remember correctly on OH1).


please send me correct configuration with METER command class


Please check the wiki - there are examples.

Have you checked already what is in the XML as I suggested?


i checked wiki and xml too.
As per that i made my configurations…
In xml there is entry for METER command class but still its not reporting…

Does it require any configuration…?

Ok - good then you have the example :slight_smile: .

And what does it say it supports?

i tried below config:

    Number RGB_meter {zwave="154:0:command=METER,meter_scale=E_KWh,refresh_interval=20"}

What is in the XML? Please provide the information that it shows for the meter class.


So the item definition should be fine. I would suggest the following though -:

    Number RGB_meter {zwave="154:command=METER,meter_scale=E_KWh"}

If that’s not working, then I would check the configuration of the device - maybe it’s configured not to report? From a quick look at the manual, this appears to be parameter 44. You should also check that the association is properly configured - this looks like group 5.

If all else fails I would suggest to check the debug log to see what is being sent by the device.