FGS211 with dusk-to-dawn sensor attached

I’m running openhab 2.4.0 and have since long a Fibaro FGS211 hooked up to a (analogue ?) “dusk-to-dawn” sensor which outputs some kind of voltage depending on light/dark conditions and between this sensor and FGS211 there is a relay because the sensor was “leaking” current…this is all told and done by an electrician.

This dusk-to-dawn sensor is attached to S1 and when signal is received it turns on a set of lamp hooked up to the output (whatever it might be called). This works as a charm.

I have created an item in my items file:

Switch SW_GARAGE_SKYMNING_1 "Switch1 Skymning" <garage_detached> (Switches) { channel="zwave:device:XXXXXXX:node3:switch_binary1" }

This is controllable by me and will turn on/off lights manually if I toggle the switch.

I have created a rule that trigger on “changed”

rule "Floodlights"
    Item SW_GARAGE_SKYMNING_1 changed
    if (SW_GARAGE_SKYMNING_1.state == ON) {
    sendCommand(Floodlights, ON)
    sendPushoverMessage(pushoverBuilder("Send message"))
    } else {
    sendCommand(Floodlights, OFF)
    sendPushoverMessage(pushoverBuilder("Send message")) }

My problem is that the rule triggers like 30-50minutes after dusk and likewise, 30-50min after dawn and not immidiately. I have checked debug log for Z-wave when I manually cover the sensor and it tells me:

2019-09-24 17:14:47.860 [DEBUG] [nal.protocol.ZWaveTransactionManager] - lastTransaction null
2019-09-24 17:14:47.861 [DEBUG] [nal.protocol.ZWaveTransactionManager] - NODE 3: Application Command Request (ALIVE:DONE)
2019-09-24 17:14:47.861 [DEBUG] [ng.zwave.internal.protocol.ZWaveNode] - NODE 3: resetResendCount initComplete=true isDead=false
2019-09-24 17:14:47.861 [DEBUG] [ng.zwave.internal.protocol.ZWaveNode] - NODE 3: Incoming command class COMMAND_CLASS_SWITCH_BINARY, endpoint 0
2019-09-24 17:14:47.862 [DEBUG] [ng.zwave.internal.protocol.ZWaveNode] - NODE 3: SECURITY not supported
2019-09-24 17:14:47.862 [DEBUG] [tocol.commandclass.ZWaveCommandClass] - NODE 3: Received COMMAND_CLASS_SWITCH_BINARY V1 SWITCH_BINARY_REPORT
2019-09-24 17:14:47.862 [DEBUG] [dclass.ZWaveBinarySwitchCommandClass] - NODE 3: Switch Binary report, value = 255
2019-09-24 17:14:47.863 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 3: Got an event from Z-Wave network: ZWaveCommandClassValueEvent
2019-09-24 17:14:47.863 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 3: Got a value event from Z-Wave network, endpoint = 0, command class = COMMAND_CLASS_SWITCH_BINARY, value = 255
2019-09-24 17:14:47.863 [DEBUG] [nal.protocol.ZWaveTransactionManager] - NODE 3: Commands processed 1.
2019-09-24 17:14:47.864 [DEBUG] [nal.protocol.ZWaveTransactionManager] - NODE 3: Checking command org.openhab.binding.zwave.internal.protocol.ZWaveCommandClassPayload@5d13aaa6.
2019-09-24 17:14:47.864 [DEBUG] [nal.protocol.ZWaveTransactionManager] - Transaction completed - outstandingTransactions 0
2019-09-24 17:14:47.864 [DEBUG] [nal.protocol.ZWaveTransactionManager] - Transaction completed - outstandingTransactions 0
2019-09-24 17:14:47.865 [DEBUG] [nal.protocol.ZWaveTransactionManager] - ZWaveReceiveThread queue empty
2019-09-24 17:14:47.865 [DEBUG] [nal.protocol.ZWaveTransactionManager] - Transaction SendNextMessage 0 out at start. Holdoff false.

I also tried different associations group setting, there is “Switch 1”, “Switch 2” and “Controller updates” to associate and I have set them one by one or all to “Controller” without success.

What’s your problem then ?

I’m guessing the delay in the sensor triggering? Did it used to work right at dawn and dusk?

That it does not trigger the item to state “on” immidiately when dusk-sensor is triggering the relay.

As I can recall yes.

And without being expert on the fibaro unit or electricity in general…isn’t this setup supposed to be able to trigger an item state immidiately ?

I’m guessing setup issue in the FGS211.

As you suspect an actuator setup issue first thing to check is if an input signal on S1 is forwarded via ZWave to openHAB. Attach a classic switch to S1 and watch ZWave debug log and event.log.
BTW you need the lifeline association only (“controller”), delete the others.

Assuming that works, second to check is if the electrical part works: attach a light to O1 (if you haven’t already) and watch what`s happening at dawn (i.e. will the light be lit). It’s probably better to change the sensor sensitivity so you can have a voltmeter also measure at that trigger moment.
Ok I now see you said you already did that.

I have a light attached to O1 and it is lit up perfectly at dusk. I have not attached a classic switch to S1 yet but as noted in first post you can read (openhab log with zwave debug on) what happens when triggering S1 from openhab and when pressing “b” button on FGS211.

You didn’t write you’re pressing “B” and you in fact mustn’t press it.
Attach a switch and retry to see if that causes a ZWave message to be sent.
Check the ZWave parameter for momentary/bistable switch input. If I was to guess it’s set to bistable but your sensor sends an impulse but does not keep the signal HIGH. Or vice versa.

Make sure you know how it is supposed to work on the electrical and logical layer.
Either way it’s not a clever setup because you cannot switch the light independent of luminosity/your dawn sensor.
Better attach the sensor to another zwave device or use one to have a lux sensor such as an FGMS.

  • if lifeline is set up correctly when S1 receives voltage(the circuit before it is closed/opened either by a relay or a switch) it should turn on/off almost immediately - not only physically but also in OpenHab. If the output on Q1 is turned ON immediately when S1 changes state, but that isn’t refelcted in OH, then it’s a transmission/range/lifeline issue.

  • dusk/dawn + movement sensors with an integrated relay(which i guess are similar to your input on s1) cost around 20€, so maybe if the contact isn’t clean, change it.

You should have only controller updates associated to the controller and a channel linking switch1 to a switch item.
S1 and S2 associations are meant for direct z-wave device to z-wave device associations.

Ok, will attach a classic switch to try.

It is set to bistable. Momentary does not even light up the O1 attached lamp…

I “think” my sensor is providing a signal like a classic switch. Not impulse.

if you keep a momentary switch pressed, you’ll get the same effect, just for testing purposes ofc, not a convenient daily use XD

and yes those sensors are bistable in nature

if lifeline is set up correctly when S1 receives voltage(the circuit before it is closed/opened either by a relay or a switch) it should turn on/off almost immediately - not only physically but also in OpenHab. If the output on Q1 is turned ON immediately when S1 changes state, then it’s a transmission/range/lifeline issue.

If you ask me, this is the issue. But what is the right config? If I leave Switch 1 and 2 blank and then set Controller update to “controller”, this does not work as supposed…is this setup so that the FGS211 needs to be in range to controller and that might be the issue ?

s1 and s2 association blank
controller updates to controller(lifeline)

then create an item linked to the switch channel,
then test the timing of actuation if you command it from paper ui
then test the timing of representation in paper ui if s1 changes state.

If you have the option to move the controller near the fgs211 (with a power strip or smth) you can also see if it is a range issue.
Same if you can ,move the fgs 211 closer to the controller (don’t electrocute yourself in the process or leave exposed cables hanging or touching each other- rather isolate them)

Ok, so range might be the problem. You say that if set to “Controller” in controller updates. It does need to be in range for the controller ?

There is then no “mesh-magic” happening ? And there is no possibility to make it mesh ?

It is possible to heal single devices (habmin>setup>things>top right corner show advanced>top right corner again heal device -they say that it can slow the network down tho, i have never experienced it but it’s not advised) .
You can also let the network heal itself day by day.
By doing so the list of z-wave neigbours for weach node is refreshed.

Check in habmin>tools>view z-wave network to see your current topology.

If a node is out of range should be quite apparent.

Also, so far you didn’t mention having other z-wave devices nearby, so it looked as though you had only controller +1x fgs211

Sorry, I have 20 other z-wave devices. All in range. Network is healed every night. Also tried manually for this specific node.

I dont think this node is out of range. Could it be 8-10 meters with 3 wooden walls in between.

if all the above are true, lifeline is set correctly and in habmin your z-wave network shows the specific node as in range, could really be a also a faulty device as mstormi pointed out earlier.

I suggest checking your z.wave network representation in habmin and doing the above mentioned tests before drawing conclusions thoug.

btw, i’ve had some walls unexpectedly screening the signal way closer than that.

Node 3 in picture below.

I just need to ask this again and clarify.

The DEBUG section in my first post is immidiately posted in openhab.log using “tail -f /var/log…” when convering my dusk/dawn sensor by hand. The light connected to O1 is also lit up immidiately.

What does that DEBUG log say ? Is this node in contact with my z-wave controller/network/other ?

How can I use this piece of information to continue my search for the cause of this issue. I mean, it does communicate at the point of activation from my sensor.

Have you tried the log viewer?