Fibaro Dimmer 2 FGD212 S2 Readout not working

Hey guys. The Fibaro Dimmer 2 is driving me nuts.
My desired Setup:
One FGD212 is in the Bathrom controlling the lights there.
A second FGD212 is installed in the Bedroom, controlling thebedroom lights. WIth S2 on that Dimmer I want to be able to also control the Bathroom Dimmer. That works somewhat well with Associations but I want to integrate them all in openhab.
I also own a Switch 2 and all readouts work perfectly there - When use the Wall switch the log happily returns:

2018-02-11 23:49:09.723 [ome.event.ItemCommandEvent] - Item 'wz_switch2_switch2' received command ON

But that does not happen with S2 on my Dimmer. What am I doing wrong? I tried nearly everything.
I installed the FGD212 via Thing search and then manually added an .items file.
These are my items for the Dimmer:

////Dimmer SZ
Dimmer sz_dimmer2_dimmer   "Dimmer"                 (Schlafzimmer)      {channel="zwave:device:zwave_usb:node8:switch_dimmer"}
Switch sz_dimmer2_switch   "Dimmer An/Aus"          (Schlafzimmer)      {channel="zwave:device:zwave_usb:node8:switch_dimmer"}

Dimmer sz_dimmer2_dimmer1  "Dimmer 1"               (Schlafzimmer)      {channel="zwave:device:zwave_usb:node8:switch_dimmer1"}
Switch sz_dimmer2_switch1  "Switch 1"               (Schlafzimmer)      {channel="zwave:device:zwave_usb:node8:switch_dimmer1"}

Switch sz_dimmer2_switch2  "Switch 2"               (Schlafzimmer)      {channel="zwave:device:zwave_usb:node8:switch_dimmer2"}
Dimmer sz_dimmer2_dimmer2  "Dimmer2"                (Schlafzimmer)      {channel="zwave:device:zwave_usb:node8:switch_dimmer2"}

Number sz_dimmer2_scene    "Scene Number"           (Schlafzimmer)      {channel="zwave:device:zwave_usb:node8:scene_number"}
Number sz_dimmer2_sensor   "Sensor"                 (Schlafzimmer)      {channel="zwave:device:zwave_usb:node8:sensor_power"}
Number sz_dimmer2_sensor1  "Sensor 1"               (Schlafzimmer)      {channel="zwave:device:zwave_usb:node8:sensor_power1"}
Number sz_dimmer2_kwh      "Verbrauch in KwH"       (Schlafzimmer)      {channel="zwave:device:zwave_usb:node8:meter_kwh"}
Number sz_dimmer2_watts    "Leistung in Watt"       (Schlafzimmer)      {channel="zwave:device:zwave_usb:node8:meter_watts"}
Switch sz_dimmer2_reset    "Verbrauch zurückzestzen"(Schlafzimmer)      {channel="zwave:device:zwave_usb:node8:meter_reset"}

Log File only returns the following when I press S1 Wall switch:

2018-02-11 23:15:30.985 [vent.ItemStateChangedEvent] - sz_dimmer2_scene changed from 26 to 16

I would prefer it to state

sz_dimmer2_switch2 received command ON 

or something similar. When I use the switch on my Sitemap the update is working. but then with associations the Bathroom lights will not turn on. . .
I don’t feel like using the scene selection in a rule.
Do you guys have any idea??
Thanks!

1 Like

With associations you are not able to control the device via openHAB independently, with catching the scene numbers your are able to trigger rules to have full control via openHAB.
I doubt there is another way to do it.

One option could be to use a map transformation and map ON to a scene number and OFF to another scene number. But then you only have to two triggers available while the FGD212 supports a lot more:

https://manuals.fibaro.com/dimmer-2:
SCENE ID value sent at specified configuration:
Momentary switches
SCENE ID: S1 input SCENE ID: S2 input
16 : 1 x click
14 : 2 x click
– : 3 x click
12 : hold
13 : release 26 : 1 x click
24 : 2 x click
25 : 3 x click
22 : hold
23 : release
Toggle switches
SCENE ID: S1 input SCENE ID: S2 input
10 : OFF to ON
11 : ON to OFF
14 : 2 x click
– : 3 x click 20 : OFF to ON
21 : ON to OFF
24 : 2 x click
25 : 3 x click
Roller blinds switches
SCENE ID: S1 input SCENE ID: S2 input
10 : turn ON (1 x click)
13 : release
14 : 2 x click
– : 3 x click
17 : brightening 11 : turn OFF (1 x click)
13 : release
14 : 2 x click
15 : 3 x click
18 : dimming

I was afraid that scenes would be the only way.
It is strange because with the bathroom dimmer your way worked really well - assigning both a dimmer and a switch item to the dimmer channel. But that probably only works with S1. Sadly…

The scene id’s also work for S2 on the FGD212 …