Fibaro Dimmer2 (FGD212)


I can’t find the meter reset for this device in the db. If you give me access I can try and add it.
User: josha

Regards S

Sorry - I missed this one. I’ve now given you access…

@chris @TedStriker

Looks like it is in the database now (Ted added it, I think), waiting for review.
I’d be happy to test it out.

Regards, S


I see that then database change is approved and exported. Still don’t get the update, using todays snapshot.
(Removed and added device)
Still problems with Cloudbees?

Regards S

Sorry - I’m not sure if I managed to get this into Github. I’ve been working very long hours over the past week (eg until 3am, then up again at 6am) - today we are finished and next week I have a holiday, so time to catch up on Z-Wave :slight_smile: .

I’ll do an export and merge tonight - hopefully this will solve it, otherwise we can investigate further.

1 Like

Sorry - last night was sleep time so I didn’t get this done. I’ve just merged and kicked off the build…

Can confirm the meter reset is working now.
Thanks again for the help!

Regards s

Great - thanks for the feedback.



I get exceptions when using the Scene activation button S2 on the dimmer.

2016-11-04 10:12:11.128 [ERROR] [ve.internal.protocol.ZWaveController] - Exception during ZWave thread: Input 2. {}
java.lang.IllegalArgumentException: Value must be between 0 and 100
        at org.eclipse.smarthome.core.library.types.PercentType.validateValue([98:org.eclipse.smarthome.core:]
        at org.eclipse.smarthome.core.library.types.PercentType.<init>([98:org.eclipse.smarthome.core:]
        at org.openhab.binding.zwave.internal.converter.ZWaveBasicConverter.handleEvent([197:org.openhab.binding.zwave:]
        at org.openhab.binding.zwave.handler.ZWaveThingHandler.ZWaveIncomingEvent([197:org.openhab.binding.zwave:]
        at org.openhab.binding.zwave.internal.protocol.ZWaveController.notifyEventListeners([197:org.openhab.binding.zwave:]
        at org.openhab.binding.zwave.internal.protocol.commandclass.ZWaveBasicCommandClass.processBasicReport([197:org.openhab.binding.zwave:
        at org.openhab.binding.zwave.internal.protocol.commandclass.ZWaveBasicCommandClass.handleApplicationCommandRequest([197:org.openhab.binding.zwave:2.0.
        at org.openhab.binding.zwave.internal.protocol.serialmessage.ApplicationCommandMessageClass.handleRequest([197:org.openhab.binding.zwave:2.0.
        at org.openhab.binding.zwave.internal.protocol.ZWaveController.handleIncomingRequestMessage([197:org.openhab.binding.zwave:]
        at org.openhab.binding.zwave.internal.protocol.ZWaveController.handleIncomingMessage([197:org.openhab.binding.zwave:]
        at org.openhab.binding.zwave.internal.protocol.ZWaveController.access$7([197:org.openhab.binding.zwave:]
        at org.openhab.binding.zwave.internal.protocol.ZWaveController$[197:org.openhab.binding.zwave:]

I can see that my dimmer bar changes when pressing s2 button, even though the actual light remains the same.
Why is the dimmer bar changing upon scene selection?

I guess this could be miss-configuration from my side?
Association group set to controller.
Additional config:
26: 3way function switch disabled
27: All groups sent as non-secure
28: Scene activation enabled

Device xml:

Regards, S

I guess you have multiple association groups configured to send to the controller? There are a number of messages being sent here…

I’m not sure I can answer your question of why the dimmer bar moves - it looks like the BASIC message is causing the exception (easy to fix) and the MULTILEVEL is ignored as the value if FF which is outside of range of a dimmer.

I will fix the exception and lets see how it looks - if there is still strange things happening, we’ll look further as maybe you’re doing something a little ‘non-standard’ (by that I don’t mean you’re doing anything wrong - just different ;)).

1 Like


Hi Chris!

No exceptions now.
Still have some odd behavior though.
When using the s2 button the dimmer object is altered ( the slider of the dim level is adjust with the scenes), I would expect this slider to not be altered since the dim level of the actual bulb is not affected.

So the switch_dimmer channel is affected, or do you know if this can be configured?
Dimmer ZwaveLRDimmerDim “Dimmer [%d %%]” (ZwaveLRDimmer) { channel=“zwave:device:be1078de:node25:switch_dimmer” }

I also see these:
2016-11-07 10:39:56.341 [WARN ] [ss.ZWaveMultiLevelSwitchCommandClass] - Unsupported Command 4 for command class SWITCH_MULTILEVEL (0x26).


Regards, S

For me this currently works well enough. I’m using the S2 button as a master switch to turn off all lights in my house, which with your latest fix works, so it’s not urgent in any sense, just thought you might find it interesting in case someone else is using the scenes in a different manner.

Regards S

What association groups are you using? (ie what groups are linked to the controller)?