Fibaro Dimmer2 without feedback

Hello,

I use openhab2 on a raspberry.
Normally I get a feedback from my devices, like:
Motion sensor detected motion: switch on sitemap turn on
wall plug turns on: switch on sitemap turns on

At my dimmer2 I can switch the light through the sitemap, but if i use the physical switch the physical light turns on, but I dont get a feedback on the sitemap.

sitemap:
Switch item=OG1_WZ_Dimmer1
Switch item=OG1_WZ_Dimmer2

items:
Dimmer OG1_WZ_Dimmer1 “Dimmer 1 WZ” (gOG1WZ, gOG1Licht, gHLicht) [“Lighting”] { channel=“zwave:device:76bb8524:node9:switch_dimmer1” }
Dimmer OG1_WZ_Dimmer2 “Dimmer 2 WZ” (gOG1WZ, gOG1Licht, gHLicht) [“Lighting”] { channel=“zwave:device:76bb8524:node9:switch_dimmer2” }

Where is the problem?

Thanks Carsten

1 Like

Does your switch report the new state back to OH? Look in events.log and see if OG1_WZ_Dimmer1 receives an update when you change the dimmer at the switch. If not, there is your problem. Not all ZWave switches/dimmers report when they are physically swithed/dimmed. Usually, the Fibaro ones do though.

Hello,

no, the dimmer dont report the state in the events.log.
But I used this dimmer with FHEM bevore, and there it worked.

The dimmer2 has 2 switches, one physical relais and one only physical switch only for zwave.
And if I link the second Switch, the zwave switch, to a wall plug nothing happens.
With FHEM the same wasnt any problem.

I reset the dimmer2 again, but the problem is the same.

I only have one switch connected to the FGD212, this one (“main switch”) needs to be linked to channel switch_dimmer
Then try for the second switch switch_dimmer1 or switch_dimmer2

Okay, I use switch_dimmer for S1 and as dimmer for the room light.
I can dimm the light with S1, get the correct feedback on the sitemap, can controll it with the sitemap and get the feedback in the log. switch_dimmer1 and switch_dimmer2 do nothing.

If I press S2, switch_dimmer on the sitemap switch, but the room light doesn’t react!!!

2018-01-22 17:25:27.108 [vent.ItemStateChangedEvent] - OG1_WZ_Dimmer changed from 100 to 0
2018-01-22 17:25:30.289 [vent.ItemStateChangedEvent] - OG1_WZ_Dimmer changed from 0 to 100
2018-01-22 17:25:33.092 [vent.ItemStateChangedEvent] - OG1_WZ_Dimmer changed from 100 to 0
2018-01-22 17:25:35.415 [vent.ItemStateChangedEvent] - OG1_WZ_Dimmer changed from 0 to 100
2018-01-22 17:25:37.717 [vent.ItemStateChangedEvent] - OG1_WZ_Dimmer changed from 100 to 0
2018-01-22 17:25:40.335 [vent.ItemStateChangedEvent] - OG1_WZ_Dimmer changed from 0 to 100
usw.

So now both, S1 and S2, send to switch_dimmer, but nothing to dimmer1 or dimmer2.

I set all association groups to “openHAB controller”

If I switch dimmer2 on the sitemap nothing happens.

I I switch dimmer1 on the sitemap, switch_dimmer and the room light react (switch).

Hi,

I have the same problem with the Fibaro Dimmer 2, I use a normal on/off switch (Parameter 20: Bi-stable input (switch)/ Toggle switch
All dimming done with the app get logged in the event.log, all actions done with the switch do not get logged.
So the app does not show the right state of the dimmer.

This looks like the never ending problems of some versions of the OH2 Z-Wave binding with multi endpoint encapsulation.
So 2 questions are important:

  1. Which version of the Z-Wave binding do you use (snapshot or dev) and which version? (Best to look up in Karaf console with the list command)
  2. How did you include the device to your network (by network wide inclusion triggered with Habmin or by including it with your Z-Wave stick) ? If done with Habmin again the intersting point is which version of the Z-Wave binding DID you use IN THE MOMENT OF INCLUSION (snapshot or dev) and which version?

Unfortunately any different combination of 1 and 2 can lead to non functioning feedback.

Thank you for your feedback.

I have to look for the versions.

I installed openHAB 2.0 and the zwave binding in december 2017, updated to openHAB 2.1 in january 2018 and include the dimmer2 in 2018 (openHAB2.1).

Unfortunately any different combination of 1 and 2 can lead to non functioning Feedback.

Is the solution to exclude the dimmer2, update openHAB and update the zwave binding, and include the dimmer2 again?

Same issue here.
FGD212 was included via snapshot (HABmin) about half a year ago and I’m using the development version from 20180120.

What can I do to solve the problem? Exclude, update and include the dimmer2 again?

I think it would be worth a try. Alhough I do not operate any Fibaro Dimmer 2 anymore myself so just a guess. I switched completely to Qubino Dimmers as they can dim loads from 3W - 200W (whereas Fibaro Dimmers need at least 50W which is not suitable for LED lamps without additional bypasses).

Hello,
updates, new inclusions, etc. does not help. Now I bought a new dimmer 2 (because I wanted to try it with the newest software in the dimmer 2), and with the new dimmer 2 the feedback works.
Unluckily I cant update the old dimmer2 to the new software, becouse I dont use the original controlcenter.

Now I have the feedback from all channels from dimmer2 in my paper UI.

And here is the next mystic problem:
I see the feedback in paper ui, and I can control my dimmer2 and my wallplug with paper ui.
But in basicui, I dont see the updates and I cant control the dimmer2 or the wallplug.
But I see the update from the motionsensor in both surfaces, paperui and basicui.

And the second problem is:
I connected the item “test2” with the dimmer2 “dimmer2” channel and with the wallplug switch channel.
If I press the dimmer2 S2 button, I can see in paperui how the states from “test2” and “dimmer2” changes.
But the wallplug doesnt change physically.
But if I use paperui to change the state from “test2”, the wallplug change physically his state too (with 2-3 seconds delay).

Why the states changed in boths ways, but the wallplug only react on the online way?

I dont work with rules in this example, I only linked the things and the items with paperui.
If I press the button on the wallplug, the wallplug physically changes the state, but doesnt update paperui.

I found the problem with an friend:

my raspberry dont load the files from VS studio editor.
I changed the links in paperui, what was a mistake.
I have to work in vs studio only.
I still dont know why the files from studio editor doesnt loads, but we found the main mistake.

So, I’m new to openhab and have been experiencing the same ‘no feedback’ from fibaro dimmer 2 issue that I’ve seen on many threads.

Last night, I got it working. Annoyingly (my fault, I was getting irritated and broke the ‘only change one thing at a time’ rule so here is exactly what I did)

First, my enviroment
Ubuntu 16.04 (yes, I know - I will update one of these days)
OpenHab (installed testing via apt). This is currently 2.5.0.M1 Milestone build
Using Aeotec Zwave Gen5 usb stick

  • First I shut down openhab (systemctl stop openhab2)
  • Remove Zwave stick from machine (i.e. unmount /dev/ttyACMx)
  • Re-insert Zwave controller
  • Start openhab (systemctl start openhab2)
  • Wait for startup to complete (tail the openhab log file)
  • Navigate to paper UI, select dimmer 2 module from Configuration->Things, click edit. Scroll to the bottom and ‘show more options’. Then switch on both heal and re-init device, and save

Give it 10 seconds or so… walk over to your Dimmer and click on your switch connected to S2. Check your log files from events, and hopefully you’ll see it working now!

Note: This is based on having previously enabled scene’s on the dimmer module via the settings config

|'m having the same issue. Been using openhab for 3+ years now. Until now I never really noticed my fibaro dimmer doesn’t send its state back to OH. I’m moving to a new home and been installing more fibaro units and I came across this issue. (its a new dimmer, so not sure it has the latest FW).

I can’t seem to get it’s state to OH when the light is turned on by the wall switch, although when I switched on the light (with S1 wall switch) it does send the changed power consumption. So this must be a setting somewhere (within the dimmer probably).

Is there a solution for this? Or is this a fw issue of fibaro

thanks
philippe

anybody? Is this the same with Qubino dimmer?

In 1 room I like to switch on the light with z-wave dimmer, placed in the wall connected to a push button. I also would like to turn on another light (KNX controlled), but require feedback in openhab to achieve this. I must be doing something wrong no?

thx

Which one? There are several issues in this thread.

Which one? Please provide a link to the zwave database.

Debug log? (Please see the zwave binding docs how to get one)