Fibaro FGFS001 ZW5

Hello, I’m trying to include new Fibaro Flood sensor FGFS001 ZW5. Firmware version is 3.3 and supports Zwave+.
OH includes the device but not recognizes it.
Device certification link is
into the xml file of FGFS001 of the zwave binding db , the device id 1003 seems to be manged so i don’t understand why of this problem.
thank you in advance

Hi. I think you mean FGFS-101 in v.3.3 and not FGFS-001?

This device is in database and normaly works fine.
I have the same problem as you have since 2 weeks. I have four of these devices running on openhab 2.5.10, but since 2 weeks two of them can not be configured via Paper-UI. After i delete one to let them detect automaticaly from z-wave binding, it will be detectet, but can nut be configuered as you describe. There must be a failure in the database, but i don’t know what we can do. So maybe there is one who can help?

1 Like

yep, i mean FGFS-101.
i’ll try to study how db works and then make modifies to allow these devices to be recognized. i’ve never did this before so hope it will not take so long

I can make you hope. I tested the same device with OH3 M5 and works fine after the first detection and the other 3 devices on OH2.5.10 are working fine also. It will only be a small problem that can be heal after an update in the database.

so what you suggest me to do with DB? flood sensors will be placed in a production environment so i cannot use OH3 but 2.5.10 instead. another thing: on yesterday i’ve included a sensor in another OH 2.5.10 and after a night, the device has been recognized but…if i trigger flood alarm nothing happens :frowning: so i cannot understand what to do

If your device will not be detected at all, try to exclude the device and reset the device. How to reset the device you find in the device description. Alfter that start including the device an wake it up meanwhile by clicking the tmp button once. If it will not be detected at all exclode and reset it again. It must at least be detected as an unknown device (you did not write as it does).

If it is detected you can import it maybe correctly. If not you can take a look on the xml file for this node.

I think it will be easier for us to wait for someone who can help. I guess it will be a problem after detection the node will not have a correct import in jar.file and xml. Maybe the version is wrong (there are 3 versions in database).

ok, i will try it. meanwhile hope someone will help us

This does not appear to be a database issue, but local to your system.

Maybe someone read who can help so i describe what happend :

After excluding the device an do a hard reset on the device i start new scannig in parper-ui z-wave binding. The binding recordnize a new thing with the warning: “[WARN ] [wave.discovery.ZWaveDiscoveryService] - NODE 52: Device discovery could not resolve to a thingType! 010F:0B01:1003::3.3”.

So the Z-Wave-Binding gets the (i think) right first information from the device:
010F for Manufacturer [010F] Fibargroup
0B01:1003 for Type 0B00:1001,0B01:1002,0B01:1003,0B01:2002,0B01:2003,0B01:3002
3.3 for the Version of the device

Whats happend next?
Openhab2 is unable to read the device fully (i guess) and puts the getting information in “smarthome.config.discovery.DiscoveryResult.json” file.
After taken the device in the openhab2 thing list the information is in the “smarthome.core.thing.Thing.json” file as an unknow device.

    Z-Wave Node 052 (010F:0B01:1003:3.3)

Unknown Device

This device has not been fully discovered by the binding. There are a few possible reasons for this -:
The device is not in the database. If the device attributes show that this device has a valid manufacturer ID, device ID and type, then this is likely the case (eg. you see a label like "Z-Wave node 1 (0082:6015:020D::2.0)"). Even if the device appears to be in the database, some manufacturers use multiple sets of references for different regions or versions, and your device references may not be in the database. In either case, the database must be updated and you should raise an issue to get this addressed.
    The device initialisation is not complete. Once the device is included into the network, the binding must interrogate it to find out what type of device it is. One part of this process is to get the manufacturer information required to identify the device, and until this is done, the device will remain unknown. For mains powered devices, this will occur quickly, however for battery devices the device must be woken up a number of times to allow the discovery phase to complete. This must be performed with the device close to the controller
  1. The device is not in the database.
    Thats whats the failure in my opinion. I have 2 running devices so it was correctly in the database. After an update the binding is not be able to get the right information, so in my opinion its a version or copy and paste failure in the database. The binding is not able to get the complete right information from the device.

  2. The device initialisation is not complete.
    Yes can be, but what can i do except waking up the device hundred times, bring it near to the controler and change the battery?

I am excited which way it will continue.


i’ve completely reset the device to it’s factory defaults and then included again. the device is powered by a power supply so it’s not about wake.
device now is fully recognized and expose channels where i’ve linked items. data arrives but are not at the right channel (or endpoint or so)
this is the log where you can see an alarm detected but nothing is catched by my item

2020-12-11 08:48:31.331 [DEBUG] [ng.zwave.internal.protocol.ZWaveTransactionManager] - NODE 55: Application Command Request (ALIVE:DONE)
2020-12-11 08:48:31.331 [DEBUG] [.openhab.binding.zwave.internal.protocol.ZWaveNode] - NODE 55: resetResendCount initComplete=true isDead=false
2020-12-11 08:48:31.331 [DEBUG] [.openhab.binding.zwave.internal.protocol.ZWaveNode] - NODE 55: Incoming command class COMMAND_CLASS_ALARM, endpoint 0
2020-12-11 08:48:31.331 [DEBUG] [.openhab.binding.zwave.internal.protocol.ZWaveNode] - NODE 55: SECURITY NOT required on COMMAND_CLASS_ALARM
2020-12-11 08:48:31.331 [DEBUG] [e.internal.protocol.commandclass.ZWaveCommandClass] - NODE 55: Received COMMAND_CLASS_ALARM V5 NOTIFICATION_REPORT
2020-12-11 08:48:31.331 [DEBUG] [ernal.protocol.commandclass.ZWaveAlarmCommandClass] - NODE 55: NOTIFICATION report - 5 = 0, event=0, status=255, plen=0
2020-12-11 08:48:31.331 [DEBUG] [ernal.protocol.commandclass.ZWaveAlarmCommandClass] - NODE 55: Alarm Type = FLOOD (5)
2020-12-11 08:48:31.332 [DEBUG] [rg.openhab.binding.zwave.handler.ZWaveThingHandler] - NODE 55: Got an event from Z-Wave network: ZWaveAlarmValueEvent
2020-12-11 08:48:31.332 [DEBUG] [rg.openhab.binding.zwave.handler.ZWaveThingHandler] - NODE 55: Got a value event from Z-Wave network, endpoint=0, command class=COMMAND_CLASS_ALARM, value=255
2020-12-11 08:48:31.332 [DEBUG] [ng.zwave.internal.protocol.ZWaveTransactionManager] - NODE 55: Commands processed 1.
2020-12-11 08:48:31.332 [DEBUG] [ng.zwave.internal.protocol.ZWaveTransactionManager] - NODE 55: Checking command org.openhab.binding.zwave.internal.protocol.ZWaveCommandClassPayload@47e11c.
2020-12-11 08:48:31.332 [DEBUG] [ng.zwave.internal.protocol.ZWaveTransactionManager] - Transaction completed - outstandingTransactions 0

What is your Item configuration?

Switch allagementoBagno2 “Allagamento2 [%s]” {channel=“zwave:device:d17171b5:node55:alarm_flood”}
Switch allagementoBagno2Binary “Allagamento2 bin1 [%s]” {channel=“zwave:device:d17171b5:node55:sensor_binary1”}
Switch allagementoBagno2Tamper “Allagamento2 tamper [%s]” {channel=“zwave:device:d17171b5:node55:alarm_tamper2”}

openjdk version “1.8.0_272”
OpenJDK Runtime Environment (Zulu (build 1.8.0_272-b17)
OpenJDK Server VM (Zulu (build 25.272-b17, mixed mode)

OH 2.5.10

Does anything show for the Items in the event log?

no, absolutely nothing. i don’t know if i can listen on the eventbus to intercept messages or something else

tried to downgrade from openjdk version “1.8.0_272” to openjdk version “1.8.0_252”
tried to use last snapshot of zwave binding versione 2.5.11
i’m running out of ideas

The device is battery powered. Have you manually woken it up so that it can complete initialization?

1 Like

No, it’s dc powered so it’s not about wake up

If that is a device that can be powered either way, it must be dc powered when included into the Z-Wave network. Otherwise it behaves as if battery powered,

If it is normally battery powered & you connected it to a DC power source, it will still behave as a battery powered device.


… and the fact that you have a Channel named Battery Level (from the pic) is a definite sign that there is a battery!