Fibaro FGMS-001 Showing as Unknown Device

I’ve been searching the forum trying to figure out how to create a debug log because I’m having issues with my Fibaro FGMS-001 motion sensor. I see that you can do it through Karaf but can’t figure out how to get that to run on my system. I have openhab2-offline running on my RPi3 and I’m SSH into it from a Windows 10 computer through Putty. I have started the openhab server by running and and they both run fine but I don’t see a debug log anywhere. Any help would be appreciated, thanks.

This is what I would do on my ubuntu server. I assume the same would work on a Pi.

From the openhab directory, you should be able to run this to enable debug log level on the zwave binding:

./runtime/karaf/bin/client “log:set DEBUG org.openhab.binding.zwave”

You would then see debug entries in ./userdata/logs/openhab.log

To revert to info level you would run this:

./runtime/karaf/bin/client “log:set INFO org.openhab.binding.zwave”

What’s the issue you’re having with the FGMS001?

Okay there is some progress. I was able to get it to try to log in by typing:

/usr/share/openhab2/runtime/karaf/bin/client “log:set DEBUG org.openhab.binding.zwave”

I got a response of:

client: Ignoring predefined value for KARAF_HOME
Logging in as karaf
Authentication failed

It’s showing up as an Unknown Device.

Hmm. I guess you could try logging into the console using this. Do this while you are logged into the Pi.

ssh karaf@localhost -p 8101

The password is karaf.

Assuming you get logged into the console, you can type

log:set DEBUG org.openhab.binding.zwave

Perfect, that worked! Thanks so much!

As for it showing up as unknown… If it’s still showing unknown, you’ll want to get the manufacture id, product type, product id, and firmware version of the device. Then compare that to what’s in the device database on Chris’s HABmin site. FWIW, I have a FGMS001, and I had to submit a DB change in order for it to be detected.

Yeah it is, that must be the problem. Mine is showing these values:

Node: 15
Manufacturer: 010f
Type / ID: 0801:2001
Firmware Version: 3.2
Generic Class: GARAGE_DOOR

and the debug log is showing:

2016-06-29 14:02:58.140 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 15: Polling…
2016-06-29 14:02:58.146 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 15: Polling deferred until initialisation complete

Hmm. That’s the same Manuf, Type, ID, and FW as my FGMS001.

You may be running into the same problem I had.

Maybe try disabling security as described in the issue. Then delete the node, and rediscover it. You shouldn’t need to exclude/include it.

I looked and the only options I have under “Secure Inclusion Mode” are “All Devices” & “Entry Control Devices”. I don’t see a “Do Not Use Security” option. I have it currently set to “Entry Control Devices”.

Do you see something in HABmin that looks like this? What version of HABmin are you running?

Yes, this is what mine shows.

I’m using HABmin2 version 0.1.6

That’s really odd. I’m at a loss. I have three separate systems all running HABmin2 0.1.6 and I see that option on all three systems.

I’ll try changing the topic title and see if anyone else has any ideas. Thanks for your help!

Not sure if it helps, but my FGMS-001 also showed up as unknown with the message:
Device discovery could not resolve to a thingType! 7FFFFFFF:7FFFFFFF:7FFFFFFF::0.0

I got it showing up correctly after remove and replace the battery. Might be worth a try?

It’s nothing to do with the HABmin version, it’s the ZWave binding version that is important for this option. If it doesn’t show the “No security” option, then it’s probably an old ZWave binding.

I just did a fresh install of openHAB2 the online version last night and currently have binding-zwave - 2.0.0.b3 according to Paper UI. Is there a newer version that I can download from somewhere?

Yes - b3 is a month or two old now I think - you should grab the nightly snapshot from cloudbees.

Okay thanks, I’ll try it out and see if that fixes my issues.

I should add that I haven’t followed this thread, so I don’t know if it will solve your issue - I was really just responding to the above point…

There is an issue with devices showing as unknown - if you have a problem with this, please email me a complete log of the binding startup.

Should I use the target or the test version of the binding?