Fibaro FGMS001 not recognized by Z-Wave binding V2

Hi @chris,

I have an issue with an (old) Fibaro FGMS001 (not Wave +, I think).
It is not recognized by the Wave binding.

I have found its reference in the ZWave DB (FGMS001, 0800:1001).
It sound that it is because of a firmware version 4.0 upper than the 2.8 that is in the database.

My first idea was to upgrade the firmware version in the database, but this raised an error.
I discovered then that another FGMS001 was referenced with the higher firmware but not for the 0800:1001).
So, I have added the reference 0800:1001 to this one and revert the first one to the previous value.

Hopefully, I hope this is the right thing to do.

If not, let me know.
Just in case, I join the XML : node10.xml (14.6 KB)


Ok @chris,

I made a mistake and a wrong reading of the XML :slight_frown: sorry for that.
I put everything back in the database.

I thing that the tag to look are (finally):

In the database I found:
References (Type:Id) 0800:1001,0800:2001,0800:3001,0801:1001,0801:2001
Firmware Versions All up to 2.8
Protocol Version 3.067

What is the correct way to change the protocol version ?

I’m not sure I follow… What do you want to change? Do you mean to change it in the database, or something else?

Currently, your device is using firmware 2.6, and the database is version 2.8, so that should be ok I think? In any case, both versions have the Type:Id for your device, so it should be found be one of them no matter what the version.

What version of OH2 are you using? Is it VERY recent (ie in the past few days) or is it quite old? Can you provide a debug log?

I downloading the binding the 9th may.

What I wanted to do is to check in your online ZWave database the reason why the device was not recognized as being in the database by the binding.
I wanted to do that by checking the information that are in the XML of the node.

What I found is:

  • the type/model exist in the database
  • I made a mistake reading the firmware number, with makes me thought the problem was there (but as you underlined it it is not the case).

Is the protocol version or anything else used to match the device against your ZWave database ?

I am going to create a log according what you have written in “Debugging openHAB Z-Wave binding”.

No - I don’t mean the binding - I mean the OH2 runtime. In any case, you need one newer than the 10th.

The application version, the type and ID are all that is used.

Please upgrade to the latest versions first and see if the problem is still there.

For reference.

All was downloaded the same day.

Will do and let you know.

Thanks for all.

Thanks @chris, it is solved by the upgrade.

Great stuff - thanks for the feedback.

Sorry for intervening to an already resolved issue but I kindly ask for your assistance for the pairing the same device. I have two FGMS that use to perfectly work with the OHb2, Then I made a clean install of the b3 version and the devices are not recognized by the controller (Unknown Device). I removed the devices from the controller and then re-included but had the same issue. My devices send their updates when wake-up as i get their properties

zwave_class_basic ROUTING_SLAVE
zwave_class_generic BINARY_SENSOR
zwave_deviceid 2147483647
zwave_frequent false
zwave_nodeid 4
zwave_version 0.0
zwave_listening false
zwave_routing true
zwave_beaming true
zwave_class_specific ROUTING_SENSOR_BINARY
zwave_manufacturer 2147483647
zwave_devicetype 2147483647
zwave_neighbours 1,3

My controller is and AEON Z-stick and I run OHb3-offline and use the z-wave bind that comes with it (binding-zwave - 2.0.0.b3)

Thank you

I would suggest that you need to wake up the device so that the binding can get the device information. The values in the device manufacturer/type/id indicate that this hasn’t yet taken place.


I have already done that several times and have a strange situation where the associated node5.xml seems to have the right values although these are not present in Paper UI.

I re-submit the properties from paperUI for node5 for matching the node5.xml file :

zwave_class_basic ROUTING_SLAVE
zwave_class_generic BINARY_SENSOR
zwave_frequent false
zwave_neighbours 1,3
zwave_version 0.0
zwave_listening false
zwave_deviceid 2147483647
zwave_nodeid 5
zwave_routing true
zwave_wakeup_time 2016-05-26T06:08:23Z
zwave_beaming true
zwave_class_specific ROUTING_SENSOR_BINARY
zwave_manufacturer 2147483647
zwave_devicetype 2147483647

and attach the node5.xml file

node5.xml (15.8 KB)

Thank you for your precious time

The parameters should be updated once discovery has happened, but it sounds like this is not happening. Do you have a debug log you can email me?

Something that might solve the issue is to delete the thing, then re-add it? However I would like to see a log if possible since this should be updated automatically but probably there is a condition that is stopping this…

I’ve also done that with removing and re-including all devices … I attach a debug output but I suppose u need the one which is created during the inclusion ? If yes then I can send it later on when I have access to my device. The attached is when starting OH service.

The message which appears is the following

NODE 5: Transaction not completed: node address inconsistent. lastSent=5, incoming=255

node5_zwave_log.xml (443.0 KB)

No - I didn’t say to remove and re-include the device. Just delete the thing and add it back - do not exclude it. So, delete the thing, then click on discovery and it will immediately be found again, and you can add it - don’t do an exclude.

This is fine - it’s not an error, just a debug message relating to transaction management.

Well I’m a bit embarrassed because node5 now appears just fine by deleting and then re-adding the thing.

Now the problem remained with node4 (same type of device FGMS). I did the same thing but had no luck, it still appears as UNKNOWN DEVICE. There’s no “node4.xml” file created for this node. I attach only the debug information when discovery was active

node4_FGMS_discovery.xml (186.3 KB)

Again thank you for the immediate feedback

I had the same problem with my FGSS001 smoke detector. I assume the FGMS is battery powered? Battery powered devices can be frustrating. I find that giving it a little time and triggering the alarms/sensors can help, that and deleting the THING and re-adding got me there in the end… can be very annoying.

Liam and Chris

Thanx for your kind replies. This thing drives me nuts… now I can see that node4 exchanges messages with the controller (attached debug file) but still I have no node4.xml file nor I can see anything in paperUI or Habmin …

Yes this is a battery device and it is already installed for a day now …

node4_FGMS_debug.xml (230.8 KB)

In the log for node 4, the device has not woken up - have you tried to wake it up yet?

Yes Chris, just came home and woke-up the device and everything is set correctly. I think I mixed up when re-installing things after the upgrade to OHb3.

Thank you very much for your kind assistance