Fibaro FGR-222: with z-Wave Snapshot 2.3.0 the device is unknown

Because another Problem a have update the z-wave binding form snapshot 2.2.0 to snapshot 2.3.0.

With 2.2.3, the installed shutter control modul Fibaro FGR-222 is showed as unknown device with no parameter. when i change back to snapshot 2.2.0, the device is known with all parameters.

the roller shutter works with snapshot 2.2.0 and 2.3.0. Only the parameter are in 2.3.0 not shown.

with snapshot 2.2.0:

with snapshot 2.3.0:

is this a known problem?

date of z-wave snapshot 2.2.0: 24.11.2017
date of z-wave snapshot 2.3.0: 29.12.2017

You have to wake it up a multiple times while include mode.

I think the thing ID got changed in the database with some of the tidying up that was done recently. If you delete the thing, and add it back, it should sort itself out.

I think that’s not the solution. the first problem with 2.3.0 was at inclusion. the inclusion of a new fibaro FGR-222 doesn’t work. It always shown in the Inbox of Paper UI as unknown device.
the inclusie of the new modul did not work until after downgrading to 2.2.0. with 2.2.0 it works fine.
i have try it many time … always unknown device.

If it is shown in the inbox, then the inclusion has worked.

Then it is a database issue - not an inclusion issue. I’d suggest to check the database against your device IDs - as I said there was some cleanup of the database and maybe something has changed.

can I check the database myself? and if so how?

Sure - the database is here. From there you can search for devices and see all the parameters and properties etc of each device.

I had the same issue with “Fibaro FGMS001 Motion Sensor”. It was recognized as “unknown device”.

It didn’t add this during inclusion as long as it was detected as “FGMS001 Motion Sensor”. Therefore I had to wake up the device 10-20! Then at some point it was recognized correctly.

The id got changed to reflect the correct name for that device: FGRM222 are the older devices, FGR222 are the newer ones (Fibaro Rollershutter 2)

Deleting the things and readding them worked without any problems (snapshot runtime #1148, dev/security zwave binding 20171230).
All linked channels and items were still available, the only thing I had to do again was setting the “invert percent” option …

I have the same problem.

Paper UI


What do I have to do exactly?
In the paper UI delete the Things? -> yes
Then search the Zwave Devices via the Inbox again? -> yes


That’s it? -> YES thats it!

Thank you for your support