Fibaro FGS221 won't get recognized OH2


I’m running a fresh install of OH2 and OH isn’t able to detect my switches correct.
Updated to the latest OH-version, also i tried installing the latest snapshot of zwave (the refactored for secure devices) but neither with this addon or the addon provided will it recognize the switches. Can i do something to reload the database?
thanks in advance

At least the device is in the database.
Can you be more specific on “not recognized”? Did you include it properly? Whats you’re controller?
no OH2 discovery? Does DEBUG log contain any valuable info about the NODE?

I’m using a gen5 aeotec zwave controller on /dev/USB-ZWAVE (using persistence). On the paper-UI I’ve included first the serial zwave controller and set the location. After that i did a search for the devices. All the double switches come up as:

Z-Wave node 11 (010F:0200:100A:2.1)
Unknown device


The singel switch (fgs211) are detected fine, the RGBW and greenwave are also found just fine. It worked on the 2.0 version of OH2.

sorry, device should be FGS221 (changed topic title)
but that is also in the database (version 2.1 as well as 1.9)

Can you somehow confirm the firmware your switches are on? I could only imagine having a differnent FW or the firmware string somehow differs from default.

Might be woth to do the following:

  • choose sample switch to debug
  • remove that thing frmo config
  • stop OH2
  • remove the XML file
  • set OH2 to debug
  • start OH again
  • upload oh2 log extract about that node when OH is re-adding

I am experiencing this too, same device. I am wondering if there could be some corruption of the device database? @chris? I tried both the development version and the snapshot version of the binding.

I very much doubt the database is corrupt - I don’t see how this could be possible as a corruption would mean the XML files almost certainly wouldn’t read. We can see that the file is intact at least… I think there’s something wrong with the version comparison since if I look at the log you sent, the devices that resolve have no version, and the ones that don’t resolve have version constraints… I therefore think that with the new version, your lock will now resolve as I’ve removed the version…

I’ll do a quick update of my OH2 test version (on my website) shortly to add some more debug in - @O1av if you could test and send me another log it would be useful.

Yes, I’ll be happy to produce some new logs!
I still do not understand though why I got the same problem also with the ordinary install of the binding (2.1.0-snapshot, not the development branch) when I tried this earlier today.

Ok - I’ve updated the binding. I’m quietly (!!) confident this might now be fixed - please give me good news! :wink: .

I think the bug was introduced recently as I didn’t properly check the comparison - the same bug is in both versions if I’m right…

:+1: I’ll give it a go right away!

Now initializing all the nodes, I have several fgs221 showing up properly - looks promising.
The log is growing huge - do you want everything?(soon 3 files each 10mb) (I have 30 nodes initializing).

1 Like

No - don’t worry about the logs. It sounds like the problem with devices not being found is solved so that was the point of this version - thanks for testing :slight_smile: .

Thanks again to you Chris!! :smile:

Thanks a lot Chris! Works perfect!