Fibaro FGS222 - not switching properly

I, too, kept and still keep (OH 1.8) seeing that message on a FGS-222.

@chris: seems that on toggling an input switch, the FGS-221/222 have always been sending messages with epid = 0.
How to cope with those? Do you know of any FGS config to map it to the corresponding endpoint ?
Or is there a way for the binding to ‘fish’ these and map them to existing items (which have epids = 1 and 2) ?

I had seen that behavior on FGS-221 for a long time, too, but it seems to have disappeared there recently (since 1.8, maybe earlier). Not sure, though.


If all status information is sent using endpoint 0, then no, there’s no way back from this. Is this for an old version of the switch - I have plenty of these switches and they report the endpoints correctly…

The thing to remember here is that originally, associations were designed to control things - not to report status to a central server. So, you didn’t want endpoints being used - you just wanted the control information. Now of course it’s normal for associations to be used to report state changes - there are still some new devices that do this (I think the Philio devices) but most I’ve send use multi_instance encapsulation.

I don’t immediately see any setting in the device to change this, and I didn’t change anything in my switches to get this to work - they just do.

What version are you using?

Hi Chris,

I have a relay switch Version 4, Protocl Version 3.52, Application Version 2.2.
Is this what you were asking for?

Yes - so, you have an older version than mine… I’m not sure why it would be different to mine though and I can’t see any configuration in the manual.

If you want to get a log where you’ve pressed both switches, I’ll take a look, but I’m not sure it will help a load…

Thanks, @Chris,

will do as soon as I have time to check again.


I found the main issue:
I wasn’t aware that the installed lighting already used a relay in the wall behind the lamp (stupid me ;-).
After disconnecting the ‘old’ relay, it works almost as expected.
So I can switch both lamps sending the command ON or OFF respectively.

The only thing what’s not yet perfect, is that the one of the OH switch items is not updated properly, if the lamp is switched by the wall-switch.
The other item based in the second fibaro switch is working perfectly.

The update association is set to the main node 1.

Anyone an idea, why the two switches are updated separately?

hi all,
I have the same problem, the switching in wall and by the app are working ok, but the status changes are not updated, so if the light is switched on by the in-wall switch, I continue to see it off on openhab, if I then switch ON the openhab item nothing happens as the light is ON, if I then switch the openhab item to OFF the light is correctly switched OFF.

It’s a new FGS-222 version 4 protocol version 3.52 application version 2.2

Is this the case for both switches?
I did not recognize that there was already a relay in my circuit. Removing the original one fixed the problem.
However, I still have one switch of both within the FGS-222 which does not update properly when switched by he wall switch.

Yes, I am not at home now so I can’t verify another time but I’m pretty sure that only one of the switches is not updating properly the status when switched from the wall switch.

I made some debugging on this issue and you can find what I discovered in this post:

this is a similar topic, we are finally talking about the same issue on two topics so I think it’s a common problem with the fibaro FGS-222.

edit: as written in the linked topic the issue seems to be resolved with this configuration for sw1:
{ zwave=“7:command=SWITCH_BINARY” }
and this for sw2:
{ zwave=“7:2:command=SWITCH_BINARY” }
now all the wall switches are updating their statuses to openhab.
thanks for the support and leave a feedback if this config works for you too, so it will be helpful for the next users.

Switch SWLuceCameraLetto "Luce camera da letto [%s]"           (GLights, GCameraLetto, GPersistLast)   { zwave="7:command=SWITCH_BINARY" }
Switch SWLuceCameraLettoCorridoio "Luce camera da letto (corridoio) [%s]"           (GLights, GCameraLetto, GPersistLast)   { zwave="7:2:command=SWITCH_BINARY" }

That’s exactly what fixed my problem!
Now both switches are updated properly!!!
Thanks to all of you.
No major issues leftism OH.
Thanks again!

Best regards, NCO

Hi guys,
Just got a FGS222 and got it working in OH but I have a question:
My switches are like the ring bell one and when I press and release the light turns on and off on the release! How can I set the FGS222 with this kind of switches? I want it to work like this:
When pressing and release the switch to turn on and pressing again and releasing to turn it off?
Is there any way to do this using FGS22 with this ring bell switches? Or do I need to replace it with a normal switch that pressed stays pressed to on and same to off?

Thanks all.

Yes - this can be configured fine with the Fibaro switches (I have a house full of them with this configuration).

I think you need to change parameter 14 to set it to use the monostable switch.

Can you please tell me how to change this parameter 14? I’m not using a Fibaro home hub but I use a zwave stick gen5 from aeon labs! Is this possible with my configuration?
Thanks for the answer.

Use HABmin. It will provide a list of all the configuration parameters for the device and you should be able to change parameter 14 to be monostable.

Thanks man, that helped a lot :slight_smile:
I would like to ask for the community help for another two problems I have now with this FGS222:

  1. On the s1 slot when I press the button I hear the relay and then a continuously noise like a short circuit. This noise stops when the contact is off and the light is off! I don’t have this problem on the s2 slot of the devices.
  2. Using the eg above I’ve created two items like this:
    Switch relay1 “relay1 [%s]” { zwave=“3:1 command=SWITCH_BINARY” }
    Switch Relay2 “relay2 [%s]” {zwave=“3:2:command=SWITCH_BINARY” }
    And I can turn the both lights on or off from OH.
    The problem is that when pressing the wall switch buttons, only the one connected to S2 is updating the status in OH and the one connected to S1 it stays off all the times!

Does anyone meet this situation with FGS222? I’m thinking that the device has an internal problem or there is something else!

One remark is that the FGS was connected according to the diagram which came in the package and there are both neutral and live wires in the wall socket.

Thanks all’

I’m not sure about the buzzing, but if the items are really how you have them specified, then the first one is wrong. It has a space between the endpoint and the command - it should be a colon -:

Switch relay1 "relay1 [%s]" { zwave="3:1:command=SWITCH_BINARY" }
Switch Relay2 "relay2 [%s]" {zwave="3:2:command=SWITCH_BINARY" }

This might explain the feedback not working when you press the button - maybe. Alternatively, what association is configured for feedback to the controller?

(I’m not sure about the buzzing issue, but it doesn’t sound good!)

your 2nd problem is related to the item configuration.
I had the same problem (see above).
You just need to change

somehow OH handles the first relay differently than the second (you need 3:2:command=… at the second)

Ah - good point and well spotted @NCO . I forgot that some of the newer Fibaro devices don’t seem to properly use the multi instance…

Thanks guys for help, I made the correction in the first item definition and now it’s updating well!
I still got the buzzing in the device but I took contact with the supplier and hopefully I’ll get a new one or at least a response.

Thanks for the help!