Fibaro FGSD-002 loosing connection

I have four Fibaro FGSD-002 smoke detectors connected to my OpenHAB 1.8.3 and it happened now four times that one of those detectors did loose the connection to OpenHAB somehow. (It happened to almost any of the detectors once, only on one twice)

The battery on all of those devices is still at 100%, but they don’t seam to send any more packets to the OpenHAB controller. The only way I found to solve this problem is either pull out the battery, wait and plug it back in or sometimes I need to completeley re-pair the device to the controller so it gets a new node id.

I’ve also started a Z-Wave range test, which returned “good”. (green light)

Does anyone else also have this problem? Is there anything I could provide to help find the source of this problem?

One of my smoke sensors has again lost the connection. I tried the Z-Wave range check on the device and it blinked red. (No connection possible) What could be the problem here?

I would guess it’s too far from the controller or other devices? I don’t know exactly what it’s doing, but the doc seems to indicate it should send a message directly to the controller, and also try routing via other nodes.

I would suggest to update your binding to 1.9 though - 1.8.3 had a database problem. I very much doubt it’s related, but it’s probably best to use the latest version.

The smoke sensor is about 2 meters away from the controller and I am already using the 1.9 binding. Any other ideas?

Not really. You could check the logfile during the test to see if anything is being received - I’m guessing that the device is sending data to the binding, although it might not be seen if it’s only a NO_OP command…

Sorry - not very helpful I’m afraid.

I’ve enabled the Z-Wave trace log and started the connection test on the smoke sensor, but no packets of this node where logged. Maybe the smoke sensor looses the settings completely somehow. I now did a complete factory reset of the smoke sensor and added it again as new node. Maybe this will help.

one of my fibaro also has that sympton now.
it just does not communicate with the controller anymore.
big bug from fibaro …esp. on a smoke detector

did you get any other / new insights?

The problem on my smoke sensors did not appear in the last 6 months. Maybe the update to the latest Openhab release fixed this problem.

Thsat actually must be a buggy device cause if it is part of a network but wont sent anything. Mine did work now for almost 2 years and all of a sudden has that bug.

It still shows in a selftest to be part of the network. The controller has the node on it.

But a “range test” of the device shows it cannot communicate with the network (red). I have 50+ mains … so it should definately be reachable. :slight_smile:

@chris
just wondering why a smoke detector shows “motor control” as specific class…
could the db be the problem?
https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/129

This information doesn’t come from the database. It might be a naming error in the binding or in the device itself. Either way, it won’t matter as this information is not used by the binding.

Hello there,

I would like to revive this topic again.

I am using several Fibaro smoke sensors (FGSD-002) around the house as well as Fibaro motion sensors (battery devices). Today it happened the third time that some of the devices do not communicate with OpenHab anymore. I typically realize this when one of the devices starts beeping because of low battery.

The picture is always the same:

  • Some devices are still communicating, some not
  • The devices are still displayed as online in OpenHab
  • I cannot exclude the devices from OpenHab anymore
  • When pressing the wake up button on the device, OpenHab does not receive anything

It is not all of them, only some, and I cannot see a pattern. Most of the time is only the smoke sensor devices, but it also happened for some of the motion sensor devices at least once.

To recover I add the device again to OpenHab and edit my items files to the new node id. There is no reset on the device required, therefore I assume it has no controller anymore?

I am not sure what causes this, maybe a reboot of my Openhabian, maybe a system upgrade or maybe only when the power is lost on the ZWave controller (I sometimes perform a backup (image) of my flash disk).

Did someone found a solution meanwhile?
Is there a better procedure to recover the connections instead of re-adding them?
Could it be because I have setup a quite high wakeup interval of 21600 (6 hours) to save battery?

Thanks a lot!
Christian