Fibaro FGSD002 smoke sensor / recurring error log at wakeup

I have successfully integrated this device in OpenHAB1 (latest OH1, latest snapshot zwave binding). I am getting all values I want to have (smoke, heat, battery, tamper, temperature).

But having a look a the log files, I can find this recurring error log:

2016-07-01 19:32:20.694 [ERROR] [WaveController$ZWaveSendThread:1347]- NODE 7: Timeout while sending message. Requeueing - 2 attempts left!
(attempt counter is variable)

This message appears every 6 hours which is exactly the wakeup period. So I think there is a relation. And when the attempt counter is 0, I’ll get:

`2016-07-02 06:40:36.918 [WARN ] [WaveController$ZWaveSendThread:1355]- NODE 7: Too many retries. Discarding message: Message: class = SendData (0x13), type = Request (0x00), payload = 07 03 31 04 01

Additionally, in HABmin the device often has a yellow button. I think this is also because of the failing retries (at least this is was the wiki says).

Is this something to pay attention at? Anyone with this sensor has made similar experiences? I can not see why this error appears, but I haven’t made a debug log yet…

Please provide a debug log - preferably from the startup, but at least one that shows what is happening around this time.

Thanks chris. Here is the debug log. I made a startup at about 11:30, and the wakeup (with the error) is at about 12:40 today.

zwave.log.json (945.1 KB)

I’ve made an update to the database - let’s see if that helps with tomorrows binding…

Thanks! Do I only have to exchange the jar? Or something else like deleting the node xml or anything similar?

And just to ensure that you update the right binding: I’m on OH1. :wink:

Thanks again,

Yes - you will need to update the JAR (and yes, I have updated OH1 :wink:). It will build tonight, so grab tomorrows version from cloudbees…

I updated the jar with the todays version from cloudbees. Unfortunately, at wakeup, the same error message occurred:

2016-07-03 12:46:01.767 [ERROR] [WaveController$ZWaveSendThread:1347]- NODE 7: Timeout while sending message. Requeueing - 2 attempts left!

I have turned DEBUG off, so if you need another DEBUG log, I have to activate it again and wait until the next wakeup (6 hours).

Any other idea? Maybe it’s a range problem? Or would this lead to another kind of message?

Yes - I need a debug log. It’s impossible to say if this is the same error otherwise.

I had some kind of strange behavior with this node (doesn’t know if this was related to the new binding). It was always gray, name/location entries were gone and I couldn’t define new names and some other stuff.

So I’ve excluded the device, deleted the xml, done a device reset and re-included it.

For now, the error seems to be gone.