Fibaro Multi/Motion Sensor FGMS-001 does not work correctly

Platform information:

  • Hardware: Raspberry PI3
  • OS: Linux raspberrypi 4.14.74-v7+ #1149 SMP Mon Oct 8 17:39:42 BST 2018 armv7l GNU/Linux
  • Java Runtime Environment: java version “1.8.0_191”
  • openHAB version: 2.3.0

Hey all,
i just added two new Fibaro FGMS-001 Multi Sensor. The Binding works correctly, so I can see the sensor as thing, and I have:

  • Temperatore
  • Luminance
  • Motion Alarm
  • Tamper Alarm
  • Battery Level
  • Alarm general

Only the battery level, luminance and temperature shows me a value at HabPanel. The rest is shown as null. Also when I shake the sensor, tamper and motion alarm is null, the event log shows nothing.

Do you have any ideas what I can do?

Thanks
Tobias

In PaperUI do you have all of the above listed and selected when you click on the thing?

Yes I do. All are listed there

With all channels selected?

I would suggest to use a newer version of the binding. 2.3 is now quite old and there have been a lot of changes.

The Binary Sensor is not selected, but all the rest.

fibaro2

Sorry, what should I update? OpenHab 2.3 is the newest, isn’t it?

2.3 is the newest stable, but this is now very old and there have been a lot of changes to the ZWave binding in 2.4 that I think will solve your problem. I would suggest to upgrade your system to use 2.4M5.

Ahh ok clear. I never done that before, so I followed this guide:

Uninstall the stable binding from the Paper UI -> Add-ons -> Bindings.

Download the latest .jar snapshot from the following location:
https://openhab.ci.cloudbees.com/job/openHAB2-Bundles/lastStableBuild/org.openhab.binding%24org.openhab.binding.zwave/ 1.2k

Copy the .jar file to the addons directory:
sudo cp /path/to/download/org.openhab.binding.zwave-2.4.0-SNAPSHOT.jar /usr/share/openhab2/addons


Restart OpenHAB2:
sudo systemctl restart openhab2

At PaperUI ZWave isnt shown as installed. When I try to connect to Karaf Console, followjng message appears:

ssh -p 8101 openhab@localhost
ssh: connect to host localhost port 8101: Connection refused

and/or

openhab-cli console

Logging in as openhab
Failed to get the session.

What I’m doing wrong?

The advice was to upgrade OH, not use a 2.4 snapshot.jar. You can use openhabian tools to upgrade from 2.3 to 2.4.

Ok now its clear. Without updating to the newest snapshot, its one of the two Fibaro sensors is working fine.

But there is a problem with the second. The second battery gets empty within one day so I checked the logfiles:

openhab.log

2018-11-03 12:08:05.858 [WARN ] [l.serialmessage.SendDataMessageClass] - NODE 3: Already processed another send data request for this callback Id, ignoring.
2018-11-03 12:08:36.287 [WARN ] [l.serialmessage.SendDataMessageClass] - NODE 3: Already processed another send data request for this callback Id, ignoring.
2018-11-03 12:08:56.402 [WARN ] [l.serialmessage.SendDataMessageClass] - NODE 3: Already processed another send data request for this callback Id, ignoring.
2018-11-03 12:09:06.504 [WARN ] [l.serialmessage.SendDataMessageClass] - NODE 3: Already processed another send data request for this callback Id, ignoring.
2018-11-03 12:09:16.641 [WARN ] [l.serialmessage.SendDataMessageClass] - NODE 3: Already processed another send data request for this callback Id, ignoring.
2018-11-03 12:09:36.753 [WARN ] [l.serialmessage.SendDataMessageClass] - NODE 3: Already processed another send data request for this callback Id, ignoring.
2018-11-03 12:09:47.014 [WARN ] [l.serialmessage.SendDataMessageClass] - NODE 3: Already processed another send data request for this callback Id, ignoring.
2018-11-03 12:10:27.437 [WARN ] [l.serialmessage.SendDataMessageClass] - NODE 3: Already processed another send data request for this callback Id, ignoring.
2018-11-03 12:10:37.566 [WARN ] [l.serialmessage.SendDataMessageClass] - NODE 3: Already processed another send data request for this callback Id, ignoring.
2018-11-03 12:10:43.467 [WARN ] [l.serialmessage.SendDataMessageClass] - NODE 3: Already processed another send data request for this callback Id, ignoring.
2018-11-03 12:10:49.235 [WARN ] [l.serialmessage.SendDataMessageClass] - NODE 3: Already processed another send data request for this callback Id, ignoring.
2018-11-03 12:11:07.629 [WARN ] [l.serialmessage.SendDataMessageClass] - NODE 3: Already processed another send data request for this callback Id, ignoring.

events.log

2018-11-03 12:09:22.501 [me.event.ThingUpdatedEvent] - Thing 'zwave:device:9783cd9b:node3' has been updated.
2018-11-03 12:09:32.599 [me.event.ThingUpdatedEvent] - Thing 'zwave:device:9783cd9b:node3' has been updated.
2018-11-03 12:09:42.712 [me.event.ThingUpdatedEvent] - Thing 'zwave:device:9783cd9b:node3' has been updated.
2018-11-03 12:09:53.061 [me.event.ThingUpdatedEvent] - Thing 'zwave:device:9783cd9b:node3' has been updated.
2018-11-03 12:10:03.024 [me.event.ThingUpdatedEvent] - Thing 'zwave:device:9783cd9b:node3' has been updated.
2018-11-03 12:10:13.019 [me.event.ThingUpdatedEvent] - Thing 'zwave:device:9783cd9b:node3' has been updated.
2018-11-03 12:10:13.171 [me.event.ThingUpdatedEvent] - Thing 'zwave:device:9783cd9b:node3' has been updated.
2018-11-03 12:10:23.162 [me.event.ThingUpdatedEvent] - Thing 'zwave:device:9783cd9b:node3' has been updated.
2018-11-03 12:10:31.806 [vent.ItemStateChangedEvent] - ZWaveMotionSensorWohnzimmer_MotionAlarm changed from OFF to O                                                                                                                         N
2018-11-03 12:10:33.331 [me.event.ThingUpdatedEvent] - Thing 'zwave:device:9783cd9b:node3' has been updated.
2018-11-03 12:10:43.266 [me.event.ThingUpdatedEvent] - Thing 'zwave:device:9783cd9b:node3' has been updated.
2018-11-03 12:10:49.223 [me.event.ThingUpdatedEvent] - Thing 'zwave:device:9783cd9b:node3' has been updated.
2018-11-03 12:11:07.589 [me.event.ThingUpdatedEvent] - Thing 'zwave:device:9783cd9b:node3' has been updated.
2018-11-03 12:11:12.608 [hingStatusInfoChangedEvent] - 'zwave:device:9783cd9b:node3' changed from ONLINE to ONLINE:                                                                                                                          Node initialising: DETAILS
2018-11-03 12:11:12.617 [hingStatusInfoChangedEvent] - 'zwave:device:9783cd9b:node3' changed from ONLINE: Node initi                                                                                                                         alising: DETAILS to ONLINE: Node initialising: GET_CONFIGURATION
2018-11-03 12:11:12.681 [hingStatusInfoChangedEvent] - 'zwave:device:9783cd9b:node3' changed from ONLINE: Node initi                                                                                                                         alising: GET_CONFIGURATION to ONLINE: Node initialising: DYNAMIC_VALUES
2018-11-03 12:11:12.738 [vent.ItemStateChangedEvent] - ZWaveMotionSensorGang_BatteryLevel changed from NULL to 100
2018-11-03 12:11:22.359 [vent.ItemStateChangedEvent] - ZWaveMotionSensorWohnzimmer_MotionAlarm changed from ON to OF                                                                                                                         F
2018-11-03 12:11:31.586 [me.event.ThingUpdatedEvent] - Thing 'zwave:device:9783cd9b:node3' has been updated.
2018-11-03 12:11:50.567 [me.event.ThingUpdatedEvent] - Thing 'zwave:device:9783cd9b:node3' has been updated.
2018-11-03 12:13:21.088 [vent.ItemStateChangedEvent] - ZWaveMotionSensorWohnzimmer_SensorTemperature changed from 21                                                                                                                         .2 to 21.4

Every 10 seconds openhab tries to update the sensor. But why?

Is there a setting you can change to have OH update less often?

Yes it is, but all the settings are identical at both sensors.

  • Polling Period: 30 Minutes
  • Wakeup Interval 7200 Seconds
  • Illuminance report: 3600 Seconds
  • Temperature report: 3600 Seconds

Hi Tobias, I have the same thing running well. I would suggest to remove the faulty thing and include it again. If that is not working I would remove it, reset to factory defaults and then include it again. Mostly this helps :slight_smile:
Regards, Siggi

Thats it! Thanks