Fibaro RGBW Module does not keep "before power cut off state"

Hi @ll,
after finaly got the Openhab communicating with the Fibaro module, I´m facing the issue that the “last status before power cut off” is lost from time to time. So sometimes its working and sometimes not. Which is actually destroying the WAF :-(. Is that normal or might be the Fibaro module buggy? does anybody has the same issue or experience with it? Is there a option to work arround that with Openhab? The light is normaly turned on/off with a default power switch.

Thx for any feedback in advance

Err, what sort of construction is that? Do you switch the input power towards the FGRGBW ?
Now that’s definitely not the way you should deploy these modules. There’s input lines to connect your switch to, you know.
Or do you really have that many power outages ? If so, your wife is likely annoyed by “that whole stuff you play with all day” and the resulting “quality of service”, but then that for sure is not because of module malfunction :slightly_smiling:

so what I did is I connected the powersupply to a normal power on / off switch. Means the fibaro module gets disconnected from the power everytime somebody is using the switch. Of course I assume that having a constant power connection and triggering the on off via one of the input channels would be prefered, but I thought the power cut off state should take care about that. After the fibaro module has power again I can control it via the app again, but in the last “state before power cut off” is lost in many cases. Which then ends up in a “pressing the switch” but nothing happens :-).

In a normal environment its not that easy to change the “cabeling”. Od did I missunderstood soomething. I´m using Philips Hue bulps on other spots which actually turn on to a predefined stat once the power was cut off. So I thought the Fibaro module should do the same. As it is working sometimes I was thinking about maybe the module is faulty.

Well, it may be faulty or not, but I guess noone has ever tried to find out if it works properly under these extreme conditions.
The module is definitely not meant to be (mis)used that way you currently do (neither are Hue bulbs). You’re likely damaging it (you possibly already did). Yes, you misunderstood that stuff. Don’t ask for a software workaround, but get your cabling right.
You can also attach your switch to a different Fibaro module and have no direct switch and “switch” your RGBW light just using radio commands (using a rule, triggered if someone toggles the switch on the other module).


after thinking about it a little more, is it really that unusual to use a fibaro module like that? I mean if somebody wants to implement such a module and he is living in a rented apartment he normaly does just have a 3*1,5 cabling, so there is no option to use the module in another way, apart from using wireless switches. So I doubt that everybody is disabling all the default switches and replacing those with wireless senders. Same applies actually to the Hue bulbs, no enduser / consumer is starting to use the Hue bulbs just with Hue switches or just with the smartphone. That would be far away from userfriendly, as we are just talking about a bulb.

Anyway thx a lot for the feedback. If somebody has experiences with a similar setup, please let me know.

I personally don’t see any issue with running it like this - it certainly shouldn’t damage the device since it should work through power cuts etc (unless of course you’re flicking the power on and off fast and frequent! :wink:).

I don’t have the RGBW, so can’t comment on that device, but the state save/restore works fine in the other Fibaro devices I’ve got (but note that this can be disabled with parameter 16 - might pay to check this is set correctly).

Well, I see a number of issues with that:

  1. You ‘create’ an instable mains-powered node, unnecessarily causing additional radio network traffic
  2. You might have a switching delay (because the module needs to start up first).
    and most important
  3. You cannot control your light from anywhere except the switch when the switch (and thus power to the module) is set to off. Btw, then where’s the point in doing that at all ?
    The normal mode of installation is to put the module under the switch, and to connect the switch to the (switching, not power) inputs of the module. No need for extra cabling (well, except for the 12/24VDC power source, but that’s of course a different story).

No I didn’t mean to exclusively switch from smartphone. I meant to connect your physical switch to a second module.
I use the secondary input of a FGD to control my RGBW module (using OH rules). You can put different functions (= different light scenes) on single, double and triple clicks.

PS: yes, my wife insisted on having that switch