Fibaro shutter blind - not found

I’m trying to add a new fibaro shutter blind zwave unit. I already have 2, which are working fine.
The third one - openhab doesn’t seem to see it at all.
Tried, pretty much every manual (click the button 3 times) and automatic inclusion method possible - nothing. Openhab just ignores the existence of it, nothing in the logs either.
If I remove one of the existing units and run discovery, it is found immediately.
I’m at a loss here.

Maybe the device is broken - it’s not unheard of for devices to fail.

it is indeed not unheard of. Thing is - I have two new units. tried replacing, still exact same behaviour - openhab just ignores its existence

Assuming the binding is putting the controller into include mode, if it’s not including, and there’s nothing in the logs, then there’s either a problem with the controller, or the device.

I guess it’s a stupid question, but are these devices for your region? eg if you’re in Europe, you haven’t somehow purchased devices that are meant for the US market?

third and 4th unit are identical to the 2 I already have installed and are already working fine.

Ok, the region issue is the only thing I can think of that would systematically prevent them working. Where these two devices purchased at the same time as the other two?

As I said above, if there’s nothing in the log, then it’s a problem with the controller or the device.

not the same time, but exactly same supplier, so not likely they are any different.
is there some key word I should look at the logs to see if there is any communication at all during inclusion/discovery?

Enable debug logging, then do a search for “Add Node:” - this should display a number of messages that show the controller entering inclusion mode, and also any devices found.

Add Node: Learn ready.
2018-09-18 11:54:19.011 [DEBUG] [al.protocol.ZWaveInclusionController] - Inclusion event: Current state IncludeSent, new event IncludeStart
2018-09-18 11:54:19.012 [DEBUG] [e.internal.protocol.ZWaveTransaction] - TID 95: Transaction COMPLETED
2018-09-18 11:54:19.014 [DEBUG] [nal.protocol.ZWaveTransactionManager] - NODE 255: Response processed after 8ms
2018-09-18 11:54:19.014 [DEBUG] [nal.protocol.ZWaveTransactionManager] - NODE 255: TID 95: Transaction completed
2018-09-18 11:54:19.014 [DEBUG] [nal.protocol.ZWaveTransactionManager] - NODE 255: notifyTransactionResponse TID:95 DONE
2018-09-18 11:54:19.014 [DEBUG] [nal.protocol.ZWaveTransactionManager] - ZWaveReceiveThread queue empty
2018-09-18 11:54:19.015 [DEBUG] [nal.protocol.ZWaveTransactionManager] - Transaction SendNextMessage 0 out at start. Holdoff false.
2018-09-18 11:54:49.002 [DEBUG] [wave.discovery.ZWaveDiscoveryService] - ZWave discovery: Stop zwave:serial_zstick:f42480b1
2018-09-18 11:54:49.003 [DEBUG] [al.protocol.ZWaveInclusionController] - ZWave controller stopping inclusion at IncludeStart
2018-09-18 11:54:49.003 [DEBUG] [ol.serialmessage.AddNodeMessageClass] - Ending INCLUSION mode.

If I understand correctly - it didnt’ at all find the device?

No - there would have been some more messages showing the discovered node.

I do get this:

Add Node: Done.
2018-09-18 12:35:28.278 [DEBUG] [wave.discovery.ZWaveDiscoveryService] - NODE 3: Device discovered
2018-09-18 12:35:28.279 [DEBUG] [al.protocol.ZWaveInclusionController] - Inclusion event: Current state IncludeDone, new event IncludeDone
2018-09-18 12:35:28.279 [DEBUG] [ol.serialmessage.AddNodeMessageClass] - Ending INCLUSION mode.

This however is a unit that is already part of the network, similar fibaro unit, but an existing one. Is it possible that in some way this unit “interferes” with the discovery of the new unit that I’m trying to add?

Before you return it I would reset the device. Did help me with an FGS223, reset procedure is the same for the FGR222:

No - I don’t think that’s a problem. There is no new node being added and you’re not receiving the messages showing the new node. I’m pretty sure that this is quite normal to see this when no new node is added.