Fibaro smoke sensor (FGSD-002) / Not getting all values from the device

Any news on wether or not this helps (or makes things worse even)?

Since I am using the offline apt-get snapshot, I can only test your changes after a new build. I haven’t had yet the chance to do this today. I will try it this evening and come back with a report.

Ok - thanks.

Well, here is what I found out:

I upated through apt-get and had to switch the mechanism to the new repository at bintray first. Before I had:

195 | Active | 80 | | ZWave Binding

And after the update/upgrade:

195 | Active | 80 | | ZWave Binding

So only a slighty newer build. But gladly your changes were implemented in the newer build (at least I think so).

Initialisation went well and I also got the xml files soon afterwards. I got a wakeup timestamp in Habmin and no DYNAMIC VALUES message.

Nevertheless I got a minor issue: During the re-addition of one of the two sensors (node 8), I got the following log message:

2017-01-09 18:01:59.706 [ERROR] [curityCommandClassWithInitialization] - NODE 8: SECURITY_ERROR Invalid state! Secure inclusion has not completed and we are not in inclusion mode. Aborting
2017-01-09 18:02:00.095 [ERROR] [curityCommandClassWithInitialization] - NODE 8: SECURITY_ERROR Invalid state! Secure inclusion has not completed and we are not in inclusion mode. Aborting
2017-01-09 18:02:01.082 [ERROR] [curityCommandClassWithInitialization] - NODE 8: SECURITY_ERROR Invalid state! Secure inclusion has not completed and we are not in inclusion mode. Aborting

This is somehow irritating, because I deactivated secure inclusion for the controller some weeks ago. And the messages didn’t appear for the other sensor (node 13). Does the sensor kind of remembers the initially inclusion method and maybe at that time secure inclusion was still active? Is this something to be concerned about?

So, is this already working for you? I’m going crazy with this, can’t get it to work. I can receive temperature data but no heat_alarm. I’m using OH2 2.1.0-1, with an item defined like this:

Switch alarma_temperatura_cocina "Alarma Temperatura Cocina [%s]" <siren> (sensor, temperatura, cocina, zwave, alarma) { channel="zwave:device:controller:node8:alarm_heat" }

I’ve tried everything I saw on the forums: Adding OH2 controller to association groups 2&4, adding the “respond_to_basic=true” (which seems not to be required anymore with OH2), etc. But even if the alarm is signalled visually (led blinks) I never get the notification on OH2.

Any clue of what might be wrong or anything else that can be tried?

many thanks in advance!!

PS: Configuration of the thing below.


I got introduced to the ‘development version’ of the z-wave binding and that binding together with a couple of updates in the device database did the trick.

My FGSD-002 now reports everything as it should. Most critically the REAL smoke alarm events. (I need to clean my oven more often).

So, to get you further i would :

  1. Get the 2.2-SNAPSHOT install of OH2
  2. Get the “development binding”.
  3. You need to remove all Things and re-add them. The development bindning have a different naming convention for node xml’s. More info how to install the development binding can be found in this thread.

Thanks hasaterhorb! after installing the dev version of the binding now I get the heat alarm. Need to test smoke_alarm as well when possible.

Just for the record, I also had to:

feature:install openhab-transport-serial

as was missing.

Any clue on when this new version of the binding will be included on the stable release?

I have no clue, maybe @chris can answer that.

You can test the real smoke notifications by blowing a match under the sensor. Easy to trigger, at least when sensitivity is set to medium or high.

I bought a cheap smoke sensor testing spray. Just need to find the right moment without many people around :wink:

Again, thanks for the tip and hope @chris can let us know when it will be part of the release.

BTW: @chris let me know if you need some testing, I’m available for it.

No - I guess late this year or early next year, but I’m not sure of the release schedule for the next stable release.

1 Like

Ok, here comes the funny thing: Now the heat_alarm is never canceled. Not just on OH2, the blue led keeps blinking even if temperature is way below the threshold… have any of you had a similar behaviour? I got excited very quickly about the sensor fully working!

Actually, i never tried the heat sensor, im (for now) only interested in the smoke sensor.

It might be that the alarm_heat channel is not updated, but the notification is sent from the device.

Or, no notification is sent from the device at all. In this case its probably the device who is not configured to send alarm_heat cancelations.

Can you verify in the logs?

Threshold was set to a relatively low value to allow testing, 30C. Alarm cancelation was sent 3mins after the sensor reported 28C.

Just out of curiosity will ask FIbaro about the expected behaviour.

For completeness, here is the answer from Fibaro. Excellent support from the Fibaro team.


The device is designed to start the overheat when the temperature exceeds value specified in parameter 30.

In order to clear the overheat alarm, the temperature drop by at least 2 degrees below the set level with param 30.

We tend to use such practises. For example the Dimmer`s overheat is at some 70 degrees, but the notification will stay until the temperature drops below 60 degrees.

This is just to ensure the temperature are really dropping. I do understand the need to test it with 30 degrees, but note the default “real” overheat protection is set at 50 degrees.

1 Like

Useful information - thanks. It might be useful to add this comment to the database so it’s not lost…

Can I do that myself? I only see how to add comments, but this should be next to Parameter 30 details.

If you have an account on the database site, then you should be able to, but it looks like you might not have an account?

I’ll add this comment to Parameter 30…

the heat alarm and smoke alarm do not return any value.
Temperature i got 21,5 degrees.

Alarm_smoke shows OK, but i do not receive any value…
alarm_heat doesn’t show anything…

The same for me: Receiving acutal status informations from Fibaro Smoke Sensor

The Ok is the value.

You don’t say what version of anything (binding/OH) you are running? Is it the latest, or 2.3, or something else? If it’s not 2.4 M4 or newer, then please change to a new version.