Fibaro Thermostatic valve operation

Tags: #<Tag:0x00007f74518c0c68>

I am having trouble configuring my thermostat correctly - I dont know if Im doing it right. I have a Fibaro FGT-001 Thermostatic Valve with external temperature sensor. I have configured it in openHab UI so it shows me current temp and setpoint, with just linking thing channells with items. I have done nothing else. But when I set its setpoint it does not seem to take this into consideration and still keeps heating even if the current temperature is way past setpoint. Should I do/configure something else so it would work as expected?

image

2019-11-06 21:05:01.062 [ome.event.ItemCommandEvent] - Item 'Thermostat1_SetpointHeating' received command 22 ▒C
2019-11-06 21:05:01.106 [nt.ItemStatePredictedEvent] - Thermostat1_SetpointHeating predicted to become 22 ▒C
2019-11-06 21:05:01.132 [vent.ItemStateChangedEvent] - Thermostat1_SetpointHeating changed from 23 ▒C to 22 ▒C
2019-11-06 21:14:31.626 [vent.ItemStateChangedEvent] - Thermostat1_SensorTemperature changed from 25.8 ▒C to 25.9 ▒C
2019-11-06 21:24:30.450 [vent.ItemStateChangedEvent] - Thermostat1_SensorTemperature changed from 25.9 ▒C to 26 ▒C

If you need any other configs to diagnose, please tell me how to get it also - I am very new to this.

please post your items file for the Thermo

How can I do that if I added the item via Paper UI? My items folder is empty.

I guess the FGT-001 is battery powered, so it wakes up just as you have set the “wake up interval”.
The log entry

Thermostat1_SetpointHeating changed from 23 ▒C to 22 ▒C

is just an information that the new setpoint was stored.
After the thermostat wakes up it gets this new setpoint and confirms receipt.
But this can take several minutes.

So check the “wake up interval” parameter of the

Item 'Thermostat1_SetpointHeating'

Yes, it’s battery powered.

In the item “edit” section, there are only one field that’s similar to the “wake up interval” - “autoupdate” and I can set it to enforce. Is that something I should try?

Or did you mean by “check the wake up interval of the item” the actual FGT-001 device (thing)?
In the thing edit section there also aren’t anything about “wake up interval”. There’s a “Polling period” and it set to 10 minutes but that clearly isn’t affecting the setpoint because I messed for hours with it yesterday and the temp was climbing the whole time.


In the device description there’s an information:
Wakeup Information
FIBARO Heat Controller is a FLiRS device. The FLiRS device alternates between sleep mode and a partially awake mode in which it is listening beam signal. When device receives this beam, it immediately fully wakes up and then communicates with the controller or other Z-Wave device.

Any clues from that?

Hi,
please try to set the lifeline to the z-wave controller. I have a Spirit valve which shows a comment, that a zwave plus node can only communicate with the controller.

Regards
Ingo

Okay, Flirs means this device does not need a wake up interval.
I assume you have paired this device with the external temperature sensor FGBRS-001?

I found in the manual following:
Additional function status:
This parameter allows to check statuses of different additional functions.

Available settings:
1 (bit 0) – optional temperature sensor connected and operational
2 (bit 1) – open window detected
Default setting: 0
Parameter size: 4 [bytes]
Parameter 3 values may be combined, e.g. 1+2=3 means optional sensor works properly and open window detection was triggered.

Have you set this parameter to “1” or “3” ?

Yes, external sensor is paired and the parameter you refer is set to 1.

Did that. I’ll know in the evening if anything changes.