Fibaro wall plug settings for fastest updates

Release = Raspbian GNU/Linux 9 (stretch)
Kernel = Linux 4.14.34-v7+
Platform = Raspberry Pi 2 Model B Rev 1.1
Uptime = 22 day(s). 18:7:26
CPU Usage = 11.72 % avg over 4 cpu(s) (4 core(s) x 1 socket(s))
CPU Load = 1m: 1.04, 5m: 1.16, 15m: 1.06
Memory = Free: 0.11GB (12%), Used: 0.83GB (88%), Total: 0.95GB
Swap = Free: 0.09GB (99%), Used: 0.00GB (1%), Total: 0.09GB
Root = Free: 25.07GB (91%), Used: 2.19GB (9%), Total: 28.45GB
Updates = 27 apt updates available.
Sessions = 1 sessions
Processes = 102 running processes of 32768 maximum processes
Version:openHAB 2.2.0-1 (Release Build)

These are the settings that I have for my Fibaro wall plug but I get updates only every 15sec. Is it possible to get faster updates?
@chris Do you have any idea if what I am asking is possible or not?


I’m not that familiar with the device. I would have thought that 15 seconds was fine? Normally, you want to configure a relatively low update rate, and then there is an update if there is a specific level of change and this gets sent immediately. Having the device send the same data at a high rate is just going to congest the network which will slow things down.

You’re polling the device every 15s and you shouldn’t need to do that. If configured properly, the device should also be sending updates immediately after the value changes. Parameter 50 looks suspicious to me. If the device isn’t securely included, then I do not see how your current setting would work. If you’re using the binding from 2.2.0-1 release, then the device is not securely included. If you are not receiving updates from the device, this may explain why.

OK, this is great info.
Can you elaborate on the

If you’re using the binding from 2.2.0-1 release, then the device is not securely included

Is this problem fixed on an updated binding version
Is there a problem with the configuration of property 50?
(The z-wave plugin version is 2.2.0 and yes the openHAB version is 2.2.0-1)

Assuming this is your device, the description of parameter 50 reads…

This parameter defines how commands are sent in specified association groups: as secure or non-secure. Parameter is active only in Z-Wave network security mode. This parameter does not apply to 1st „Lifeline” group

I suggest you set parameter 50 to 0 (using Habmin!) and see if this helps, assuming you are not getting reports sent from the device and that is why you are polling it every 15s. I don’t have one of these devices, and there could be more to it than this. I was just pointing out a possible cause to your problem… you have the device configured to use security but the version of binding you are using does not support security.

Sadly I set parameter 50 to “none of the groups are send as secure” which the closest I can get to “0” but the update (polling actually) time did not change

Set the polling interval to 1 day. You shouldn’t need to poll the device, since it is sending reports based on how you configure it. Which values are you looking for from this device? I’m guessing the power, so plug something into it that uses power and check if the item linked to the Elecric meter (watts) or Sensor (power) channels changes value. If not, then your other parameters may need to be adjusted.

I have a similar issue, the device is not sending updates after it changes :frowning: