Files are no longer loaded automatically after a change

Since my penultimate update a few days ago my files are no longer loaded automatically, as soon as I save a change. I’ve tested it with rules and items.

In OH1 there was a setting for that. How can I get the “hot reload” back?

It should hot reload. There is no setting, its the default and only behavior.

Try restarting OH and testing. If it still doesn’t reload files automatically file an issue on github.

I tried everything (restart OH, restart raspi, updated system). No luck so far. :cry:

Ok, will file an issue the next days. Thanks for your reply.

I set up a complete new OH2 instance (new raspi, new sd card, no old files from my first OH2 instance). After some configuration I got the same behavior. OH2 does not load the files automatically anymore. I have done some research and found, that every time I made an error in a configuration file (.items, .things) a message occurs and afterwards OH2 didn’t reload a file. I have to restart OH2. That’s the message:

2017-01-13 22:21:37.942 [WARN ] [el.core.internal.ModelRepositoryImpl] - Configuration model 'home.things' is either empty or cannot be parsed correctly!

That’s completely annoying. :angry: Does anybody knows a workaround without restarting OH2?

I recommend posting an issue. This is clearly a bug.

I just had a weird one too. - I already had a harmony hub and just bought a black bean for upstairs. The rules file is similar so I copied the harmony.rules to blackbean.rules I modified the blackbean stuff and got it working great. Later I tried to have Alexa turn the telly on using the harmony and nothing. - I checked the logs and found that indeed Alexa was causing the switch to come on as always however, the rules were not triggering. After much investigation and tearing my hair out I found that the harmony.rules file had somehow been ignored. I made a minor edit to the file (changed the text in the log command) and it was reloaded then everything started working again. Not sure what caused this issue but was glad it was easily fixed.

This always helps - bug filed 3 days ago, now the fix is already in the current distro:

1 Like