First time setup, issue on Mac OS (Mojave)

Hi all,

newbie question, I’m trying to start playing on MacOS before moving onto a final environment.
After having followed the instructions I am not able to start OH, getting this error:
Any helpful suggestion please?

thanks

$ ./start.sh
Launching the openHAB runtime…
Error: Could not find or load main class downloads.openhab-2.5.0.M1

Running Java:

$ /usr/libexec/java_home -V
Matching Java Virtual Machines (1):
1.8.0_201-zulu-8.34.0.1, x86_64: “Zulu 8” /Library/Java/JavaVirtualMachines/zulu-8.jdk/Contents/Home

/Library/Java/JavaVirtualMachines/zulu-8.jdk/Contents/Home

There isn’t a lot of details here but it looks like either something didn’t get unzipped or it got corrupted during the installation process. All I can recommend given the current information is to try reinstalling. Java appears to be working so you just need to do the OH steps.

Hi,
that’s bizzarre, indeed the installation for Mac OS seems to simply consist of unzipping a file and run the script in it. I don’t really know what else I can try.
I tried 2.4 and 2.5 using two different unzip tools, same result!
thanks anyway