[FIXED] Zigbee Bindings Help (Nortek)

[FIX - For this issue] Set baud rate to 57600 and restart your openHab service/device. [FIX]

Having trouble with the Linear HUSBZB-1 made by Nortek. Already have the z wave bindings setup but am seeing the following error when trying to add the Nortek dongle as an Ember EM35x coordinator.

2018-01-02 22:58:20.779 [hingStatusInfoChangedEvent] - 'zigbee:coordinator_ember:82fee38c' changed from UNINITIALIZED to INITIALIZING

2018-01-02 22:58:20.794 [me.event.ThingUpdatedEvent] - Thing 'zigbee:coordinator_ember:82fee38c' has been updated.

2018-01-02 22:58:20.808 [me.event.ThingUpdatedEvent] - Thing 'zigbee:coordinator_ember:82fee38c' has been updated.

2018-01-02 22:58:20.821 [me.event.ThingUpdatedEvent] - Thing 'zigbee:coordinator_ember:82fee38c' has been updated.

2018-01-02 22:58:20.827 [hingStatusInfoChangedEvent] - 'zigbee:coordinator_ember:82fee38c' changed from INITIALIZING to UNKNOWN

2018-01-02 22:58:20.834 [nt.FirmwareStatusInfoEvent] - Firmware status of thing zigbee:coordinator_ember:82fee38c changed to UNKNOWN.

==> /var/log/openhab2/openhab.log <==

2018-01-02 22:58:21.846 [INFO ] [ing.zigbee.internal.ZigBeeSerialPort] - Serial port [/dev/ttyUSB1] is initialized.

2018-01-02 22:58:21.858 [WARN ] [bee.dongle.ember.ash.AshFrameHandler] - Trying to send when not connected.

I know @5iver had some success with zigbee in the past; anyone else and anyone specifically with this dongle?

Zigbee is working well for me, especially with the latest snapshot version of the binding. Which version of the binding are you running? If you haven’t already, search the forum for HUSBZB and you’ll find a few threads with info that may be helpful. Be sure to set the baud rate to 57600 and restart.

[FIXED] Using binding-zigbee - 2.2.0 on an openHabian build. The baud rate was the key. Now working!

Cool! In case things get wonky, I have found the latest version of the binding to be much more stable for my devices (mostly GE Link bulbs).

Just got my Nortek working on a fresh install of openhabian 1.6. Somewhere else the order was mentioned. You need to configure the zigbee binding first. So required steps are:

  1. Install the serial binding
  2. Install the zigbee binding, configure for Ember controller. The serial was automatically installed on ttyUSB1, on/off flow control, 57600baud.
  3. Then, install the zwave binding.

The first time through, I did the zwave first. The zigbee always showed a communication error. After trying many things, uninstalled both, then did just the zigbee with the above settings.

The order of the binding installations makes no difference. I can install them in any order and my HUSBZB works fine.

1 Like

Absolutely. And just to note that installing bindings doesn’t really do a lot - if the issue was with serial port access, then what matters is when the bindings start, and this is not something that you can control at all. So, even if you can install then in a certain order, the next time the system starts, the start order will be random.

I am new to OH, have a basic working understanding of linux. The serial ports always came up after a reboot, as could be seen in ssh/cli. I tried several things with the ember controller, doing a full restart between attempts. The zwave always came up after restarts, Soo I don’t think the serials ports were moving. I finally decided to delete both things and start again with the zigbee/ember controller first. It magically worked with the exact same settings I had tried previously. I half expected it to stop working after I brought the zwave portion into the mix. One final note, the configuration was all done in the paperui. Logically it doesn’t make sense - each binding is interacting with a particular serial port. Thanks