Follow Profile in MainUI broken?

Hi All

When you go to link the item to an additional channel, there is no drop down or method to do this?

in textual configuration, both channels appear in the Item with the profile=follow, but this isnt possible in MainUI

Is this yet to be implemented?


See also

which does not end conclusively.

Are you attempting to add a second channel to your Item, and then to modify that newly created link with a profile? I believe that is the way it should be done.

Yep, it didnt haha!

My Air conditioning has 4 zones and a main power switch. I want users to use the Zone switch to a) turn it on/off to direct air to the room and also power on the main AC unit.

In an item text file, you’d have both the AC Zone Channel and AC Power switch channel. With the follow profile, whilst the log wouldnt indicate that the AC power was switched on (by nature I’m told) it would work just fine.

This doesnt appear to be the case in MainUI

I believe it works if you start from the thing instead of the item. Go to the channel on the thing and click the Add Link to Item. The first option there is whether you wish to create a new item for the link or add the link to an already existing item. The full array of profiles is available through that UI page.

Ah, I can see, but the only option is to link to an Item, in the text configuration you’d link it to a channel.

Ignoring that, if i link it to the AC power switch of the ducted unit, when the zone switches on, it wont turn on the AC.

You can see it here. Zone is on, AC Unit is OFF

@cweitkamp The follow profile in MainUI is still broken it appears, do you know if anyone is addressing this? Thanks!

For clarity;

Profiles don’t get connected to any Items, ever. Profiles are a modifier for a channel<>Item link.

It follows that we must designate/create the link before we can describe modifications (a profile) for it.

In MainUI, there are two ways to go at that.
Start at a pre-existing Item, add a new channel link.
Or start at a Thing channel, add a link to a new or pre-existing Item.

Ideally both ways should offer profiles to modify the new link.

Sure, but thats the issue. It might modify the link but it hasn’t triggered ON to the linked channel. When linking it appears its linking another ITEM, not another channel as the textual version

Can we see the text config you are trying to recreate?

If I remember right, follow profile does offer an optional parameter for an Item name. I don’t really know what that is for and have not seen it used in real life. I suspect you just omit that.

General ‘follow’ usage - when applied to a channel link, it listens for state updates to the parent Item and converts those into commands for the parent channel.
Assuming the channel goes on to to some real device, that device ‘follows’ the state of the OH Item.


Yes thats how I understood it worked - the below configuration worked just fine

Switch DaikinACUnit_Zone1  "Front Room Zone"         { channel="daikin:airbase_ac_unit:DaikinAP65279:zone1", channel="daikin:airbase_ac_unit:DaikinAP65279:power" [profile="follow"], alexa="PowerController.powerState"}

Okay, so MainUI is insisting on an Item parameter that you don’t want?

MainUI is insisting on an item (The power item for the AC unit) which whilst accepted, won’t trigger when the Zone receives a command.

The text file had the channels linked, MainUI has the items linked.

I’m still not quite sure what you are describing here. Here’s one of my examples (configured completely through the UI and functioning perfectly well:

This item has two channels: the first is the direct channel. This item responds to and pushes changes to the wall switch. The second channel is the follow channel:

This channel only pushes item changes out to the fan relay.

This is just like the text configuration. The same item has two channels, one of those channels has the follow profile applied.

I set this up via the method I described above, using the Add Link to Item in the channel tab of the thing page.

Are you saying that you see the exact same setup as I am showing but that you don’t see the follow profile working or that you cannot set up the profile correctly?

I see it, it just doesnt work

There must be a bug. You can see ive linked the zone on/off switch to the power on/off, I see the Zone turn on but the power of the AC unit does not. I can turn the AC unit OH switch on just fine separately.

Where’s the profile, may we see that?

I’ve given up. I’ll do it with a rule :slight_smile:

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.