Forbidden to connect to Myopenhab


I am using openhab2 and have configured the remote access with myopenhab. Everything went well and I now have access to it throught the openHAB android app (on local network and on remote URL).

However, when trying to connect to with a webbrowser I have a “Forbidden” page displayed.
Same happens if I try to change my password.

Any inputs on this ?

Today I wanted to register a new account and this is also not possible: it shows a plain page saying ‘forbidden’

Tried it just now and it worked without any problems. Make sure you have the correct url:

Tried to connect again just now, and I still have the page Forbidden.
Same goes for the reset password action…

1 Like

Same here

1 Like

I’ve been getting this too. I am using Chrome. But then I tried Firefox and it worked fine. Went back to Chrome and it gives the ‘Forbidden’. I’ll use Firefox for now. Any idea why this is a problem with Chrome? I did a refresh, but that didn’t change anything.

This is REALLY strange.
My successful test from above was made with Firefox. I tried it just now with Chrome: it works fine. Login to my existing account was successful, creating a new account was also successful.

Indeed strange. Registration worked in Chrome in an incognito tab, regular tab still forbidden…

Tried again.
Doesn’t work with Chrome (version 56.0.2924.87 (64-bit))
Works with Chrome for Android
Works with Microsoft Edge…

I don’t know whats going on here …
I checked my Chrome version and it is Version 56.0.2924.87 (64-bit).
Login worked fine.
Then Chrome got updated to Version 57.0.2987.110 (64-bit) just a minute ago and login still works fine.

I did not check Android versions or Edge, though.

It looks like this is the wrong forum for reporting this bug, because the login works. Why it does not work for you with certain browsers … I don’t know.

Did you clear the cache folder? Maybe its worth a try.

Me too. I can’t login through Chrome or Firefox. Firefox allows me to reset my password but the doesn’t allow me to login

Cookie problem? Maybe an old cookie is stored. Find and delete them … but that is just a guess.

This is a very strange problem. I get forbidden on Firefox for at least 2 days. After seeing this thread, I tried a Firefox ‘Private Window’ and login works.

I removed all cookies and cleared web cache. Still forbidden from Firefox 52.

Same problem here. Clearing cookie worked for me, thanks for the hint.
Chrome on OSX, FWIW.

Cleaning the cookie also solved the issue.

Thanks for the answers.

I also just got the “Forbidden” after the login in Chrome.
Deleting all 9 myopenhab cookies solved it…
Thanks for the idea!

I tried everything: Every browser, 4 different devices, via wifi/lan and LTE and I always get Forbidden page.

What can I do ?

EDIT: clearing cookies did not help

1 Like

Same problem here. Cookies deleted. Firefox 56 and Chrome 63 on MacOS 10.13. No chance to connect. Error like above.

Since reports no problems ( the problem is most probably at your site.