Fresh/Clean install of Eclipse org.openhab.demo.app on Windows 10 - Run OSGI not starting demo app?

Tags: #<Tag:0x00007f4331a20208> #<Tag:0x00007f4331a203e8>

I believe I have followed the instructions to the letter, and have been successful in the past.

Installing Eclipse IDE for Openhab

Today is a different story and I have been struggling for a couple days now to figure out why. I assume that the demo app can be run without adding any additional bundles - is that correct? I have not added any bundles nor updated the dependencies in the pom.xml file.

After the clean install and clicking on Run OSGI, the Eclipse Resolve/Run screen looks like the screen shot below. I expected to see additional messages in the Console about starting the OH3 session on port 8080, but nothing and trying to connect confirms its not there…

Also including what is the result of clicking the Resolve button in the following screen shot. There are a number of optional resources listed. I have not selected any of them and simply pressed update in the lower right bottom of the resolution results screen.

Its seems like I am missing something really obvious, but for the life of me I can’t seem to figure out what?? Any advise would be greatly appreciated…

---- update -----
Including environment info:

Apache Maven 3.6.3 (cecedd343002696d0abb50b32b541b8a6ba2883f)
Maven home: C:\Program Files\apache-maven-3.6.3
Java version: 11.0.9, vendor: Oracle Corporation, runtime: C:\Program Files\Java\jdk-11.0.9
Default locale: en_US, platform encoding: Cp1252
OS name: “windows 10”, version: “10.0”, arch: “amd64”, family: “windows”

After completely removing Eclipse and the OpenHab repo (openhab-main, .m2, .eclipse, .p2 folders). Tried another clean install today and now have a new/different result. Eclipse is reporting some errors on the pom.xml for missing artifacts. See error messages/screen shot below.

  1. Missing artifact org.eclipse.orbit.bundles:io.github.classgraph:jar:4.8.35.v20190528-1517
  2. Missing artifact org.openhab:com.caucho.quercus:jar:4.0.45
  3. The container ‘Maven Dependencies’ references non existing library ‘C:\Users\DSchoepel.m2\repository\org\eclipse\orbit\bundles\io.github.classgraph\4.8.35.v20190528-1517\io.github.classgraph-4.8.35.v20190528-1517.jar’
  4. The project cannot be built until build path errors are resolved

While I can verify that the two artifacts are not included in the .m2 repository (they are there but have .lastUPDATED appended to their file name), not sure why they are missing or how to find and add them to the repository. Searching the community and Google is not coming up with anything useful for this problem.

I did manage to find and add the two missing artifacts to the .m2/repository so the build completed successfully. Running the demo still has the same result as I reported above.

Again any help would be welcome…