Fresh openhabian > "openhab2.service changed on disk"

  • Platform information:
##   Release = Raspbian GNU/Linux 10 (buster)
##    Kernel = Linux 4.19.57-v7l+
##  Platform = Raspberry Pi 4 Model B Rev 1.1
##    Memory = Free: 3.36GB (87%), Used: 0.49GB (13%), Total: 3.86GB

openHAB 2.5.6-2 (Release Build)

as i mentioned here i’m having trouble setting up openhabian.
@mstormi is probably ignoring me already but i’m pretty shure this souldn’t happen…
yesterday i downloaded a fresh openhabian image and wrote it to a new sd card. then i booted the pi and waited until setup was completed… first thing i did was testing:

openhabian@openhab:~$ sudo systemctl stop openhab2

openhab stopped without comment. everything ok for now i thought, shut the pi down.
i just booted again and to be sure ran the command again:

openhabian@openhab:~$ sudo systemctl stop openhab2
Warning: The unit file, source configuration file or drop-ins of openhab2.service changed on disk. Run 'systemctl daemon-reload' to reload units.

sudo systemctl daemon-reload fixed the problem (at least i didn’t get the error anymore) but after reboot it’s there again…

i swear, i did absolutely nothing except running systemctl stop/start openhab2and reboot a couple of times - didn’t even use openhabian-config.

should i ignore this warning and proceed with configuring openhab or is this relevant?

edit: this is probably not ZRAM related, so i hope it’s ok that i openend yet another thread…

afaik this is a side effect when delayed rule load is activated.

is this activated by default on openhabian? never heard of it :slight_smile:

No, I don’t think it’s activated by default.

that means it’s still not activated. i didn’t activate anything :slight_smile: :smiley:

On new installations it is, and it daemon-reloads, too so that can’t be the reason here.

should i ignore this, or could i do something to figure out why this happens?

yes, double-post… but i really don’t know what to do on this point. my current zram setup continues to lose data and i’m not sure it makes sense to create a new setup when this error shows pops up from the very start :face_with_raised_eyebrow:
i can’t be really the only one to be affected by this?

From what I read here it’s a bug in systemd that according to this can be ignored.
In the meantime it should be fixed ( see end of first link )
Are your system packages up-to-date ?

i installed openhabian in july, according to the link you posted this sould’ve been fixed in june. just did a ugprade via openhabian-config (“Upgrade System”), rebooted… aaaand:

[21:30:35] openhabian@openhab:~$ sudo systemctl stop openhab2
Warning: The unit file, source configuration file or drop-ins of openhab2.servic                                       e changed on disk. Run 'systemctl daemon-reload' to reload units.

The current Buster systemd package seems to have release number 241-7-deb10u4
while the patch is tagged as 246-rc1. Thus not available.

ok, that makes sense… so - for now - i can ignore the error and it will disappear once systemd moves to a higher release.
thank you very much!

Just to let you know… I have the exact same issue here on my rpi4. I didnt do anything either, except installed a fresh openhabian boot from usb using a ssd. I have no tried sd card, but I assume its the same.

1 Like

Me too, have the same issue
It happen every time I try the command systemctl restart openhab2.service
Need everytime to run the suggested reload command

Note there’s a solution ticked post in this thread.