Fritzbox Comet Dect Thermostat

No , the switch on sound has a separatly checkbox at fb-ui.

I’ll try to use Comet Dect with following thing

Bridge avmfritz:fritzbox:192_168_2_1 [ ipAddress=“”, password =“xxxxx”, user=“xxx” ]
Comet_DECT CD1 [ ain=“1234567890” ]

But i get nothing (not in event.log)

Can anyone find my error?


there is a not working example of the fritzbox thing configuration in the documentation. See discussion here: and here: [avmfritz] FRITZ!DECT 200 jsut "INITIALIZING" and items don't work

Dear SnakeEater

Sorry. With FRITZ_DECT_200 it works perfect. But not with Comet Dect thermostat

Hi Frank,

just to get an overview of your setting. Can you specify a little more about it? That would be nice: Which version of the avmfritz binding do you use? Did you install it over Paper UI, apt-sources or an other way?

Please keep in mind that the Comet DECT implementation is not merged to the main repository, yet.

Can you post your updatet *.things file?

Yes, i can :slight_smile:

Fritzbox 7490 - OS 6.80


Bridge avmfritz:fritzbox:192_1xx_xxx_xxx [ ipAddress=“”, password =“xxxx”, user=“xxx” ] {
Comet_DECT CD1 [ ain=“10xxxxxxxxxx” ]


Number COMETDECTActualTempCD1 “Raumtemperatur [%.1f °C]” { channel=“avmfritz:Comet_DECT:CD1: 10971xxxxxxx:actual_temp” }
Number COMETDECTSetTempCD1 “Thermostat Temperatur [%.1f °C]” { channel=“avmfritz:Comet_DECT:CD1: 10971xxxxxxx:set_temp” }
Switch COMETDECTBatteryCD1 “Battery low” { channel=“avmfritz:Comet_DECT:CD1: 10971xxxxxxx:battery_low” }

events.log from /var/log…
2017-03-xx xx:xx:26.881 [ItemChannelLinkAddedEvent ] - Link 'COMETDECTActualTempCD1-avmfritz:Comet_DECT:CD1:1

2017-03-xx xx:xx:44.912 [WARN ] [] - Cannot update existing item ‘COMETDECTActualTempCD1’, because is not managed.

Hi Frank,

I think I can help you, IMHO your syntax in the *.items file is not correct. It should be:


In your case the <BRIDGE_UID> is missing. Try changing the items definiton to something like this:

Number COMETDECTActualTempCD1 "Raumtemperatur [%.1f °C]" { channel="avmfritz:Comet_DECT:192_1xx_xxx_xxx:10971xxxxxxx:actual_temp" }

Hope that works. Please give feedback.

Unfortunately, nobody could help me with that issue:
Therefore, I have to presume that replacing bindings from repo with packages from addons-Folder is instable. With openhabian it works, with a manual install not… So I can not replace avmfritz binding’s repo version with the version from here.

Because of this issue - may I kindly ask when the avmfritz binding version supporting Comet Dect will be merged to the SNAPSHOT repository?

Hi queen-shit,

I am sorry that I cannot help you to solve your problem. I can understand that you do not want to use experimental versions and tinker around in your setup.

I hope my PR #1815 will be merged shortly. But we have to wait until one of the maintainers maybe @Kai himself will review it and confirm to merge it.

Have a good one.

Hi @cweitkamp,

I do not mind using experimental versions like SNAPSHOT builds - that’s why I would like to have this extended binding version merged into this branch :wink: … And I do not mind either tinkering around in my setup as long as I can come to a positive result or gain the knowledge why I definitely can not. But in this case, I do not have a single indication why not, i. e. why not in the case of manual installation (which is definitely easier to maintain)!

I can acknowledge that this binding extension works very well and moreover, it’s a real improvement - therefore, I wonder why it does not become integrated in SNAPSHOT version of OHA2. I thought that is where SNAPSHOT builds are for ;).

Thank you for the link to your PR! Now I can have an eye on the progress myself and I will now be able to know very soon when the big moment has come. No need to install new SNAPSHOT any longer and being disappointed again about still not integrated this great one…

I’m also still waiting for Comet DECT support. In my first openHAB installation on Windows I used OH 1.8 - there It was working - at least I could read out the temperature. But after a short time I started to build a productive RasPi with openHABian 2.0 - where this is not possible.

sorry for late reply. Got no mail from GITHUB

I’ll tested it. Not working :frowning:

Hi Frank,

I am sorry to hear, but maybe you are right. Could you check if the temperature channel works for you? It should provide the same values like the ‘actual_temp’ channel. I am going to proof the code.

Number COMETDECTActualTempCD1 "Raumtemperatur [%.1f °C]" {

@cweitkamp I don’t know if it a general binding question or a question related to the Comet DECT. I want to create a simple two state time plan for my heating. I have set up the following items

String              Livingroom_Heating_1_Mode        "Modus Heizung [%s]"                                                                                               {channel="avmfritz:FRITZ_DECT_300:Flur:Livingroom_Heating1:mode"}
Number:Temperature  Livingroom_Heating_1_CurTemp     "Momentane Temperatur Heizung [%.1f %unit%]"   <temperature>                       ["Measurement","Temperature"]   {channel="avmfritz:FRITZ_DECT_300:Flur:Livingroom_Heating1:actual_temp"}
Number:Temperature  Livingroom_Heating_1_SetTemp     "Set Temperatur Heizung [%.1f %unit%]"         <temperature>                       ["Measurement","Temperature"]   {channel="avmfritz:FRITZ_DECT_300:Flur:Livingroom_Heating1:set_temp"}
Number:Temperature  Livingroom_Heating_1_EcoTemp     "Eco Temperatur Heizung [%.1f %unit%]"         <temperature>                       ["Measurement","Temperature"]   {channel="avmfritz:FRITZ_DECT_300:Flur:Livingroom_Heating1:eco_temp"}
Number:Temperature  Livingroom_Heating_1_ComfTemp    "Comfort Temperatur Heizung [%.1f %unit%]"     <temperature>                       ["Measurement","Temperature"]   {channel="avmfritz:FRITZ_DECT_300:Flur:Livingroom_Heating1:comf_temp"}
String              Livingroom_Heating_1_RadiatorMode "Radiator Modus Heizung [%s]"                                                                                     {channel="avmfritz:FRITZ_DECT_300:Flur:Livingroom_Heating1:radiator_mode"}

If I switch the Livingroom_Heating_1_RadiatorMode from Comfort to ECO it changes the temperature in the device to 15.5 °C, which I initially set like this in the Fritzbox, but I can not change the temperature it changes to via the binding. I thought I could do this by changing Livingroom_Heating_1_Eco / Comf via e.g.


It changes the value for 1ms but than gets resetted to the initial FritzBox value (15.5°C) again

2021-10-22 09:35:35.084 [INFO ] [openhab.event.ItemStateChangedEvent ] - Item 'Livingroom_Heating_1_EcoTemp' changed from 15.5 °C to 16 °C

2021-10-22 09:35:41.388 [INFO ] [openhab.event.ItemStateChangedEvent ] - Item 'Livingroom_Heating_1_EcoTemp' changed from 16 °C to 15.5 °C

For Comfort it even doesnt change the temperature at all

2021-10-22 09:57:59.174 [INFO ] [openhab.event.ItemCommandEvent      ] - Item 'Livingroom_Heating_1_ComfTemp' received command 20.5

2021-10-22 09:57:59.192 [INFO ] [penhab.event.ItemStatePredictedEvent] - Item 'Livingroom_Heating_1_ComfTemp' predicted to become NULL

Am I doing something wrong?

Things have changed in the four years that this message thread has been dormant.

It’s a Number:Temperature type, you should command it including units.

Does not change the behaviour, it gets automatically resetted to value set in FritzBox Settings


2021-10-22 14:39:18.808 [INFO ] [openhab.event.ItemCommandEvent      ] - Item 'Livingroom_Heating_1_EcoTemp' received command 13 °C

2021-10-22 14:39:18.828 [INFO ] [penhab.event.ItemStatePredictedEvent] - Item 'Livingroom_Heating_1_EcoTemp' predicted to become 13 °C

2021-10-22 14:39:18.853 [INFO ] [openhab.event.ItemStateChangedEvent ] - Item 'Livingroom_Heating_1_EcoTemp' changed from 15.5 °C to 13 °C

2021-10-22 14:39:30.080 [INFO ] [openhab.event.ItemStateChangedEvent ] - Item 'Livingroom_Heating_1_EcoTemp' changed from 13 °C to 15.5 °C

Looks like the command isn’t actioned at all. (the change/revert state change is just about ‘autoupdate’ guessing, followed by the device saying “nope, it’s like this”)

A slightly less ancient thread that looks more relevant -

Thank you for the link, I was reading through old threads to confirm what I was suspecting:

Comfort and Eco Temp seem to be read-only items. So to control the temperature via Openhab the valves have to be set to Mode “On” and the SetTemp has to be changed.

Remark: When changing to “On” the SetTemp gets every time resetted to a default of 30°C :sweat: :sweat_drops:

You are quite right.
ON= 30 °C, BOOST=28 °C and OFF=6 °C. That are Initial-Values from the Fritz-Box

But you don’t have to change the Mode if you want to manually change the Temperature. If you manually select a Temperatue via OH or via Radiator-Valve, the Mode change then to “ON” itself.

My item in OH3 now has the following syntax:

Number:Temperature radiator_valve_01_Set  "Solltemperatur Büro[%.1f %unit%]" <heating1> (gRFritz_01,gRtSoll)  ["Setpoint","Temperature"]  { channel="avmfritz:Comet_DECT:192_168_178_1:119601003400:set_temp",listWidget="oh-stepper-item" [step=0.5, min=6, max=24], widget="oh-stepper-card" [step=0.5, min=6, max=24]}

and is shown in the items-settings like this:

But there are a lot of Custom Widgets here in the Forum and in the Community-Market-Place. The one I use is from @Nico_R . You can find information for the Valve here.

I’m using the widget for temperature-monitoring (it’s not the latest release)

Okay thank you, so the RadiatorMode changes itself. Do you know if you have to set the Mode to Manual ?

What are the effects of changing the mode from Manual to automatically and vacation?