FritzBox TR064 Binding Troubleshooting


After upgrading to 1.8.0 I tried the FritzTR064 Binding, but can not get it to start (items are not populated, and the logs show nothing that pertains to that binding).
The Binding was downloaded from the Wiki Page, and openhab.cfg was amended with the snippet thats on the wiki page also.
Java Version is 1.8.0 running on an Raspberry Pi2 with Debian wheezy.

Bye, Frido.

Hi, I have a similar problem. Unlike you the binding starts, but every request results in a repsonse with invalid arguments. I have a Fritzbox 7490 with the latest stable firmware.

 [ERROR] [o.o.b.f.i.FritzboxTr064Binding] - Error received from FritzBox: <?xml version="1.0"?><s:Envelope xmlns:s="" s:encodingStyle="">
<UPnPError xmlns="urn:dslforum-org:control-1-0">
<errorDescription>Invalid Args</errorDescription>
</s:Envelope>. SOAP request was: maconline:xxx }

I’ve got the same problem as @fridomac.

I’ve got teh same error as tobias. When I run it with the same configuration under Windows I haven’t this error.
Anybody an idea?


I had the same issue at Raspberry Pi, but can’t really tell what fixed it for sure, therefore please excuse my detailed description below.

When I changed addon name (mv … openHAB/addons/org.openhab.binding.fritzboxtr064-1.8.1.jar), it started to work (with another restart of service), but I also changed log level at logback.xml.

After that I changed contact item as described at this post.

Unfortunately I am not able to reproduce it by (re)moving file and it still works when I use origin filename (org.openhab.binding.fritzboxtr064_1.8.0.201603130944.jar) now.

I tried changing configuration from https (port 49443) to http (49000) before and switched back to https with port 49443 finally, user + password is set for authentication, changed logback.xml and restarted service such as rebooted pi several times with no effect previously.

Update: Looks like Java 1.8.0 hadn’t been used at previous attempts. RWE Binding stopped working, when Fritzbox TR064 Binding was working. I found out, that this is caused by TLS 1.2 being used by default at Java 1.8.0. --> Get sure, that Java 1.8.0 is used to run openHAB.

I have the same problem with my raspberry 2 B running OH 2. Java version is “1.8.0_111”

Contact Online "Online [%s]" <present> {fritzboxtr064="maconline:00-00-00-00-00-00" }

=> SOLVED: I just did another restart and it works now fine. I don’t know why but it is working now.