Fronius Binding: missing channels

Hi there,

I run a Fronius Symo Gen 24, a Fronius Smartmeter TS 65A-3 and a OH 4.1 Release Build with the Fronius-Binding .

The Fronius-Binding itself runs like a charm since many months, but due to some circumstances, I found out that I do not have a number of channels like (and that´s the one I desperately would need now) “powerflowchannelppv”. But also I miss i.e. “powerflowchannelautonomy”.
I also found out, that (at least) one other channel is there, but do not have any data like the “inverterdatachanneldayenergy”.

I already tried to add the ppv-channel manually in the code-tab of the inverter-thing, hit save, but when I leave this page an go back, it is gone again.

Any tips or anything I can do??

Of course. When it’s not coded in the binding, it does not exist.

Code it yourself or kindly ask the binding author to do it for you,
open an issue on GitHub - openhab/openhab-addons: Add-ons for openHAB
Mind the title should start [fronius] and make clear it is a feature request, not a bug.
While at it you could also kindly ask for implementing battery control channels.

There are bindings, in which this is working, i.e. the MQTT or the Govee-Binding, in which you CAN manually add channels that way.

If you had a look into the documentation of the binding (which you btw can find here; Fronius - Bindings | openHAB ) you would have seen, that it IS ALREADY coded, but not working…

That’s irrelevant.
Dynamic channel creation isn’t available in every binding for good reasons.

Why should I lookup the docs for your problem before answering?

Then open the issue (link above) and tag it a bug.

A “normal user” like me cannot see where this works and where it is not available. Anyhow, I just mentioned, what I´ve treed before opening this threat.

maybe, just maybe: Don´t answer to a threat if you just want to blame others and do not have anything which brings the threat forward??

i don´t know, if it is a bug or if I do something wrong.
Additionally: As a “normal user” I do not even have a github-account…

1 Like

Those two channels are in the fronius binding in 4.0.4.
Did you upgrade to 4.1 from 4.0?
I have noticed that some channels get lost or parts go missing after the upgrade.

1 Like

Yes, I did an update from 4.0.
… and MANY thanks for that tip: I removed and re-installed the thing and the channels are there (and working) now!

I told you exactly what to do to get the thing done, didn’t I ? Sure there’s multiple solutions now, but this clearly was a correct and working direction to get to a solution.

Your response now, well, that now was ad hominem blaming.

Maybe, just maybe, re-read and re-consider before answering like this next time.

exactly NO.

I just responded in your own sound, which was not the first time discussed in this forum.

Anyhow: I got, what I was looking for. I´m thankful for that. So this is my last response to this topic

1 Like

Maybe you knew, without opening the docs first.
Have you ever thought, this is a part of the vision and idea of an community!

Why even care to answer anything, when it is his problem?



Exactly yes.

No, both that and this comment are ad hominem. My ‘sound’ is just being to the point.

I have a similar setup (Fronius GEN24, Smartmeter TS 65A-3 and BYD battery).
Are you sure the channels inverterdatachanneldayenergy (Day Energy) and inverterdatachannelyear (Year Energy) are delivering valid data?
Mine are always “0 kWh”.
I deleted and reinstalled all 3 Things, but still get “0 kWh”. All other channels seem to work, though.

I referred only to the missing channels, sorry for confusion. As I don’t use the “energy”-channels anymore, I gave it a try: You are right. The only “energy”-channel which seems to work (or at least is not 0) is the total.
Even not sure, whether the inverter anyhow has this day and year-data, as the LOCAL interface of the inverter also do not show them. Only the cloud-service of Fronius show this, so it might be, they are calculated at their cloud and not locally??

I´m reading this kind of information from my Wallbox, which is doing a number of calculations with this data, so I don´t have to do them by myself in OH.

No problem.

That is what I figured out, too :grinning: