Frontiersilicon Radio Binding not working on my new Internetradio

i bought a new Internetradio with a Frontier Silicon Chipset.

Silvercrest SIRD 14 C1

The Binding is not working, i can not power on my radio. The undok-APP (Android Playstore) is working perfect.

When i enter the command which was mentioned in the binding-wiki, i get the excepted result “fs_ok xxxxx” - so i think there could be a little hope to get this binding running with my radio.

Can anybody help my? Maybe the developer of this binding is reading here too?

I copied the items and sitemap from the binding-wiki to my openhab and changedit to my things, i get messages in openhab-log, if i power on the radio, but radio is still off.

Where can i see, if the binding is working correctly and connecting with my radio?

My first guess is that this model maybe has another than the default pin?

I did some further tests, also i did a restart of the openhab service. Now the binding is working.

The pin was ok.

But one issue still exists. My Volume Control is from 0 to 20, in the binding it is codes from 0 to 30. Volume Control is not working with my radio.
I get shown the % but i can´t raise/lower the volume.

I changed “slider” to setpoint, now it is working for me.

Good to hear that the binding is working :slight_smile:

I added another volume control item in the FS internet radio binding (one for percentage, one for absolute number) which will be part of eclipse smarthome, but I did not yet find time to port these changes back to the openhab 1.x version of the binding. If you want, you could do that and create a pull request for it.

Furthermore, maybe you could add your radio model to the list of compatible radios on the wiki page of this binding?
Edit: thanks for adding your radio to the wiki page!

I can´t write a program in java, so i can´t change the binding for myself.

Is eclipse smarthome another project like openhab?

Openhab 2 is based on Eclipse Smarthome as explained here:

I extended and revised this binding specifically for Eclipse Smarthome:
This means that it can also be used in openhab 2, but not in openhab 1.x. The new features for openhab 2 are device discovery (which is not available in openhab 1.x) and an additional item type for controlling the volume as discussed in the PR.

But as far as I understood your second last post, everything is now working for you.

Yes, it is working, but i can’t use the setpoint item for volume, because oft the % error. My radio is in very low volume, i want to change and for example it jumps to 18% in openhab but radio Volumen jumps to 18 (max is 20) and it is very very loud. So all is usable except the volume.

And another question to eclipse smarthome: is eclipse smarthome openhab2? Is it the same? or is eclipse smarthome another Programm like openhab2?

The link to openhab 2 moved:
There you should find all the answers to your question regarding openhab 2.

If I find some time, I will add the additional volume item type also to the openhab 1.x binding, but I’m quite busy at the moment, so don’t expect this to happen very soon :wink:

Finally, I had some time to look into this issue and there was in fact a bug when posting a new volume to the event bus. Fix is provided in this PR:

When will this be included in the openhab addon-download section?

Where can i download the new version and when will it be available?

I don’t know when and how the fixed binding will be available, but I built it locally and you can test it by replacing the jar-file in your addons folder with this: org.openhab.binding.frontiersiliconradio-1.8.0-SNAPSHOT.jar

Now the PR is valid, so you can also download the jar file from the latest Jenkins build: org.openhab.binding.frontiersiliconradio-1.9.0-SNAPSHOT.jar

I changed to OH2 and now my volume control is not working anymore.

My volume gets from 0 to 20.

My thing in paperui is: fsinternetradio:radio:1234567d:volume-percent

What do i have to change to get working volume control without percent?

There should be an advanced option to control volume via a numeric item:

Thank you, i changed the item to

Number RadioVolDimmer		"Radio Volume [%d von 20]"	(gRadio)	{ channel="fsinternetradio:radio:2e4b2ec0:volume-absolute" } 

and now it works!

1 Like