Frustrated beginner struggling with z-wave configuration

Hi. This is my first post here. I’m new to openHAB but not new to z-wave. I’m exploring a switch from Homeseer. After being initially impressed by openHAB, I’m slowly finding it more and more opaque and confusing.

I have a fresh install of openhabianpi on a RPi 3. I have a house full of z-wave dimmers (Fibaro FGD-212) and various sensors and I’m trying to get these dimmers configured the way I want. After figuring out that I need to update to the 2.3.0 version of the z-wave binding to actually send z-wave parameters, I am now stuck trying to update parameter 6 on one of my dimmers using PaperUI. I should be able to set the value to anything from 0-255. I want to set it to 0, but in the configuration screen it won’t let me set it below 1. 0 is a valid value for this and I was able to set it to this in Homeseer. Is there a way of overriding this or do I need to contact the maintainer of the binding?

Can you try using HABmin to do the Z-Wave device configuration? HABmin is an alternative to Paper UI, and does a better job with Z-Wave configuration. You can install HABmin using Paper UI. It’s under Add-ons -> User Interfaces.

If you are correct about parameter 6, then the Database entry needs work.

Good catch. Allowed range doesn’t match description.

Parameter 8 looks wrong too.

Yeah, I was scanning down the entry and a couple look suspicious. There is the device document pdf at the bottom. It appears to be in line with the db entry through. Notice the default values on the 0-255 ranges is actually 1. Doc error, or DB error? Not sure…

Yep, based on the Fibaro manual, it looks like the Allowed Range should be 0-255 for param 6 and 8.

There are two DB entries for the FGD-212, and both look incorrect.

Interesting. I’ll try setting HABmin up next chance I get.

OK, I’ve started playing with HABmin. Still unable to set parameter 6 to zero. How might I go about getting the database updated? Am I able to just modify a text file somewhere to achieve it locally?

If the database is wrong, I’d recommend fixing it. You simply won’t be able to set the value outside of what is programmed in the database.

I fixed param 6 and 8 in the DB.


Too fast for me, I was 30 seconds late :rofl:

1 Like

I’ve just done a database update, so this will go in to dev today, but it missed the master branch update, so probably master will be another day or two.

I had to make another addition into master, so have added these updates at the same time.

Wow. I’m impressed by how responsive the community has been here! Next question; What do I need to do to update my system with these database changes? Do I need to switch to a development branch or something like that?

You need to switch to the dev branch or to a recent zwave snapshot.

Many thanks! Especially for including the links!

1 Like

Just wanted to confirm that I am now able to set parameter 6 to 0 on my Fibaro Dimmer 2s and that it achieves the effect I was after (instantaneous on rather than dimming on).

Thanks very much.