GardenaAccountHandler - Error 403 Forbidden,”User is not authorized to access this resource with an explicit deny”

Continuing the discussion from GardenaAccountHandler - Error 403 Forbidden,"User is not authorized to access this resource with an explicit deny":

Hello, same issue for me. I run 3.4.3 in a docker container and integrate one automover and 2 sensors based on the garden binding - this is normally not much.

Somehow these behavior is descibed in the binding documentation:
The Gardena server imposes call rate limits to prevent malicious use of its API. The limits are:

On average not more than one call every 15 minutes.
3000 calls per month.

Normally the binding does not exceed these limits.
My conrete error message shows always:
[st.core.internal.thing.ThingResource] - Received HTTP PUT request for update configuration at ‘things/gardena:account:36592a1108/config’ for an uninitialized thing ‘gardena:account:36592a1108’.
2023-04-29 10:17:50.816 [WARN ] [ternal.handler.GardenaAccountHandler] - Error 403 Forbidden, {“Message”:“User is not authorized to access this resource with an explicit deny”}

It always works for some days and then i have to generate a new API key, what is very disappointing. Any solution proposal are welcome.

You can try with a 4.0 snapshot or milestone. It contains this fix which should solve the issue.

Just tried to install the 4.0 snapshot with bundle:update.

It went ok, but I can’t start it on my OH3.4.3. Any ideas why?

Error starting bundle 267: Could not resolve module: org.openhab.binding.gardena [267]
Unresolved requirement: Import-Package:; version=“[2.9.0,3.0.0)”

Yes: 4.0 bindings don’t work on 3.x (due to Java, Karaf and library changes). You’ll need to use the full 4.0 snapshot.

(And yes, I agree that’s slightly annoying. As I mentioned in the linked PR, I would’ve hoped this fix to be backported into a 3.4.x release.)

1 Like

Could you lease change the title of this topic.
Without reading your first post completely, nowbody would know what your issue is and how to help.

Thanks for your answer. I have tried to install the OH 4.0.0M2 with Java 17 - but the system becomes veeerrrryyy slowly. It is unusable then - I have reinstalled a backup with 3.4.3. The onlyest way for me is to build a clean install - but this takes a lot of time because I have some more network services at the raspberry around the OH-service installed. Up to this time I’m not able to manage the Gardena equipment - that isn’t fine in spring and early sommer.
I have see at github that the fix changes only one class-file. Is there any way to get the compiled class file for the running 3.4.3-version (I have never compiled java programs myself)?


I have the same issue since 11:42:54 today.

Yes … I have the same problem since today, too :frowning:

The fix is now available in 3.4 branch. So will be included in next 3.4 release.


Realy a great job, thanks a lot. I will impatiently waiting for the next 3.4-release… :slight_smile:

Hi Lolodomo,
sorry for this beginner question…
Could you please tell me where I can find the fixed 3.4 addon file as a jar file?

1 Like

“The transfer you requested has been deleted.”
Any direct link that could be used to retrieve the new build of the binding?

Hello, a working linke exist in the other post this one worked for me and now since 24 hours no issue anymore: - org.openhab.binding.gardena-3.4.4-SNAPSHOT.jar

1 Like

Perfect, Thank You!


… and there came the 3.4.4 patch-release :slight_smile: