Getting started with Zigbee

  • Platform information:

    • Hardware: Raspberry Pi
    • OS: Raspbian
    • openHAB version:
  • Issue of the topic:
    I am new to OpenHab and I am trying to setup ZigBee using a Nortek HUSBZB-1 USB Z-Wave and Zigbee adapter. The problem is I can’t figure out how to get started I tried following the ZigBee tutorial from the OpenHab site but didn’t fully understand what to do and I couldn’t find any videos on YouTube showing how to setup ZigBee.

    My goal is to connect a Sylvania smart sensor to the adapter so I can get the status.

    I have also tried looking in inbox in paperUI but nothing showed up when I click the + it searches but also doesn’t find the adapter.

1 Like
  1. Install the Zigbee binding
  2. Open the Inbox
  3. Click the + icon
  4. Click “Add Manually”
  5. Choose the Ember35x Controller from the list for the HUSBZB-1.
  6. Select the proper device. On Linux its usually /dev/ttyUSBx. The HUSBZB-1 appears as two different USB devices, one for Zwave and one for Zigbee. The Zigbee will always be the second one. If you have no other USB devices plugged in, that means /dev/ttyUSB1 or /dev/ttyAMA1 will be the correct one.
  7. For the HUSBZB-1 set flow control to “Software (XOn/XOff)” and the baud rate to 57600
  8. Wait for the controller to appear as online. If it doesn’t check the logs and review your settings.
  9. Return to the Inbox and click the + icon
  10. Select Zigbee
  11. You now have 30 seconds to perform some action on the smart sensor, see the senor’s manual
  12. If successful you should now see a new entry in the Inbox for the sensor. Accept the new Thing and the device will become a part of your OH config.
  13. Create Items and link them to the Channels of the Thing.
4 Likes

For step 6, it doesn’t show a drop down of connections unlike it does for the other inputs. How do I figure out what to type in to get the Zigbee port?

Unplug the device. Look in /dev. Plug the device in. Look in /dev again. The two new files will be your zwave controller and zigbee coordinator.

I found the two ttyUSB0 and ttyUSB1 files but my coordinator keeps saying offline.

I checked the logs and it says

2019-03-26 21:03:17.654 [ERROR] [ding.zigbee.handler.ZigBeeSerialPort] - Serial Error: Port /dev/ttyUSB1 does not exist.
2019-03-26 21:03:17.664 [ERROR] [zigbee.dongle.ember.ZigBeeDongleEzsp] - Unable to open Ember serial port

Also when I use the terminal and type “/dev/ttyUSB1” it says permission denied, does this have something to do with it not working?

Yes. You probably need to add the openhab user to the group that owns those files. Usually the group is dialout.

rich@norns:~   ls -l /dev/ttyUSB0
crw-rw---- 1 root dialout 188, 0 Mar 28 07:42 /dev/ttyUSB0

Search Google for “add user to group linux” for dozens of tutorials on how to do that.

I tired adding it to the group and it still says offline. No errors in log either.

Installed zigbee binding but do not see Controller. I only see Coordinator.

with the HUSBZ pick the Ember I think

Controller = Zwave
Coordinator = Zigbee

Andrew is correct, you need the Ember Coordinator.

Hi Rich,
wondering if you could please help me getting my Nortex HUSBZB-1 to work with OpenHAB.

I’m using windows and have selected COM3 as the serial port but alas OpenHAB still says its offline.

Any thoughts?

Cheers

I’ve never used openHAB with Windows. I’ve no ideas what could cause that problem.

For me ZigBee didn’t work so far.