Giving up on OH2, it's just not usable yet

I spent 2 days, probably 8 hours total trying to get a few devices working on OH2 and every time I tried I just get frustrated and quit. I did this three times, twice removing everything and starting over because things just didn’t work as expected. This morning it took me 1/2 hour to get five devices setup in OH1.8. WTF?! I know a lot of work has gone into this but really, shouldn’t the newer version work better than the older version? I really want to use OH over Smartthings because it’s more versatile but I’m worried that I’ll set everything up in OH1 just to have it deprecated out. Is this because “2.0” is still new, I feel it just lacks visibility into what’s going on especially for zwave. Things are hidden away in databases that can’t be seen and the UI only shows certain information.

/rant. Thanks for the work everyone, I’m just really disappointed because I really wanted to ditch smartthings.

I started my home automation project from 0 back in October. I knew nothing about OH. Downloaded OH2 snapshot, spent an hour here reading/searching and was able to automate 80% of house in first 24 hours (zwave, lights, sensors, multi room audio, htpc, projector, garage, homeKit, alexa, you name it … ). I am using latest build (2.0) and it is 100% reliable for me.

What exactly doesn’t work for you ?

And I wanna say THANK YOU to the developers and everyone else, who is somehow involved to this project!


The zwave stuff just wouldn’t take. I could setup one thing but the next thing wouldn’t work. All values were in celsius no matter what I did (OH1 just works fine). I tried removing nodes but they wouldn’t go away, they would just keeping showing up in the inbox as if it was stuck in some DB somewhere. My “F this” moment was last night after I cleared everything out and restarted but then added a device and it kept thinking it was a light switch when it was a motion sensor, probably because before the light was node2 before but now I was trying to make the motion sensor node2. It’s like something was not getting removing from the database but I had zero visibility into this. I also couldn’t get items to work from text config files, I followed multiple tutorials but nothing would work, it only worked if I added it through the paper ui but then I was left wanting more since the gui is lacking options.

I just spent the last hour setting up multiple test rules, config options and dashboards in OH1 and they are working great. If I switch over my house to OH1 (33 devices) and next year it stopped getting updates or bindings are only compatible with OH2 and I have to go through this all over again I might snap. :wink:

To setup zwave devices I use Habmin. Let it discover nodes and configure them one by one.

1 Like

:rage: That’s what I’ve been doing with OH1 BUT I just restarted and now three devices are not working. I now see what smartthings is the leader as bad as they are because for the most part it works. I can’t have devices not working after I restart OH…I give up.

Well it works for me and it doesn’t matter how many times I reboot :slight_smile:

What is your host machine and zwave controller ?

1 Like

Why didn’t you ask for help before giving up? I agree it’s not always as easy as it could be, but I’ve found the community extremely helpfu,l and OH2 itself is improving very rapidly.

So here is what I mean. I have this test bed working fine in OH1 so I figure why not try to migrate over to OH2. Using the same stick that’s configured I start up OH2 and the inbox is wrong, here is a shot of what OH1 had and what OH2 thinks is there. There are currently no things in OH2 but it thinks these devices are the wrong type, where does it pull this info from?

It takes time to initialize Z-wave items in PaperUi. Let it discover items and wait until nodes will change from unknown to “known” then add. You can manually trigger sensors to update data on zwave controller if you don’t want to wait.

I think he’s mainly concerned about Node 2 and 3 being switched. OH1 says Node 2 is a Window Sensor and OH2 says Node 2 is a Motion Sensor. I’m still learning too but I thought OH pulled that information from the controller.

Model number for Node2&3 on OH1 and 2 is the same. I think OH2 has to finish initialization process to get more info for items and then it should be fine.

I’d just like to add here that I switched my whole house from FHEM to Openhab2 in the last 2 weeks.
It includes homematic items (heating, lighting, etc), RFX433 items (weather, temp sensors, blinds), a bunch of arduino sensors (connected via MQTT), grafana visualization and a habpanel interface for my tablet and multiroom audio based on squeezelite.

Almost everything worked as expected. The only problems I had were some very unintuitive behaviors of the rules language (null does not seem to be really null, etc).

Maybe it’s a zwave issue not an OH2 issue, well, a zwave binding issue. I gave it another try and things were going okay then everything went down hill again. Things stopped responding, the UI doesn’t update when switches are toggled and adding new devices is a chore since they are not picked up right away.

This works for a few devices, but I have 22 thermostats and configuring them via a UI to get Fahrenheit and configure refresh timers the way I want via the GUI is just crazy! I am stuck on openHAB 1 because of zwave right now, as soon as there is a way to configure with .things I am ready to jump ship.

Having said that, openHAB is an open source project and I am thrilled to death of all the development that has gone into it.


The controller itself. Most of the problems you describe sound an aweful lot like the problem isn’t OH but your controller.

null is null like it is in Java. NULL means uninitialized state for Items. I think it is an unfortunate name and prefer the OH 1.x Undefined. Is that what you are referring to?

From the description I tend to agree. My top suspect is the controller. I would reset the controller, readd your devices (maybe just a few to start) and see what shows up in the inbox and Habmin. Zwave is one of the more popular bindings and many have been running it on OH 2 for months now without any of the issues you are reporting so there is something different about your environment. My first guess is its the controller that is a little corrupted.

There is a button on the Inbox page that will let you force a discovery on an Item. Press that and select zwave and it will dump all the unconfigured nodes on the device right into the Inbox immediately.

It just dumps the nodes from the controller so it happens instantly. No need to wait.

I’ve had a frustrating migration to OH2 from 1 but it’s not bad if you think of the PaperUI stuff separately from the traditional .items, .rules .sitemaps. I really like the abstraction with things and channels… just got to work thru it and get your head around it.

If zwave stuff isn’t showing up it doesn’t sound like OH2 is to blame, it saw everything in my home immediately and not seen many complaints around of this… You might want to utilize the console and keep log:tail going to see whats going on under the hood.

If you turn off auto linking, do your configs solely in the text files, it’s not that different. I’ll agree that the disconnect between PaperUI and the texts is jarring but nobody says you NEED to use it.

the celcius thing might be related to you using Yahoo Weather - the native 2.0 addon only supports C. Use the 1.9 generic Weather addon

1 Like

Where are you running OH2. While OH1 ran fine on a raspberry 1 I tried OH2 on it and it gave all kind of strange errors. Similar to what you describe. Then I bought a raspberry 3 and now it works nicely.

I was giving OH2 a try. As long as stuff worked in Paper UI, all was (most of the time) fine, but getting down o the text files really gave me a hard time, even it was described well. So I went for a Devolo Home System and My Troubles have all vanished. Setup was done in not even 30 minutes, and another 15 to set up all rules in the mobile App.
I’ll check back on OH2 at the end of the year to see what happened.

I migrated from OH1 to OH2 and I find it difficult to use so I’ve reverted to configuring it through text files as per OH1 and it works just fine.

That said, I don’t use zwave…

I do use zwave and absolutely share your point: I’ve also reverted to configuring it through text files as per OH1 and it finally works just fine. The UIs are all uncomplete, buggy and restricted. You cannot use the potential of OH2 only with the UIs.
Having your files also permits to easier switch between different versions/snapshots (just as easy as in OH1…)
I personally do not understand at all why this buggy and incomplete UI approach is orchestered that much for OH2. The UIs are far from any relaease status, it would be more honest to call them Beta6.