Google Assistant Help - for heating

Hi

I have lighting and power point controllers are working perfectly from google assistant or google home app.

But heating for the life of me cant get it working!

On google home app - heater says “Offline”

What am I doing wrong here?

Group gLoungeHeater_TSTAT "Lounge Thermostat" [ "Thermostat" ]
Number LoungeHeater_Mode "Lounge Heating/Cooling Mode" (gLoungeHeater_TSTAT)[ "homekit:HeatingCoolingMode" ]
Number LoungeHeater_Temp "Lounge Temperature" (gLoungeHeater_TSTAT)[ "CurrentTemperature" ] { channel="mqtt:topic:mybroker:lounge:temp" }
Number LoungeHeater_Hum "Lounge Humidity" (gLoungeHeater_TSTAT)[ "CurrentHumidity" ] { channel="mqtt:topic:mybroker:lounge:hum" }
Number LoungeHeater_Setpoint "Lounge Setpoint" (gLoungeHeater_TSTAT, gHeaterSetpoint)[ "TargetTemperature" ] { channel="mqtt:topic:mybroker:lounge:setpoint" }
Switch LoungeHeater "Lounge Heater" ( gHeater, gLiving ) { channel="mqtt:topic:mybroker:lounge:heater" }
  • Platform information: ubuntu
    • Hardware: dell poweredge r710 / 2x 3gigx4core cpu / 90gig of ram / lots of space
    • OS: 18.04
    • Java Runtime Environment: official docker 2.4
    • openHAB version: 2.4

Unless something has changed, you need to have a String Item mode Item and you have a Number Item. That’s the only thing I see that’s different from mine.

Thanks I will try that today when I get a minute.

In the openhab Google assistant documentation it show number :frowning:

Change the Number of LoungeHeater_Temp by String , and change homekit:HeatingCoolingMode by HeatingCoolingMode, you will can change temperature, but there is a bug from several months (heat mode don’t work) and I think always no solution… the post or we talked about this problem was closed, so I deduce …

Thanks I’ll try that.

I haven’t tried either suggested solution yet. Will try this weekend.
But I actually disabled that line and I am able to change Target temp… And created a another config line as switch outlet to turn on and off heater. So technically I can turn on and off heaters and control temp with Google Assistant. But would prefer it worked as designed. If I have same result as you. I could just add a rule to say if Target temp changed then turn on heater. Then it would work as it should I guess.

Weird documentation says set as number.

Rich… Are you using a Google Nest Hub? (or Max) and have the heating mode working?
I have found heating mode works fine in the Google Home app. But in the Hub or Max, its not working. I have no idea if this is a country-based issue, as it would be a Google issue then.

I have a Google Nest Hub (formally just Google Hub). It works for heating but I have a Nest Thermostat and it interact with it directly, not through openHAB. I have a replacement coming bu the end of October.

I have some fake thermostats that I set up so I can ask what the temp and humidity are in some rooms that have their own sensors. It worked the last time I tried it but that was some time ago.

It´s pretty weird to be honest. But I believe it´s an Google issue:
This is a sccrenshot of one of my thermostats using the the Google Home app, which works just fine:

And this is the exact same thermostat on the Google Nest Hub.

Text says “The current state is not supported.”.

It seem no one can really answer whats going on…

This is my items setup for this thermostat (it´s actually a combination of a temperature sensor, temperature setpoint and the actuator).

Group     g_aktivitet_TSTAT          "Aktivitet Thermostat"                                                                                                                      [ "Thermostat" ]
Number    aktivitet_Temperature      "Aktivitetsrum Temperatur [%.1f °C]"                                      <cu_heating>    (g_aktivitet_TSTAT,Temperatur,gTvaer,gSugeTemp)   [ "CurrentTemperature" ]  { channel="ihc:controller:elko:aktivitet_temperatur_fb" }
Number    aktivitet_Tempsetpunkt     "Aktivitetsrum Temperature setpunkt [%.1f °C]"                            <temperature>   (g_aktivitet_TSTAT)                               [ "TargetTemperature" ]   { channel="ihc:controller:elko:aktivitet_temperaturSet_fb", autoupdate="false" }
Switch    telestat6_aktivitet        "Aktivitetsrum Telestat [%s]"                                             <cu_switch>     (g_aktivitet_TSTAT,gTelestat)                                               { channel="ihc:controller:elko:aktivitet_telestat" }

Just to know Kim , differents modes work on your google home app ? or just heat and stop who don’t work ?

EDIT - Sorry I misread you post…
Its all temperature and heating modes which doesnt work on the Google Nest Hub. In fact, I just tested… It seem to be a problem with a plain temperature sensor and the CurrentTemperature tag… Its the same, it doesnt work on the Google Nest Hub.