Google assistant not working


(Eskil Reiremo) #1

Hi I have been using openHAB with Google home for about a week, and it has been working, but now it stopped working. When I tell it to “turn on/off (device name)” it just says “I don’t know what (device name) you want to turn on/off”. Just using the app with openHAB works tho.
I have tried resetting the Google home, rebooting openHAB and my router and also unlinking and linking openHAB again. The same happens with the assistant on my phone.
Do anyone know what this can be?

BTW I did not know what topic to set, should I change it?

Thanks for all help


(B K) #2

Have you tried telling Google to “Sync my devices” yet? Also, are your items exposed (tagged with “Switchable”, “Lighting”, etc…)?


(Eskil Reiremo) #3

Yes I have, and I use the tags


(Kim Andersen) #4

Thats is the wrong way of doing it.
You should NOT use “item name”. You should use whatever name represented in Google Assistant setup, or you could choose to give the device a new name inside Google Assistant, (I think it´s “calling name”, at least thats what it is in the danish version).

Ie, if you name your device “LampX”, then you just say, “Hey Google, turn on/off LampX”. And Google Assistant will turn on/off the item you have linked to LampX.

I use name calling, and it works pretty good almost 99% of the time. When it doesnt work, its because Google have not heard exactly what I said, Then it should be wrong.


(Eskil Reiremo) #5

that is what i mean about the item name. sorry if that was unclear


(B K) #6

Are your item labels (the “name” in quotation marks) possibly too generic? I find that if i have have to items with names that are too close to each other, Google will sometimes tell me the same “I don’t know which ____ you want to turn off”. Try making something very unique in the label, and then sync your devices and try operating it again…

Also, take a look at your Google Home app on your phone, and see what Google is actually hearing you say…


(Kim Andersen) #7

I just used it (2 seconds) here, and it works just fine.
I use a Google Home device, as well as Google Assistant on my phone, and Android Auto in my car. They all works for voice commands to openhab.
(note to @rlkoshak - The Danish Google Assistant DO work between all google assistants now, including Android Auto. Now I can open my garagedoor from my car using voice command. I would never have thought about that if you havn´t mentioned it a few days ago! :+1: ).


(Eskil Reiremo) #8

these are the tagged items

(Blurred MAC on purpose)

Color LedStripEskilColor "RGB" [ "Lighting" ]

Switch LedStripKjokken "Ledlist Kjøkkenbord" [ "Lighting" ]

Switch PCSkrivebord "My Computer" [ "Switchable" ]     {wol= "192.168.2.255#XX:XX:XX:XX:XX:XX", autoupdate= "false"} 

Switch PluggEskil "Panelovn" [ "Switchable" ]

Switch SecuritySystem "Alarm Anlegg" [ "Switchable" ]

(Eskil Reiremo) #9

Ok, so everything worked yesterday with the configuration i use now, and with the same names


(B K) #10

Ok, so the configuration looks good, how about when you log into your myopenhab.org account, click on your account name and “Applications”…do you still see Google listed there?


(Eskil Reiremo) #11

yes, “i can controll openhab via the app tho”


(B K) #12

Then I really can only recommend looking at your Google Home app and seeing what Google is understanding when you say the item name. Other than that - it might be a local outage where you’re located (mine definitely is working, as is @Kim_Andersen 's


(B K) #13

BTW, do you already have the newest Google Home app, with manual control (i.e. the one that shows switches and looks like this?

If so, see if you can use the manual switch control to turn your devices on and off (that way, we’ll know whether your link to myopenhab is working).


(Eskil Reiremo) #14

@bartus yes i am


(Eskil Reiremo) #15

this is what shows up in myactivity.google.com

com.google.homeautomation
Sorry, I’m not sure which security system you’d like to turn on.
OK, turning the Security System on.
You got it, turning the Security System on.


(B K) #16

So, did you actually say “Security System” or “Alarm Anlegg”? (Your item label)


(Kim Andersen) #17

It could be Google messing around. Based on your items labels it looks like your in scandinavia somewhere… . A week ago we had a simular situation here in Denmark, nothing worked, but day before everything worked, and the day after it was working again. Using the app worked fine though.
Perhaps just give it a few hours and try again. Google Assistant in our native language is pretty new. (since 24 october).


(Eskil Reiremo) #18

I changed the name in the home app to security system


(Kim Andersen) #19

This is why I recommend name calling in Google Assistant insted. It works!.


(Eskil Reiremo) #20

Ok, I am living in Norway that makes sense. Guess I’ll just have to buy a VPN and pretend to be American then XD