Google Assistent + Chromecast + HLS Video Stream

I dont think its a Google problem in your case… I think it might be another issue, maybe ffmpeg setting…
You should try the direct link to PlayStream. Then you´ll know if its a format issue.

That will break chromecast.

Unfortunately not

here the ffmpeg setting used:

ffmpeg -rtsp_transport tcp -i rtsp://<>:554/user=admin_password=<password>_channel=1_stream=0.sdp?real_stream \
    -preset veryfast -g 25 -sc_threshold 0   \
    -acodec aac \
    -vcodec h264 \
    -hls_list_size 4 \
    -hls_flags delete_segments \
    -hls_time 2 \
    -flags -global_header \

still the same image on Chromecast :triumph:

i did open the FFMPEG streamfile in VLC and Rendered to Chromecast…guess what…not Working

Did you try the PlayStream link?
I´m very possitive this is a camera/ffmpeg issue somehow.

what do you mean with Playstream link?

Search for PlayStream here on the forum, you´ll see lots of examples of how to stream to a chromecast device directly from a switch/rule etc…
As mentioned earlier, I havn´t tried with the hls stream yet, but I have tried with other formats (mp3 etc). I assume if you send the link of the .m3u8 is would be the same.

If it works,I believe its a good way to test the format.
You probably need to start the demuxing from ffmpeg manually somehow.

I will give it a try later and report back

As an experiment try 10 second or higher segments.

nothing changed, only the delay from live to stream raised with up to 10sec

Just tested with:

Switch Kamera_Stream "Stream"
rule "Kamera Stream An"
	Item Kamera_Stream changed to ON   
	sendBroadcastNotification("Stream Started")
rule "Kamera Stream Aus"
	Item Kamera_Stream changed to OFF   
	sendBroadcastNotification("Stream Stopped")

and got this showing on my chromecast

apparently something with the stream is wrong so my Chromecast V3 can’t handle it.

But what is wrong?

Here again FFMPEG output:

Output #0, hls, to 'einfahrt.m3u8':
title           : RTSP Session
encoder         : Lavf58.29.100
Stream #0:0: Video: h264 (libx264), yuv420p, 1920x1080, q=-1--1, 25 fps, 90k tbn, 25 tbc
  encoder         : Lavc58.54.100 libx264
Side data:
  cpb: bitrate max/min/avg: 0/0/0 buffer size: 0 vbv_delay: -1
Stream #0:1: Audio: aac (LC), 8000 Hz, mono, fltp, 48 kb/s
  encoder         : Lavc58.54.100 aac

I just noticed in your rule, that you have written


Why IP From Camera?? Shouldnt this be IP from your server?? (Zoneminder probably).

I’ve tried with both. On Zoneminder I don’t have audio stream. As I thought Chromecast needs audio for the HLS stream to work I’m testing it with direct stream from camera till I figure it out why Chromecast won’t show me the stream.

1 Like

But you cant use that direct url to the ip of your camera, since the m3u8 file doesnt exsist on your camera. It wont work only your camera has an url to the hls stream, which I highly doubt.

You dont need audio in zoneminder. You need to tell ffmpeg the rtsp steam of your camera (the rtsp url). And then let ffmpeg demux the stream to HLS, including audio.
I´m not into ffmpeg that much… But I wonder if it shouldnt be possible to run ffmpeg from commandline, and provide it with the rtsp url, as well as the output… Simply wihtout using any other programs.
Maybe Matt knows this abit more.

Sorry …misunderstood something. The m3u8 file is created on the server with zoneminder with ffmeg. Ffmpeg is using the stream from camera, not from Zoneminder.

Ffmpeg is running separately from Zoneminder in a terminal window.

(My English is a bit rusty)

So this is the IP of Zoneminder (server), and not the camera, correct?



Okay, we´re back on track then :smiley:

Which camera are you using? I wonder if there could be some issue with the format, and then ffmpeg cant deal with it.

It’s a cheap ONVIF China cam with PTZ for approximately 40€. But does his job. I also have other cameras in the house, I don’t think it will be a camera issue…so long the stream created with ffmpeg is working on VLC and browser

Something like that

You´re right… Hmm…

When looking at the screen you get on your chromecast, it looks like your chromecast cant reach the m3u8 file… Could it be an WiFi or firewall issue somewhere?

Not that I am aware of.

Firewall…don’t know and guess not as long the stream can be accessed from other pc, laptop or phone in same network(I’m still a beginner in linux)
Wifi… definitely not (stream anything else from pc, laptop, phone to Chromecast works well)

I will try to sent the stream link to my LG webos TV and see if the TV is showing the stream.

I just played abit more with my settings, and suddenly I cant stream to my Chromecast either (get the same respons you get). I moved my settings back, bit still I can no longer get the stream to work for my Chromecast.
Streaming to other devices (Home Hub) works fine.