Google home/ assistant wont link

I want to leave it here for others with same problems.
My problem was solved simply resetting rasp. Why is openhabian so unstable on my setup. Should I make raspberry restart weekly? could it help?

-------------------------- original problem -----------------------------


I have openhabian on raspberry and I am pretty experienced using it. It is my first time I have to post here, in the past the great documentation and other posts have helped, not this time.

I have been using Google home speaker, phillips Hue and openhabian to control lights, wallsockets and self made arduino IoT devices on daily basis in my digital workshop during year 2019. Setup is quite easy and system has been working ok. Sometimes home speaker answers “Sorry I couldn’t reach openhab” but repeating command usually works. If not then unlinking the openhab from google home app and linking again (this could take several tries) would fix it.

This time I came from a month holiday and tried to turn light on with voice command as I’ve done daily. Home speaker thinks(rolls leds) but wont answer anything. Not “Sorry I couldn’t reach openhab” or “Ok turning on 20 lights”. After thinking for about 20s light will turn off.

So I unlinked my openhab from Home app again and it will not link back again! Nothing works. These are the steps I have done:
-Deleted all the items (item files and items from paper ui)
-Deleted items from cloud
-Deleted my room and home app and reinstalled
-Reset (poweroff) my raspberry and home speaker

This problem almost always is caused by problems on the servers. Particularly when it is intermittent.

I do know that there were some issues with yesterday.

I can’t say whether the reset actually fixed something or it just so happened to coincide with changes made on the servers to address their problem.

If you experience the same problem again and the same fix works, please gather logs from your OH instance and post them and maybe we can find the source of the problem.

I also had this happening to me yesterday, so I’m inclined to think it’s a myopenhab/Google Assistant issue. I’ll sometimes get the “couldn’t reach openhab” response even though the item/rule has clearly been triggered by Google Assistant (including last night).

On one of the many “is myopenhab down” threads, there was a discussion about restarting the cloud connector, and I wonder if that’s what solved your problem. Restarting the RPi obviously restarts the connector. Others have mentioned using Karaf to stop/start the service.

Personally, I find it easiest to go into Paper UI > Configuration > Services and edit the openHAB Cloud configuration. When you save your edit, OH will automatically stop/start the connector.