[Google Home] Suddenly all devices became unavailable

Today when I was trying to disarm alarm system via “Goodmornig” rule, Google said that devices are unavailable. Despite that Assistant had disarm my alarm. When later I said to Google “sync devices” all devices had gone.

Is there some global problems with cloud now or it’s only my issue?

PS Could it be related witch adding Alexa (to openhab cloud) to work simultaneously with Google (I assumed that it’s possible).

I have the same problem. OpenHAB had become unlinked to Google Home. I’ve tried to re-add it and it goes through the motions, says that it’s been added, but it hasn’t. I’m guessing that it’s a Google problem, rather than the OH side.

Where You can see this? In Google Home App in “Linked services”? In my case I can see it’s linked there, but it shows only 2 devices (there should be several dozen of them).

Unlinking Alexa changed nothing. Relinking Google changes nothing.

Strange is that Alexa (after relink) still can see all of my devices correctly.

In the Google app, no OpenHAB devices are shown, and if you ask Google assistant to ‘re-sync’ she isn’t aware of any OpenHab devices.

In my case I can see 2 of them, and these are groups:
Group g_Klimatyzator1 “Air Condition in livingroom” { ga=“Thermostat” [ thermostatTemperatureRange=“17,30”, modes=“cool=Cool,fan-only=Fan-only,dry=Dry,auto=Auto,off=Off” ] }
Group g_Klimatyzator2 “Air Condition on first floor” { ga=“Thermostat” [ thermostatTemperatureRange=“17,30”, modes=“cool=Cool,fan-only=Fan-only,dry=Dry,auto=Auto,off=Off” ] }

The remaining several dozen are gone.

Since when you have this problem?

I’m on OH 2.5… Is there any chance that Google API had been changed and my OH is no more compatible?

I first noticed last night, when I tried to turn the TV off. I too am on OH2.5 … perhaps you are correct.

Is there any way to verify/confirm this?

The Google assistant integration has been updated, and no longer supports the TAG solution. You will have to add metadata to the items/groups you will expose to google home, and redo all the linking.

I don’t even get OpenHab listed as a connected device, and all of my items have been exposed through tags for years. When did this change happen, and is it documented?

@sjef86 You are spot on … Items now need to be tagged with e.g. { ga="Switch" }. Now I just need to plough through my items, and update them all :frowning:

Could someone point some doc’s describing how to acheive this for now?

Now can see how in big steps upgrade to 3.0 is comming inexorably. I’m already terrified about the work with number of items (“multi-platform/technology” system and their specific) that I will have to reconfigure from scratch and . :open_mouth: - Referring to that, any know-how to go through this process painlessly (Openhab on docker)?

Item tagging in OpenHAB

Can somebody help me with the syntax please, as I’m struggling with my Z-wave items. How do I add the metadata to an item that has the channel information in it e.g.

Switch E_XmasTree "Christmas Tree" <switch> ["Switchable"] {channel="zwave:device:37789533:node8:switch_binary"}

Wherever I place the google tag I get an error when parsing the file.

Like this (one of items from my config):

Switch Exec_PS4_Wake "Exec - Budzenie PS4" (LastState) { expire="1s,command=OFF", channel="exec:command:b859e445:run"}

So in your case as I assume:

Switch E_XmasTree "Christmas Tree" <icon> (group) { ga="Switch", channel="zwave:device:37789533:node8:switch_binary" }

PS [“Switchable”] is obsolete.

Use a comma within the brackets to separate out metadata.

{channel="zwave:device:37789533:node8:switch_binary", ga="Switch"}

@rpwong Spot on! Thanks :slight_smile: