Govee / Dreamcoulour LED Strips

hi would love to try give Binding can I have the url thanks

Are you on 4.1 already? The binding is only compatible with 4.1. Which device are you using? Please provide the Artikel Number starting with H…? Does ist support LAN-API in the Wifi-Settings?

I’m on openhab 4.0.4 and using h6054 dreamview

There are about 50 Govee devices that supported the Govee LAN-API but it seems this one isn’t - all other devices can only be controlled via the internet which I haven’t implemented (yet :thinking:)

Check if you have the following setting available in the app:

just checked lan control is not on there

Is it not on or is it not available? If it is there, try to switch it on.

just try that does not show up

Unfortunately then it is not supported at the moment as Govee hasn’t provided that API for that device.

is the tv lights H6199 supported with the binding.Have no “Lan control” option available at settings though…

No, unfortunately not as it is missing this option. Please ask Govee to support the LAN-API for that device.

Hello Stefan,
I recently became the owner of the following Govee devices:

Govee Stehleuchte H6076
Govee M1 H61E1
Govee AI H6602

Would you also make your addon available to me?
I am currently using version openHAB 4.1M4.

Thanks in advance
Björn

I have somewhat good news. The official binding is in its last phases, hopefully to become official with the 4.1 release. I can though send you the latest version via PM but eventually please use the final one.

Is the last one the sync box? This one isn’t supported as it is not a light, is it?

1 Like

:+1:

1 Like

I can announce that the latest Govee Neon Rope Light 2 (H61D5-301DE) is fully supported with the Govee Binding.

and currently they even sent me a voucher (at least I was informed as I have other devices as well) for a 35 Euro Discount on Amazon.

1 Like

Hello Stefan,

I’m currently testing your Govee binding (LAN API) as a replacement for my python mqtt implementation :slight_smile:

So far the control works, but I have the following problems. Maybe you can help me with that:

  • The binding documentation says to specify the “deviceType”. However, I have not found a way to do this in the GUI? It also works without this specification…

  • The current status of the lamps is not read out! I can control the lamps, but when I make a change via the Govee app, it is not applied correctly…

  • Could you add the new H60A1?

I use a H6072 and the new H60A1.
At the moment, the new H60A1 is not yet displaying the correct values via LAN API, this is known and is being clarified with Govee…

Thanks :slight_smile:

Let’s start with the configuration:

The thing type can only be found in the thing properties section and is automatically read from the device when it is being detected.

I checked the configuration and I remember there was a lot of back and forth during development and finally I was asked to drop the device type, hence the documentation is wrong. This is what you can configure:

	<config-description uri="thing-type:govee:govee-light">
		<parameter name="hostname" type="text" required="true">
			<context>network-address</context>
			<label>Hostname/IP Address</label>
			<description>Hostname or IP address of the device</description>
		</parameter>
		<parameter name="macAddress" type="text" required="true">
			<label>MAC Address</label>
			<description>MAC Address of the device</description>
		</parameter>
		<parameter name="refreshInterval" type="integer" unit="s">
			<label>Light Refresh Interval</label>
			<description>The amount of time that passes until the device is refreshed (in seconds)</description>
			<default>2</default>
		</parameter>
	</config-description>

I will update the documentation regarding this ^.

You cannot add the device type yourself via the thing file (note that this is information only anyway and the binding does not make any decisions based on that).

Did you actually scan the thing H60A0 and add it via the inbox or configure it via a things file? If the latter, do you mind scanning the thing and adding it via the inbox and see if it does make a difference?

Can you confirm that the H6072 is working correctly because than I will mark that accordingly in the docs.

Note that I requested an updated list of wifi-supported devices from Govee several times but the always told “it will come soon”, though now looking at it they seem to have updated the documentation, so I have to compare it to know devices of the binding (unfortunately the way their documentation is done, it makes it very tedious to do). The latest list at least I know does not mention your device H60A1. It does mention though the H60A0 which probably is the predecessor which is not available anymore.

Thanks for your answer!

One thing at a time… :slight_smile:

When I try to run a scan, I get the following error:

2024-06-10 10:03:23.971 [DEBUG] [govee.internal.GoveeDiscoveryService] - starting Scan
2024-06-10 10:03:23.972 [DEBUG] [govee.internal.GoveeDiscoveryService] - Discovering Govee devices on name:ens18 (ens18) ...
2024-06-10 10:03:23.973 [WARN ] [.govee.internal.CommunicationManager] - exception when receiving status packet
java.net.SocketException: Socket closed
	at sun.nio.ch.DatagramSocketAdaptor.receive(DatagramSocketAdaptor.java:252) ~[?:?]
	at java.net.DatagramSocket.receive(DatagramSocket.java:700) ~[?:?]
	at org.openhab.binding.govee.internal.CommunicationManager$StatusReceiver.run(CommunicationManager.java:202) [bundleFile:?]
Caused by: java.nio.channels.AsynchronousCloseException
	at sun.nio.ch.DatagramChannelImpl.endRead(DatagramChannelImpl.java:523) ~[?:?]
	at sun.nio.ch.DatagramChannelImpl.trustedBlockingReceive(DatagramChannelImpl.java:677) ~[?:?]
	at sun.nio.ch.DatagramChannelImpl.blockingReceive(DatagramChannelImpl.java:635) ~[?:?]
	at sun.nio.ch.DatagramSocketAdaptor.receive(DatagramSocketAdaptor.java:240) ~[?:?]
	... 2 more
2024-06-10 10:03:23.974 [DEBUG] [govee.internal.GoveeDiscoveryService] - Discovery with IO exception: Invalid argument
2024-06-10 10:03:23.974 [TRACE] [govee.internal.GoveeDiscoveryService] - After try

As I said, both lights can be controlled, I just don’t get a current status back. If the scan works, you can include the H6072 in the documentation, but at the moment I can’t really confirm it… :frowning:

I have also checked that the ports are not blocked.
All devices are in the same LAN, no VLAN, no Docker. openHAB (4.1.3) is running in a vm on Proxmox…

The error reads very similar to this one:
Govee binding - exception when receiving status packet - Off-Topic - openHAB Community