Grafana stopped working

yours is the clean solution, granted just Grafana the rights, correct.
To correct mine, rolling back by ‘chmod -R 744 /var/log/grafana’ is the right way and afterwards to execute yours?

Just execute the chown command with switch -R and then fix the permissions to give owner and group grafana read, write access.

1 Like

Great job so far guys!
Thank you for the support, I learned a lot about Linux today.
I got grafana running again with the following:

sudo mkdir /var/log/grafana
sudo chown -R grafana:grafana /var/log/grafana
sudo systemctl start grafana-server.service

And best thing is I understand what the comands are doing. :wink:

But after a restart of the rpi grafana didnt come up again.
Looking closer I realised that the folder “/var/log/grafana” was gone.
Do I have to make the creation of the folder somehow persistent or am I missing something?

1 Like

Thx! Same issue: installed grafana+influxdb on a virgin system, propper working.
Failed to start service after reboot.

Solved with this approach…

1 Like

do you use openhabian and ZRAM ?

I use openhabian. I fixed it with entries in crontab -e knowing, that this is not the cleanest solution. Maybe it will be fixed with upcoming versions ob openhabian.