Habdroid Cloudbees apk


(Dustin Thurston) #1

The wiki states “You can always find current development build on openHAB Cloudbees page: https://openhab.ci.cloudbees.com/job/HABDroid/

However, I’ve tried downloading multiple apks and always get a “Parse error: There was a problem parsing the package”.

Do I need to do something with the apk before installing? Is there a newer working apk than what’s available in the Play Store? Also, there appears to be a wear app, but I can’t find any documentation on it nor am I able to install it on my device.

Nexus 5x 6.0.1, Unknown Sources enabled


(Scott Radner) #2

Certainly happy with the current version (thanks), but always like to try the latest.

I am having the same experience. I just tried build 103, which shows as successful. Android Version 6.0.1 (Build MHC19Q) Marshmallow. No Joy.


(Dan Cunningham) #3

I just got the build working again last night, let me see what’s going on with the output files.


(Dan Cunningham) #4

It just finished a successful build. I was able to install the mobile-debug package using adb. Can you try again? https://openhab.ci.cloudbees.com/job/HABDroid/lastSuccessfulBuild/artifact/mobile/build/outputs/apk/mobile-debug.apk


(Scott Radner) #5

Good news for the debug package.

Using Build 105

mobile-release-unsigned.apk - "Parse error: There was a problem parsing the package"
mobile-debug.apk - Asks for GPS permission then Shows “App not installed”

I then uninstalled the Play Store version

mobile-release-unsigned.apk - "Parse error: There was a problem parsing the package"
mobile-debug.apk - Asks for GPS permission then “App installed”

Hopefully this gives you a lead. And I can poke around the debug version and see how it works.

Thanks for the quick turnaround, always great to work with your code.


(Dan Cunningham) #6

Thanks Scott. Question, were you able to install the mobile-release-unsigned.apk in the past? I thought that all packages needed to be signed before they could be installed.

I don’t think it’s possible to have the debug version overwrite/upgrade the play store version, they both have the same app id, but different certificates, which Android does not allow. But now since you have the debug one installed, future cloudbee builds should just overwrite it (same cert and id). Did this work differently in the past?


(Scott Radner) #7

I was always on the Play Store version, just started looking at the pre-release when I saw the original post. Everything else makes sense, so probably nothing else to do.

Hopefully, this also helps @Dustin_Thurston get up and running with the debug.apk as well.

Cheers


(Hans Hazelius) #8

@digitaldan you are correct, the apk needs to be signed to be installed on the device (even if you allow unknown sources).
The debug build is signed by a debug certificate, so people should be able to install that one (as long as they don’t have a release version installed).

http://developer.android.com/tools/publishing/app-signing.html


(Lolodomo) #9

Hi

Any chance to have soon a new version in the Play Store ?

The version in the store is old (released almost one year ago) and there was apparently important changes recently done, including a bug fix I am waiting for :wink:


(Dustin Thurston) #10

Thanks for the information. I haven’t tried the method described above yet. I second @Lolodomo, will the play store version be updated soon? Does the debug app function any differently? I see that the file size is a little smaller.

I’m also really curious what the wear app is all about. Any details? Is it safe to test?


(Dan Cunningham) #11

The debug version is what we distribute between official builds, other than new features it should not behave differently. I don’t have an ETA on when a new version will get pushed to the play store, but I would expect soon. There are a couple more things that need to get added and some release coordination that has to be done first. But I’m very eager to get something out soon!

I have not tested the wear app, there is a PR that I’m waiting for feedback on that looks like it significantly enhances the wear app, I’m hoping the author is still around and wishes to support it.


(Dustin Thurston) #12

Just to follow up, I was successful installing with the above advice. I couldn’t install the wear app though. I think it may be looking for the play store version of habdroid as a prerequisite, but I can wait for the next release to confirm that.

On another note, I added issue #180 on github, which I think would solve the constant reliability issues I seem to have when using my.openhab service.


(Lolodomo) #13

@digitaldan: still not the time for a new release ?


(Dan Cunningham) #14

I am just working through some certificate issues, hopefully very very soon.


(Dan Cunningham) #15

see openHAB Android (HABDriod) 1.8.0 released


(Elena Gil) #16

This issue can be caused by apk not being completely downloaded or corrupted, the device being incompatible with the application, and so on. There are many ways to solve There is a problem parsing the package, such as enabling application installation from other sources, turning on USB debugging, disabling security software, resetting Android devices to factory settings, and so on.